Ubuntu

Audio fails on Resume from Hibernate & Suspend in Gutsy On Dell

Reported by Kyle M Weller on 2007-09-29
20
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

When I resume from Hibernate/Suspend audio is disabled, volume applet shows / disabled sign:
Linux ion 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
Intel Hyperthread 3.0ghz
768mb RAM
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
lspci:
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:01.0 Modem: Intel Corporation FA82537EP 56K V.92 Data/Fax Modem PCI (rev 04)
01:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 02)

Kyle M Weller (kylew) wrote :

dmesg log output attached

Kyle M Weller (kylew) wrote :

sudo lspci -vvnn > lspci-vvnn.log output attached

Kyle M Weller (kylew) wrote :

also I am running Ubuntu Gutsy Beta

Kyle M Weller (kylew) wrote :

no audio works at all, reboot is needed

What's your lsmod and /etc/modprobe.d/alsa-base?
Is it working after reloading modul snd_hda_intel and related?

Tom Haddon (mthaddon) wrote :

There is a reported workaround here:

http://linux.dell.com/wiki/index.php/Ubuntu_7.10/Issues/Audio_Failure_On_Resume

Although I've tried it and I get the following error:

amixer: Unable to find simple control 'Master',0

"amixer scontrols" reveals:
Simple mixer control 'PCM',0
Simple mixer control 'Front',0
Simple mixer control 'Surround',0
Simple mixer control 'Center',0
Simple mixer control 'LFE',0
Simple mixer control 'Line In as Output',0
Simple mixer control 'Mic as Output',0
Simple mixer control 'Capture',0
Simple mixer control 'Input Source',0

Tom Haddon (mthaddon) wrote :
Tom Haddon (mthaddon) wrote :
Tom Haddon (mthaddon) wrote :

Tried removing the snd_hda_intel module, but got this error:

sudo modprobe -r snd_hda_intel
FATAL: Module snd_hda_intel is in use.

Is there some other way of doing it, or am I missing something?

Changed in dell:
importance: Undecided → Medium
status: New → Confirmed
Tom Haddon (mthaddon) wrote :

Per bug 122025 I've installed the linux-backports-modules-2.6.22-14-generic package. Will test the workaround script.

What system/model is this on?

Tom Haddon (mthaddon) wrote :

I'm using an Inspiron 1420N. The workaround script works once the linux-backports-modules-2.6.22-14-generic package is installed.

Hi Tom,

Can you confirm if this issue still exists in the Hardy Alpha releases? Thanks.

Changed in linux:
status: New → Incomplete

We'll keep this report open against the actively developed kernel however will be closing against the 2.6.22 kernels as this does not meet the criteria for an SRU. Thanks.

Changed in linux-source-2.6.22:
status: New → Won't Fix
Changed in linux-ubuntu-modules-2.6.22:
status: New → Won't Fix
Tom Haddon (mthaddon) wrote :

Tried Hardy i386 Alpha 4 and sound doesn't work at all, so not really applicable as to whether it fails on resume from hibernate or suspend.

Tom:

Have you tried Hardy 4 with latest updates (as of 2/13)? ALSA was updated to 1.0.16 last weekend. I just tried it today on a 1420 and no longer have a problem with sound after suspend/hibernate. No workarounds needed.

Tom Haddon (mthaddon) wrote :

I haven't. Was trying with a stock Alpha 4 install without any updates. Will try again with updates when I get a chance.

Thanks, Tom

Marking this as Won't Fix for dell project, since there is an acceptable workaround for this issue on Gutsy. Fixed on Hardy.

Changed in dell:
status: Confirmed → Won't Fix

Kyle, since you are the original bug reporter, care to comment if this is still an issue for you with the latest Hardy Alpha release and updates applied? Thanks.

Saivann Carignan (oxmosys) wrote :

With Dell Vostro 200 with Hardy Final Release, there is no sound after resume. Gnome mixer applets shows that sound is working but there's no sounds when playing a audio file or testing audio system. Rebooting seems to be the only solution.

00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 02)

Irene Balogun (irenebalogun) wrote :

I have a 1525N and it appears to have shipped with the mentioned workarounds already included (both the 99-restore-volume.sh script and the linux-backports-modules-2.6.22-14-generic). However, I still have this issue on return from Hibernate. Return from suspend is so messed up that I can't even get far enough to tell if it is happening there.

zwa (ulpianosonsi) wrote :

Hardy final release: Sound does not work after resume!

I attached some logs.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Saivann Carignan (oxmosys) wrote :

In my case, this bug is fixed with latest linux kernel in intrepid 2.6.27-3. I can even suspend while listening music, and it will still work at wakeup.

Changed in linux:
status: Incomplete → Fix Released
Sancho (sancho-sancho) wrote :

I am using ibex 8.10 with kernel 2.6.27-7-generic and the issue remains.
The system is unable to be rebooted after wake-up from suspend and I have to do a power cycle.
I am using old IBM T30.

Saivann Carignan (oxmosys) wrote :

Sancho : You are using a different hardware than initial reporter, therefore the bug you get is another bug. If you don't find a existing bug report that concerns your hardware, you can also open a new bug report with more details. Thanks for your feedback.

Changed in somerville:
importance: Undecided → Medium
status: New → Won't Fix
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306159

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers