BUG: unable to handle kernel NULL pointer dereference at virtual address 0000013c

Bug #145770 reported by Marco on 2007-09-27
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

During a test of Gutsy Beta Desktop CD, the windows decoration disappear (title of windows and buttons). I need to restart the decoration with metacity --replace or compiz --replace from shell.

This is an extract of dmesg:
[ 2712.276000] BUG: unable to handle kernel NULL pointer dereference at virtual address 0000013c
[ 2712.276000] printing eip:
[ 2712.276000] c0195183
[ 2712.276000] *pde = 00000000
[ 2712.276000] Oops: 0000 [#1]
[ 2712.276000] SMP
[ 2712.276000] Modules linked in: michael_mic arc4 ecb blkcipher ieee80211_crypt_tkip af_packet ipv6 i915 drm rfcomm l2cap bluetooth ppdev parport_pc lp parport acpi_cpufreq cpufreq_userspace cpufreq_stats cpufreq_powersave cpufreq_ondemand freq_table cpufreq_conservative video sbs container button dock battery ac snd_hda_intel snd_pcm_oss snd_mixer_oss snd_pcm joydev snd_seq_dummy snd_seq_oss ipw3945 snd_seq_midi snd_rawmidi ieee80211 snd_seq_midi_event sdhci ieee80211_crypt mmc_core psmouse serio_raw snd_seq iTCO_wdt iTCO_vendor_support shpchp pci_hotplug intel_agp agpgart snd_timer snd_seq_device snd soundcore snd_page_alloc evdev squashfs sd_mod loop unionfs nls_cp437 isofs sg sr_mod cdrom usbhid hid ata_piix ohci1394 ieee1394 e100 mii ahci ehci_hcd ata_generic libata scsi_mod uhci_hcd usbcore thermal processor fan fuse apparmor commoncap
[ 2712.276000] CPU: 1
[ 2712.276000] EIP: 0060:[<c0195183>] Not tainted VLI
[ 2712.276000] EFLAGS: 00210292 (2.6.22-12-generic #1)
[ 2712.276000] EIP is at touch_atime+0x13/0x120
[ 2712.276000] eax: df0ecb00 ebx: 00000000 ecx: df0ecb00 edx: ddfcef68
[ 2712.276000] esi: d251f4b0 edi: 00000004 ebp: d251f500 esp: c2bffdf4
[ 2712.276000] ds: 007b es: 007b fs: 00d8 gs: 0033 ss: 0068
[ 2712.276000] Process gtk-window-deco (pid: 8592, ti=c2bfe000 task=d20f2f90 task.ti=c2bfe000)
[ 2712.276000] Stack: 00000001 d251f4b0 00000004 e01b2bf5 db79c860 c0eab258 d251f480 d251f4f8
[ 2712.276000] d251f508 d251f500 c10eafa1 00000000 00000000 c10eafa0 c0d953c0 00000000
[ 2712.276000] c10eafa0 00000000 00000003 d251f554 c01654c3 000000d0 c2bffea8 d251f558
[ 2712.276000] Call Trace:
[ 2712.276000] [<e01b2bf5>] unionfs_readpage+0x235/0x3e0 [unionfs]
[ 2712.276000] [<c01654c3>] __do_page_cache_readahead+0x1b3/0x250
[ 2712.276000] [<c01610e5>] filemap_nopage+0x155/0x340
[ 2712.276000] [<c016cd18>] __handle_mm_fault+0x148/0xb00
[ 2712.280000] [<c02f6266>] do_page_fault+0x126/0x690
[ 2712.280000] [<c0140336>] do_gettimeofday+0x36/0x100
[ 2712.280000] [<c02f6140>] do_page_fault+0x0/0x690
[ 2712.280000] [<c02f49c2>] error_code+0x72/0x80
[ 2712.280000] [<c02f0000>] unlink_clip_vcc+0xc0/0x120
[ 2712.280000] =======================
[ 2712.280000] Code: 4a 04 75 d6 85 f6 66 90 75 d6 eb a1 8d b6 00 00 00 00 8d bf 00 00 00 00 83 ec 0c 89 c1 89 1c 24 89 74 24 04 89 7c 24 08 8b 5a 0c <f6> 83 3c 01 00 00 02 0f 85 92 00 00 00 8b bb 98 00 00 00 8b 47
[ 2712.280000] EIP: [<c0195183>] touch_atime+0x13/0x120 SS:ESP 0068:c2bffdf4

Marco (mfj) wrote :
description: updated
description: updated
exactt (giesbert) wrote :

i have a similar problem with the nightly from 09-Oct .

BUG: unable to handle kernel NULL pointer dereference at virtual address 00000000

Yet I get it during boot up and Gutsy won't start. Neither the CD nor an updated version of Gutsy start up....

Thank you for taking the time to report this bug and helping to make Ubuntu better. Now that the 7.10 Gutsy Gibbon release of Ubuntu is out (kernel 2.6.22-14), we were wondering if you can still reproduce this issue. Could you please download and try the new version of Ubuntu from http://www.ubuntu.com/getubuntu/download and report back your results. If the issue is still present in the new release, please attach the following information:

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux-source-2.6.22:
status: New → Incomplete
Marco (mfj) wrote :

I've tried 7.10 Final Release in Live Mode. No more bugs detected.
Thank You

Changed in linux-source-2.6.22:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments