[gutsy] Prism 2.5 Wavelan chipset based wireless doesn't work

Bug #145695 reported by Vladimer Sichinava on 2007-09-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

It's not recorgnised even if I've blacklisted thesse modules:

blacklist hostap
blacklist hostap_pci
blacklist prism2
blacklist prism2pci
blacklist prism2_pci

Vladimer Sichinava (alinux) wrote :
Vladimer Sichinava (alinux) wrote :
Vladimer Sichinava (alinux) wrote :

command: iwconfig:

lo no wireless extensions.

eth0 no wireless extensions.

command: sudo lshw -class network

 *-network:0 UNCLAIMED
       description: Network controller
       product: Prism 2.5 Wavelan chipset
       vendor: Intersil Corporation
       physical id: 9
       bus info: pci@0000:00:09.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=64
  *-network:1
       description: Ethernet interface
       product: DP83815 (MacPhyter) Ethernet Controller
       vendor: National Semiconductor Corporation
       physical id: 12
       bus info: pci@0000:00:12.0
       logical name: eth0
       version: 00
       serial: 00:0b:cd:a8:30:18
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii fibre 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=natsemi driverversion=2.1 duplex=full ip=192.168.1.117 latency=90 link=yes maxlatency=52 mingnt=11 module=natsemi multicast=yes port=twisted pair speed=100MB/s

Changed in network-manager:
assignee: nobody → benc
Vladimer Sichinava (alinux) wrote :

I use:
 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

Changed in network-manager:
assignee: benc → nobody
Alexander Sack (asac) wrote :

why would you blacklist the these modules?

Changed in network-manager:
status: New → Incomplete
Tormod Volden (tormodvolden) wrote :

In Gutsy there is no oricono_pci driver, and I believe the hostap_pci driver should work, bar bug #63989. Please try again without any blacklisting. If it still doesn't work please attach a new dmesg output.

Changed in network-manager:
assignee: nobody → tormodvolden
Scott Peterson (lunchtimemama) wrote :

I am having this same problem. I'd be happy to provide any information I can, if you tell me exactly what to provide and how to get it.

Tormod Volden (tormodvolden) wrote :

Please attach the file /var/log/dmesg

Scott Peterson (lunchtimemama) wrote :
Scott Peterson (lunchtimemama) wrote :

Can I provide any other information?

Tormod Volden (tormodvolden) wrote :

Scott, can you please also run:
 sudo lshw -class network
 sudo iwconfig

Brian Pitts (bpitts) wrote :

Did you try "wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable"? This got a DWL-122 that was otherwise causing trouble for me working. I'm pasting the notes i was making before I discovered this solution for comparison below.

dmesg when i boot the computer with the adapter plugged in
[ 27.169792] prism2usb_init: prism2_usb.o: 0.2.8 Loaded
[ 27.169797] prism2usb_init: dev_info is: prism2_usb
[ 27.170028] usbcore: registered new interface driver prism2_usb
[ 27.668894] ACPI: PCI Interrupt 0000:02:0c.0[A] -> GSI 17 (level, low) -> IRQ 20
[ 28.764511] hfa384x_usbctlx_complete_sync: CTLX[3] error: state(Request failed)
[ 28.764518] prism2sta_getcardinfo: Failed to retrieve NICIDENTITY
[ 28.764522] prism2sta_getcardinfo: Failed, result=-5
[ 28.764525] prism2sta_ifstate: prism2sta_getcardinfo() failed,result=-5

dmesg when i remove and reinsert the adapter
[ 467.163671] usb 1-2: USB disconnect, address 2
[ 475.082610] usb 1-2: new full speed USB device using uhci_hcd and address 3
[ 475.237433] usb 1-2: config 1 has an invalid interface number: 1 but max is 0
[ 475.237440] usb 1-2: config 1 has no interface number 0
[ 475.250540] usb 1-2: configuration #1 chosen from 1 choice
[ 476.647247] hfa384x_usbctlx_complete_sync: CTLX[3] error: state(Request failed)
[ 476.647258] prism2sta_getcardinfo: Failed to retrieve NICIDENTITY
[ 476.647262] prism2sta_getcardinfo: Failed, result=-5
[ 476.647264] prism2sta_ifstate: prism2sta_getcardinfo() failed,result=-5
[ 477.359655] hfa384x_usbin_rx: Received frame on unsupported port=1

dmesg when i remove and reinsert the adapter while the computer is under load (dd if=/dev/urandom of=/dev/null)
[ 743.661436] usb 3-1: USB disconnect, address 3
[ 755.663956] usb 3-1: new full speed USB device using ohci_hcd and address 4
[ 755.867822] usb 3-1: config 1 has an invalid interface number: 1 but max is 0
[ 755.867830] usb 3-1: config 1 has no interface number 0
[ 755.873924] usb 3-1: configuration #1 chosen from 1 choice
[ 757.447770] ident: nic h/w: id=0x8026 1.0.0
[ 757.448765] ident: pri f/w: id=0x15 1.1.0
[ 757.450758] ident: sta f/w: id=0x1f 1.4.2
[ 757.452760] MFI:SUP:role=0x00:id=0x01:var=0x01:b/t=1/1
[ 757.454755] CFI:SUP:role=0x00:id=0x02:var=0x02:b/t=1/1
[ 757.456754] PRI:SUP:role=0x00:id=0x03:var=0x01:b/t=1/3
[ 757.458755] STA:SUP:role=0x00:id=0x04:var=0x01:b/t=1/9
[ 757.460751] PRI-CFI:ACT:role=0x01:id=0x02:var=0x02:b/t=1/1
[ 757.462749] STA-CFI:ACT:role=0x01:id=0x02:var=0x02:b/t=1/1
[ 757.464750] STA-MFI:ACT:role=0x01:id=0x01:var=0x01:b/t=1/1
[ 757.466747] Prism2 card SN: 000000000000
[ 757.898460] linkstatus=DISCONNECTED (unhandled)
[ 757.901024] ADDRCONF(NETDEV_UP): wlan0: link is not ready

Trying to bring the device up results in "SIOCSIFFLAGS: No such device" unless the device was plugged in while under load. Then it works, but if I take it down and try to bring it up again without touching the card the error reappears. iwconfig always returns "no wireless extensions".

Tormod Volden (tormodvolden) wrote :

I'll close this bug since we haven't heard from Vladimer for months. It seems like he blacklisted all possible drivers. Scott has another problem with the hostap_pci driver (seems like missing firmware). Brian's issue is with the prism2_usb driver, which has been improved in this regard in Hardy.

Changed in linux-source-2.6.22:
assignee: tormodvolden → nobody
status: Incomplete → Invalid
Vladimer Sichinava (alinux) wrote :

Ah, it's ok Tormod, thank you!
I'm sorry for the silence... my laptop died definitelly some weeks ago.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers