"Sluggish" behaviour with cx88 remote control

Bug #138380 reported by Adrian Roman on 2007-09-09
6
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using an Winfast TV2000XP Expert tuner card. I configured the remote control to work with lirc, with the dev/input driver. And although it does work, I sometimes have to press a key on the remote control 7 times before it actually does what it was supposed to do. Usually it will do what it's supposed to do after 2 or 3 key presses, but that's still too much.

I used to use Slackware, and recompile the kernel myself. I found that there was a problem in the cx88-input.c file, where if a key release event was received without a prior key press event, nothing would happen. That would typically be ok, except that quite a significant percentage of the events were key release events without a matching key press event. So I patched the file to treat that as a key press and release event, at the same time. Details of the patch can be found here: http://lists-archives.org/video4linux/16875-fwd-cx88-ir-issue.html - that made the remote control work ok, as long as you didn't repeatedly press the same button. That still didn't work ok, and I didn't figure that out yet.

But because I no longer have time to compile stuff from source and troubleshoot little things I am considering switching to Ubuntu or Fedora. Interestingly enough, in Fedora 7, with kernel 2.6.22-65.fc7, the remote control works perfectly fine (as it did in every version of Windows I ever used). I suspect one of the kernel patches they incorporate into the kernel gets the job done, and although I looked through them, I didn't manage to identify exactly which one is responsible for fixing this problem.

So I tried upgrading my Feisty system's kernel to Gutsy's 2.6.22-10 - the upgrade worked ok, but the remote control is still sluggish.

Can anybody have a look at the patches Fedora ships with the kernel, and help patch Ubuntu's kernel as well? I'm suspecting it may be one of the 2 that have "input" in their name, but I couldn't understand what they actually do...

[root@panther SOURCES]# ls -las | grep input
    8 -rw-r--r-- 1 root root 799 2007-08-15 00:06 linux-2.6-input-ff-create-limit-memory.patch
    8 -rw-r--r-- 1 root root 731 2007-07-10 19:14 linux-2.6-input-kill-stupid-messages.patch
[root@panther SOURCES]#

Adrian Roman (adyroman5) wrote :

I assume this would be a kernel source issue...

Adrian Roman (adyroman5) wrote :

Assigning to ubuntu-kernel-team. Can anybody take a look? Thanks.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team

Hi Adrian,

You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you in the 7.10 Gutsy Gibbon release (kernel 2.6.22-14)? Please let us know. Thanks in advance.

Changed in linux-source-2.6.22:
status: New → Incomplete

Hi Leann,

The bug is still applicable for the 7.10 Gutsy Gibbon release, and also for
the latest stable kernel (installed as described here:
http://ubuntuforums.org/showthread.php?t=311158
- Master Kernel Thread).

I also tried to apply all the patches from Fedora's kernel to Ubuntu's, but
unfortunately that didn't work out... I didn't manage to identify what
kernel patch (or set of patches) is responsible for fixing this bug in
Fedora - I would have tried with only that one, and I could have probably
provided you with more specific details on how to fix this issue.

I also discussed this issue with "Nickolay V. Shmyrev"
<email address hidden>which is, as far as I understood, a v4l kernel
developer / maintainer - but
he said he is caught up in other stuff and can't deal with this right now.

As I have told Nickolay, I am willing to pay for a Leadtek TV2000 XP Expert
card for whoever is willing to work towards fixing this issue - so if you
need this card, I can pay for it via PayPal (most convenient for me).

Let me know if I can help with anything.

Adrian

On 12/1/07, Leann Ogasawara <email address hidden> wrote:
>
> Hi Adrian,
>
> You reported this bug a while ago and there hasn't been any activity in
> it recently. We were wondering if this is still an issue for you in the
> 7.10 Gutsy Gibbon release (kernel 2.6.22-14)? Please let us know.
> Thanks in advance.
>
> ** Changed in: linux-source-2.6.22 (Ubuntu)
> Status: New => Incomplete
>
> --
> "Sluggish" behaviour with cx88 remote control
> https://bugs.launchpad.net/bugs/138380
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
DRM 'manages access' in the same way that jail 'manages freedom'.

Hi Adrian,

The Hardy Heron kernel was recently uploaded for testing. It was synced with the mainline 2.6.24-rc3 kernel. I know you tested with the latest stable release of the mainline kernel, but was hoping you'd give the Hardy kernel a quick test. We'd really appreciate if you could just verify this issue still exists in the currently developer Hardy kernel. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2. However, here are the instructions to install (if you choose to do so):

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
status: New → Incomplete

Also just adding a note that this report is remaining open against the actively developed kernel but against linux-source-2.6.22 this bug will be closed as it does not meet the criteria for a stable release update. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: Incomplete → Won't Fix
Adrian Roman (adyroman5) wrote :

Leann,

I managed to perform the test today, and the bug can be reproduced on the
latest development kernel as well.

I went through the numeric keys on the remote control, a couple of times,
from 1 to 9 followed by 0 (so the 10 digit keys). After each round I pressed
enter on the keyboard to separate the test result on the console. Here's a
copy / paste from the console - as you can see, a large percentage of the
keypresses was lost.

"adyroman@littlewillie2:~$ uname -a
Linux littlewillie2 2.6.24-1-generic #1 SMP Fri Dec 7 22:06:49 GMT 2007 i686
GNU/Linux
adyroman@littlewillie2:~$ ps axu | grep ir
root 4 0.0 0.0 0 0 ? S< 23:30 0:00
[ksoftirqd/0]
nobody 4457 0.0 0.1 1892 424 ? Ss 23:31 0:00
/usr/sbin/inputlircd /dev/input/event0 /dev/input/event1 /dev/input/event2
/dev/input/event3 /dev/input/event4 /dev/input/event5
adyroman@littlewillie2:~$ irw
13
25890
89
1267
46
678
adyroman@littlewillie2:~$"

Let me know if I can help with anything else.

Thanks.
Adrian

On Dec 7, 2007 3:00 AM, Leann Ogasawara <email address hidden> wrote:

> Hi Adrian,
>
> The Hardy Heron kernel was recently uploaded for testing. It was synced
> with the mainline 2.6.24-rc3 kernel. I know you tested with the latest
> stable release of the mainline kernel, but was hoping you'd give the
> Hardy kernel a quick test. We'd really appreciate if you could just
> verify this issue still exists in the currently developer Hardy kernel.
> Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older
> 2.6.22 kernel. You'll have to manually install the newer Hardy Heron
> kernel in order to test. This should not be the case for Alpha2.
> However, here are the instructions to install (if you choose to do so):
>
> 1) edit the file /etc/apt/sources.list and add the following line:
>
> deb http://archive.ubuntu.com/ubuntu hardy main restricted
>
> 2) sudo apt-get update
> 3) sudo apt-get install linux-image-2.6.24-1-generic
> 4) reboot and select the new kernel from the grub menu
>
> After you've tested, please feel free to revert back - ie boot into the
> old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove
> the line from /etc/apt/sources.list . Please update this report with
> your results. Thanks in advance!
>
> ** Also affects: linux (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> --
> "Sluggish" behaviour with cx88 remote control
> https://bugs.launchpad.net/bugs/138380
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
DRM 'manages access' in the same way that jail 'manages freedom'.

Thanks Adrian,

Can you please attach the following information:

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies .

You also mentioned this is an issue with the upstream mainline kernel. I'd actually encourage you to also open an upstream kernel bugzilla report. I've witnessed many bugs get resolved very quickly once reported upstream. For more information on how to file an upstream bug report please refer to the "Reporting Bugs Upstream" section of the following wiki: https://wiki.ubuntu.com/KernelTeam/GitKernelBuild .

Thanks again and we appreciate your help and feedback.

Adrian Roman (adyroman5) wrote :
Adrian Roman (adyroman5) wrote :
Adrian Roman (adyroman5) wrote :
Adrian Roman (adyroman5) wrote :

Did everything as requested.

Changed in linux:
status: Unknown → Confirmed
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Confirmed
Changed in linux:
status: Unknown → Confirmed
Adrian Roman (adyroman5) wrote :

As of yesterday, June 22nd 2008, with kernels 2.6.24-19-generic (shipped with Ubuntu 8.04) and 2.6.25.7 (vanilla), the problem is still present.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Adrian Roman (adyroman5) wrote :

On linux kernel 2.6.27-2 shipped with Intreprid Ibex 8.10 Alpha 5 the issue remains. Same on vanilla linux kernel 2.6.26.5.

It's not clear to me if I should open a new bug on this new kernel version, or if that remark was valid only for new (other) issues that I might notice on these newer kernels. If I should open new bugs for the same issue, on the other kernel versions, please confirm and I will do so.

Thanks.
Adrian

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Adrian Roman (adyroman5) wrote :

A patch was submitted for the upstream bug report. I have tested it on 2.6.30-rc7 and it seems to work just fine. The submitter also tested it on 2.6.28 and says it works ok.
See:
http://bugzilla.kernel.org/show_bug.cgi?id=9637
and
http://<email address hidden>/msg05636.html

Changed in linux:
status: Confirmed → Fix Released
Adrian Roman (adyroman5) wrote :

The bug has been fixed and the fix has been incorporated into every version of the kernel since 2.6.32. It can be closed.

Changed in linux:
importance: Unknown → Medium

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.