[Gutsy] Resume fails with kernel 2.6.22-11: ata revalidation failed

Bug #138348 reported by Albert Damen on 2007-09-08
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

Suspend/resume worked fine with kernel 2.6.22-10.
After today's update to kernel 2.6.22-11, resume does not work anymore.

Error messages on the console show ata3.00: revalidation failed and the main file system is mounted read-only.
As the fs is read-only, log files are not written to disk and I could not write anything to a usb disk either.
The network is disabled and could not be restarted, so I couldn't write the logs to a network share.

I made pictures of the screen, hopefully that helps to identify the issue.

Symptoms after resume:
- file system is read-only
- one processor core seems to be at 100% (dual core system)
- Login on tty1-6 was not possible. I could enter my name but was never asked for the password.
- The X screen is still visisble. An empty pop-up was shown in X
- top could not be started to identify the process causing high cpu load (input/output error)
- ps ax works. It looked like gnome-mount was taking a lot of cpu time
- the network was down
- Shut down failed.

A second attempt to use suspend/resume failed with the same problems.
After forced power off the system rebooted normally.
When booting the old kernel, 2.6.22-10, suspend/resume still works fine.

System is daily updated, AMD64.

Albert Damen (albrt) wrote :

uname -a: Linux BTO 2.6.22-11-generic #1 SMP Fri Sep 7 04:31:16 GMT 2007 x86_64 GNU/Linux

Albert Damen (albrt) wrote :
Albert Damen (albrt) wrote :
Albert Damen (albrt) wrote :
Albert Damen (albrt) wrote :

NB: this dmesg does NOT contain messages about the problem, as the FS was read-only when the problem occurred.

Albert Damen (albrt) wrote :

I tried to do the debugging described in https://wiki.ubuntu.com/DebuggingKernelSuspend
Unfortunately dmesg does not contain any lines with "Magic number" or "hash matches".

Sebastian Urban (surban) wrote :

Same problem here.

May be connected with this discussion: http://www.gatago.org/linux/kernel/50612004.html

They suggest to not wait for disk revalidation after resume to fix long delays after resumes. Perhaps the new kernel includes this non-working "solution".

I also have this problem on a dell precision M65.
Hard to give debug information since I can't run programs after resume.

Albert Damen (albrt) wrote :

The issue continues with the new kernel:
Linux BTO 2.6.22-12-generic #1 SMP Sat Sep 22 17:45:57 GMT 2007 x86_64 GNU/Linux

Ludovico Cavedon (cavedon) wrote :

Same problem here, with latest gutsy.
I am attacching dmesg and lspci output

Thanks

Ludovico Cavedon (cavedon) wrote :
Ludovico Cavedon (cavedon) wrote :
Ludovico Cavedon (cavedon) wrote :

This is not happening (i.e. resume is working!) with vanilla 2.6.20 and 2.6.23.rc8

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers