qla1280 module missing

Bug #137911 reported by Jan Gyselinck
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
High
Unassigned
linux-source-2.6.22 (Ubuntu)
Won't Fix
Medium
Unassigned

Bug Description

Binary package hint: linux-image-2.6.22-10-sparc64-smp

On the SPARC64 architecture, the module qla1280.ko is missing in the linux-image package.

Sun used to sell PCI cards with one ethernet (Sun HME) port and one fast-wide SCSI port (Qlogic ISP1020) on the same card. The qla1280 module is needed to use that SCSI interface, I have been able to compile the module by using the source package, and all seems to work.

Can the qla1280.ko module be included by default in the linux-image package on SPARC64? It's included by default on i386, so it would only make sense to do the same thing on SPARC64.

The problem exists at least in these packages:

linux-image-2.6.20-16-sparc64
linux-image-2.6.20-16-sparc64-smp
linux-image-2.6.22-10-sparc64
linux-image-2.6.22-10-sparc64-smp

Tags: bitesize
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Paulo Tanimoto (tanimoto) wrote :

I believe this bug is of utmost importance, because it prevents us from installing any recent Ubuntu release. I've tried Gutsy, Feisty, but could only get the installer to recognize the scsi drives with Dapper (6.06). Dist-upgrading does not work. I'm about to try to compile the module from the source, as suggested by Jan.

Also, the bug is more general than just qla1280. In my case it involves qla2200.

Please let me know what information I can provide. I hope we can fix this before releasing Gutsy.

Changed in linux-source-2.6.22:
status: Triaged → Confirmed
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Looks like CONFIG_SCSI_QLOGIC_1280 is still not set in Gutsy or Hardy for sparc. Reassigning to the kernel team. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: New → Triaged
Changed in linux-source-2.6.22:
status: Confirmed → Triaged
Changed in linux:
assignee: ubuntu-kernel-team → amitk
Revision history for this message
Tim Gardner (timg-tpi) wrote :

Enabled CONFIG_SCSI_QLOGIC_1280=m

Changed in linux:
assignee: amitk → ubuntu-kernel-team
milestone: none → hardy-alpha-4
status: Triaged → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

This module is present in linux-image-2.6.24-5-sparc64 2.6.24-5.8 in hardy.

Changed in linux:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.22:
status: Triaged → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers