Ubuntu

[gutsy] [regression] suspend-to-ram: resume is blocked on a blinking cursor until some random keystrokes are entered - removing "processor" module makes it work

Reported by Vincenzo Ciancia on 2007-09-05
10
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Steve Langasek
linux (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Steve Langasek
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Declined for Hardy by Steve Langasek

Bug Description

Binary package hint: acpi-support

I am using gutsy tribe 5. Suspend to ram worked like a charm in feisty, but now it suspends quickly, then resume and stay blocked in console with a blinking cursor and the word "Linu" in yellow (which used to appear for a few seconds in feisty, too). It stays there until I press some keys at random. Let me know how to provide more information in case you need those.

Removing the "processor" module causes it to work. Also, suspending and then inserting the "processor" module makes the system visibly slow down.

teedog (teedog) wrote :

I have a more serious issue, but it seems related to this so I'm not creating a new report.

Suspend and hibernate work fine for me as well (except for a ton of messages flashing across my console before the screen goes black). However, when I try to resume after a suspend, my laptop is frozen with a black screen, not even a cursor. The same thing happens if I boot up after a hibernation.

My laptop is a Dell Inspiron 8600.

Is this bug related?
https://bugs.launchpad.net/ubuntu/+bug/137738

teedog (teedog) wrote :

Steps to reproduce my problem:
1. Suspend
2. Resume (on my laptop that's hitting the power button)
3. Profit, I mean, black screen of death

Vincenzo Ciancia (vincenzo-ml) wrote :

I can also add that system is slowed down after resume from suspend-to-ram, just like some broken hardware device was polled, or like under heavy cpu load. However "top" does not report any anomalous system load.

Vincenzo Ciancia (vincenzo-ml) wrote :

I have discovered that the problem is in the "processor" module, which is needed for acpi_cpufreq. Removing that module makes suspend-to-ram work fine. If I insert that module after suspend-to-ram, system gets very slow. If I remove the module, system works normally. It reminds me problems of interrupts but I don't know.

Vincenzo Ciancia (vincenzo-ml) wrote :

Last kernel upload (2.6.22-12-generic) should solve suspend/resume problems for many toshiba laptops, however this problem is still there, just for reference.

Tim Potter (musikgoat) wrote :

I would like to note that I too have this bug with a Toshiba A105-S4004 laptop with intel chipset. I am able to get past the locked up blackscreen by pressing my arrow keys some amount of time, (upwards of 10-20 keystrokes) before getting past the blank black screen. then I will usually need to move my mouse to get the login prompt.

Vincenzo Ciancia (vincenzo-ml) wrote :

Tim: please try to remove the "processor" module and see if this makes the laptop suspend fine.

You will have to remove thermal and acpi_cpufreq, for that. Just in case you don't know, the relevant commands should be (but please report any failure)

sudo rmmod thermal
sudo rmmod acpi_cpufreq
sudo rmmod processor

If you get some "module is in use by OTHER_MODULE", theno do sudo rmmod OTHER_MODULE as well.

Tim Potter (musikgoat) wrote :

Oh, I had blacklisted processor, that would not remove the kernel mods though i guess.

attached was my modified dmesg output. (I added some relevant key stroke times)

After that test, (unsuccessful) i saw your message and tried removing the 3 modules, and didn't get any bad output. I also removed processor from the blacklist.

I added that as dmesg attachment

That test was also unsuccessful. I recieved the same yellow Linu and a flashing cursor. the arbitrary number of key strokes still brings it out of that mode, and the screen will become active after moving the mouse.

It could have something to do with my toshiba satellite A105-S4004 laptop though. I will look for BIOS updates as well.

Vincenzo Ciancia (vincenzo-ml) wrote :

If in feisty it worked, don't update the bios or we will loose a test case for the regression :) Just to be sure, can you remove module "processor", then lsmod, and then suspend to ram? Just in case for some reason the module stays there.

Tim Potter (musikgoat) wrote :
Download full text (7.7 KiB)

Hehe, sorry, I missed that post... I updated my BIOS but the regression is still there, however... the bios fixed my usb power surge errors that I knew would be fixed eventually.

one more dmesg just in case it helps.

I updated from v 5.10 to 5.90
http://www.csd.toshiba.com/cgi-bin/tais/su/su_sc_dtlViewDL.jsp?soid=1795538&moid=1310946&rpn=PSAA8U&BV_
[quote]
Change History

      Version 5.90 07-06-2007
          o Added: 4GB USB Memory boot support.
          o Added: Battery critical wake up" at 5% enable/disable function.
          o Added: When the battery capacity <= 5% in DC mode during BIOS Setup, the Critical Battery Wakeup item will be enabled to wake the computer from standby.
          o Updated: Intel Microcode for 6F6h, 6F2h, and 10061h CPUs to address errata AH3.
          o Added: Merom-Lite Celeron CPU support.
          o Corrected: "TBX error" and "auto password prompt pop-ups" that occur if CMOS data becomes corrupt.
          o Corrected: The Wireless LAN LED/function does not correlate with the latest kill switch status after waking from Standby (S3), Hibernation (S4), or Soft Off (S5) states.
          o Added: Kill-Switch On/Off events to correct "Wireless LAN can not maintain the correct state" after waking from S3/S4/S5.

      Version 5.60 03-15-2007
          o Corrected: Audio Line-In function appears without being docked.
          o Updated: Execute Disable (XD) function.
          o Updated: Virtualization Technology function
          o Corrected: Computer hangs when closing the top cover during a restart (DOS or POST) with Yonah Celeron CPUs. (Debug code "69")
          o Added: NVIF interface for nVidia systems.
          o Added: ATIF interface for ATI systems.
          o Corrected: USB errors occurred on XP Main Boards with a Vista BIOS after waking from a Suspend state.
          o The pre-charge current was changed from 128mA to 256mA to correct rare occurrences of battery recharge failures.
          o Notes: BIOS version 5.10 (and higher) can be used with Windows XP & Vista. BIOS versions 2.20 (and lower) can not be used with Windows Vista. Once the BIOS is updated to V5.10 (or higher), it will not be possible to downgrade back to V2.20 (or lower).

      Version 5.50 03-07-2007
          o Updated the T2060 CPU (CPU ID=6EC) microcode from version 59h to 5Bh.
          o Added support for the G781-1 Thermal sensor IC.
          o Notes: BIOS version 5.10 (and higher) can be used with Windows XP & Vista. BIOS version 2.20 (and lower) can not be used with Windows Vista. Once the BIOS is updated to V5.10 (or higher), it will not be possible to downgrade back to V2.20 (or lower).

      Version 5.20 01-30-2007
          o Corrected: Audio Line In does not function when docked.
          o Notes: BIOS version 5.10 (and higher) can be used with Windows XP & Vista. BIOS version 2.20 (and lower) can not be used with Windows Vista. Once the BIOS is updated to V5.10 (or higher), it will not be possible to downgrade back to V2.20 (or lower).
[/quote]

So your suggestion worked. I believe that after rmmod the first time, i rebooted as I had the false impression that this was something that need...

Read more...

Vincenzo Ciancia (vincenzo-ml) wrote :

So, let's underline it since you didn't explicitly state it in your comment, _removing_ processor module fixes the problem, right? If so, could you please mak the bug as confirmed?

description: updated
Tim Potter (musikgoat) wrote :

I have confirmed that removing the processor (and dependent) modules fixes the issue, and modprobing the module causes the bug again.

Changed in linux-source-2.6.22:
status: New → Confirmed
Matthew Garrett (mjg59) on 2007-10-07
Changed in acpi-support:
status: New → Invalid
Zachary Waldowski (zwaldowski) wrote :

I can confirm this regression on my Compaq Presario V5204NR laptop.

Id2ndR (id2ndr) wrote :

Same trouble with a Toshiba Satellite U200 (gutsy).
Removing processor (and related module), as explain in comment 7, work well.

Otherwise, I got the yellow "linu" on the screen. After moving the mouse, a led show me hd activity. After moving the mouse a second time, "linu" disappear and is quickly replace by output related to usb, and then lock screen appear.

What the trouble with processor module ? And how do you find that it was related to this ?

Vincenzo Ciancia (vincenzo-ml) wrote :

I don't know what the trouble is, since I discovered this just by removing all the modules (first using "killall5" from a console, then removing all the modules with some lsmod/grep trickery, then using the command pm-suspend from the pm-utils package). Then, by removing half of the modules each time, I discovered the culprit in logarithmic time using the well-known bisection debug technique :)

marcw (marcw) wrote :

I can confirm this problem (yellow Linu when attempting resume) and solution (rmmod processor) on my Compaq v5209us with Intel video chipset.

Hi Vincenzo,

The Hardy Heron 2.6.24 kernel was recently released. Can you try installing this newer kernel and verify if this issue still exists? Please report back your results. Thanks!

Changed in linux:
status: New → Incomplete
Vincenzo Ciancia (vincenzo-ml) wrote :

My laptop is still without power charger (but I hope to get it repaired in the next days) however I can already ask a question: is suspend/resume supported from the livecd? Maybe one should just "swapon" the swap partition on the hard drive. Or else we should install hardy on our laptops - or maybe you could provide a gutsy package for the kernel (?)

Hi Vincenzo,

Suspend to RAM should be supported by the LiveCD. However, the Alpha1 ISO was packaged with the 2.6.22 kernel so it will give you the same issue that you are seeing. To test the hardy kernel on your machine please do the following:

1) edit your /etc/apt/sources.list and add the following lines (replace <mirror> with whatever mirror you are currently using in your sources.list file):

deb <mirror> hardy main restricted

deb-src <mirror> hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and make sure to select the newer kernel from the grub menu

After you've tested, feel free to revert back - ie boot into old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, remove lines from /etc/apt/sources.list

Vincenzo Ciancia (vincenzo-ml) wrote :

Surprisingly enough, I repaired my laptop today, and decided to do a quick test to brand new linuxmint. Using just installed kernel ,2.6.22-14-generic, I can seamlessy suspend and resume, with dual core turned on, on my toshiba m400 - excluding the pen that breaks after resume. I will test up-to-date gutsy, and also disabling dual core, in the next days, however I must say I was never able to suspend or hibernate with dual-core on before.

Tim Potter (musikgoat) wrote :

I would like to comment (I originally assisted in confirming this issue) it seems only to be confirmed in an upgrade from feisty to gutsy. Due to other reasons, I had to re-install gutsy on my laptop and did not have any problem suspending to RAM as I originally did.

I still have troubles hibernating sometimes, and find that only 1 suspend seems to work, if you have to do a second, things start to hang. I believe that can be related to other issues.

Hope this helps :]

-tim

Henrik Nilsen Omma (henrik) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined. According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates .

I'm also closing the 2.6.22 task, as this is unlikely to be updated for hardy. Work will continue on fixing it for the next release, Hardy Heron (8.04). I'll approve the Hardy nomination when we see confirmed cases with 2.6.24.

To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage and https://wiki.ubuntu.com/DebuggingProcedures .

Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Vincenzo Ciancia (vincenzo-ml) wrote :

Suspend to ram and to disk seems to work like a charm with the new kernel, however I don't have modules for the wireless card (ipw3945) and the tablet is not working, so I don't know if any of those had, for some obscure reason, interferences with the processor module. However, I suspect that the bug is fixed in hardy. In gutsy, after a while (i think, with latest kernel updates) the thing breaks and the bug is still there even after re-install.

In case somebody wants to test hardy, I have the following in /etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu hardy main restricted

the following in /etc/apt/preferences (to avoid unwanted upgrades)

Package: *
Pin: release a=hardy
Pin-Priority: 400

and installed the new kernel with apt-get install linux-image-2.6.24-2-generic

Thanks for the update Vincenzo, this sounds promising. If you can go ahead and test with the Hardy Alpha2 LiveCD when it comes out, that would be great. That should resolve some of the wireless issues you see. I'll be sure to update this report when it is available. Thanks!

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Id2ndR (id2ndr) wrote :

I installed Hardy Alpha2 and I haven't encountered this bug ; it seems that it has been fixed.

Changed in linux:
status: Incomplete → Fix Released
Rolf Leggewie (r0lf) wrote :

somebody please be so kind to close the remaining open hardy tasks.

Rolf Leggewie (r0lf) wrote :

There is nothing left to be done

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers