snd-hda-intel - Lenovo N100, headphones does not mute speakers

Bug #136810 reported by UbuPetr on 2007-09-02
16
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Ubuntu Audio Team

Bug Description

Binary package hint: linux-source-2.6.22

Plugging in headphones jack into Lenovo 3000 N100, notebook speakers does not mute.

In the connection of other bugs: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/88546
"options snd-hda-intel model=lenovo" or "options snd-hda-intel model=laptop-eapd" in "/etc/modprobe.d/alsa-base" did not help

UnMute trick did not help too: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/88546
Basically, press mute, plug in phones, then unmute. sound comes through phones and not main speaker. To reverse, press mute, unplug phones, then unmute...sound now comes through main speakers again.

Version 2.6.22-10.30 did not solve the problem: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/88546
Kernel linux-image-2.6.22-10-generic 2.6.22-10.30 is affected too.

Partial lame solution:
add this "options snd-hda-intel model=3stack" to the end of file "/etc/modprobe.d/alsa-base"
- notice: with 3stack option, notebook speakers are muted forerver, also without headphones

System:
Ubuntu Gutsy Gibbon - current
Compiz Fusion (AIGLX) at Lenovo N100 (i945)

UbuPetr (ubu-petr) wrote :
Mike Basinger (mike.basinger) wrote :

I having the same problem with a Lenovo 300 N100.

Mike Basinger (mike.basinger) wrote :
Mike Basinger (mike.basinger) wrote :
Mike Basinger (mike.basinger) wrote :
Mike Basinger (mike.basinger) wrote :
Mike Basinger (mike.basinger) wrote :
Mike Basinger (mike.basinger) wrote :
Mike Basinger (mike.basinger) wrote :
Mike Basinger (mike.basinger) wrote :
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-audio
importance: Undecided → Medium
status: New → Triaged
Mike Basinger (mike.basinger) wrote :

This is a bug with Alsa possibly. This page has a patch that may fix this problem.
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2581

lusepuster (thoeger) wrote :

It may be of interest that wneh I ran Linux 2.6.20-15-generic on my Lenovo 3000 n100, it worked fine (I still boot into that kernel version for the same reason). The upgrade to 2.6.20-16-generic seemed to break it. But, still works fine in 2.6.20-15.

Mike Basinger (mike.basinger) wrote :

dbasinge@mikebuntu:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Analog Devices AD1986A
Codec: Generic 11c1 Si3054
dbasinge@mikebuntu:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

loopeando (loopeando) wrote :

Same here with a Lenovo 3000 N100 (0768-6EU). And I confirm what lusepuster said, it works with kernel, 2.6.20-15.

Diego Iastrubni (elcuco) wrote :

Not working as expected under 2.6.22-14-generic. When plugging the headphones internal speaker does not mute.

Rolla Selbak (rolla-n-selbak) wrote :

Opened a new task against the actively developed kernel...

Changed in linux:
status: New → Incomplete
Rolla Selbak (rolla-n-selbak) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The Hardy Heron Alpha series was recently released. Alpha2 and subsequent releases contain an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . Please note that Alpha3 will be released within the next day or two so you many want to wait. You should be able to then test this bug with the new kernel on the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks!

Rolla Selbak (rolla-n-selbak) wrote :

Diego Iastrubni: are you also reporting this problem on the same Lenovo 3000 n100?

lusepuster: Yes, it is indeed interesting that the problem seems to be in between 2.6.20-15-generic 2.6.20-16-generic since it works fine on -15 and broke starting from -16.

Looks like there have been a few alsa and snd-hda-intel commits in 2.6.24, so hopefully a retest with the above Hardy Alpha 2 or 3 will solve the problem *crossing fingers*

On Wednesday 09 January 2008 22:56:55 Rolla Selbak wrote:
> Diego Iastrubni: are you also reporting this problem on the same Lenovo
> 3000 n100?

I can confirm this for Lenovo 3000 n100 running linux-image-2.6.22-14-generic
(2.6.22-14.47) 64bit and alsa-base 1.0.14-1ubuntu2. (Kubuntu 7.10 with all
updates as of 9-1-2008).

If you need more details about my laptop, on the bottom it says 0768-B9G. If
you need even more, you will have to tell me how to produce it for you :)

Rolla Selbak (rolla-n-selbak) wrote :

I see, ok thanks. If you can also retest with Hardy Alpha 2 or 3 to confirm the bug's existence in 2.6.24 that would be great, thanks.

Changed in linux-source-2.6.24:
status: New → Incomplete
Changed in linux:
status: Incomplete → Invalid
Diego Iastrubni (elcuco) wrote :

If you want, I can test on 7.10, by compiling a stock 2.6.24 (or any other
kernel at your request). just ask.

On Thursday 10 January 2008 00:33:13 Rolla Selbak wrote:
> I see, ok thanks. If you can also retest with Hardy Alpha 2 or 3 to
> confirm the bug's existence in 2.6.24 that would be great, thanks.

Rolla Selbak (rolla-n-selbak) wrote :

I think retesting with Alpha2 or Alpha3 would be great if you can...

I downloaded alpha3, the problem is fixed in that release. (Lenovo 3000 N100 Type 0768-6NU), ICH7 Audio w/ AD1986A codec.

Jacob (frias90) wrote :

I'm on a Lenovo 3000 N100, plugged in earphones doesn't mute the speakers.

Diego Iastrubni (elcuco) wrote :

 Jacob ,

Can you reproduce the problem on the released version of 8.04?

This may help some Lenovo user :

with a laptop model : Lenovo 3000 C200 8922AZG

Using headphone, I was obliged to mute manually the speakers output (with gnome volume manager)

Adding this line in /etc/modprobe.d/alsa-base:

"options snd-hda-intel model=lenovo"

fixes the problem : when I plug headphones, speaker are automatically off
(the box headphone in the volume manager has to be checked whatever output you use)

Additionnal information of my current install :

$uname -a
Linux NEANT 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

$cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC861-VD
Codec: Generic 11c1 Si3054

$lspci -vvnn
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
 Subsystem: Lenovo Lenovo 3000 C200 audio [Realtek ALC861VD] [17aa:3802]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 22
 Region 0: Memory at d0340000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
  Address: 0000000000000000 Data: 0000
 Capabilities: [70] Express Unknown type IRQ 0
  Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag-
  Device: Latency L0s <64ns, L1 <1us
  Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
  Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
  Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
  Link: Supported Speed unknown, Width x0, ASPM unknown, Port 0
  Link: Latency L0s <64ns, L1 <1us
  Link: ASPM Disabled CommClk- ExtSynch-
  Link: Speed unknown, Width x0

Remark : with feisty, sound doesn't work out of the box, I was obliged to install manually the alsa drivers.

I am closing this for the actively developed kernel, since it seems to be fixed in Hardy. (See comment from Matthew Ernisse)
If you are still experiencing this bug with Ubuntu 8.04 LTS or Intrepid, please reopen.

The Intrepid Ibex 8.10 Alpha2 is also scheduled for release today. It will appear at the following when available: http://www.ubuntu.com/testing/intrepid/alpha2 . It contains the actively developed 2.6.26 Ubuntu kernel. It would be great if you could test this upcoming release via a LiveCD and verify if the issue still exists. If so, please include the appropriate debugging information as outlined at https://wiki.ubuntu.com/DebuggingSoundProblems . Thanks in advance.

Changed in linux:
status: Incomplete → Fix Released

I'm also closing the linux-source-2.6.22 task as this bug does not qualify for a stable release update. See: https://wiki.ubuntu.com/StableReleaseUpdates . Thanks.

Changed in linux-source-2.6.22:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.