[patch] snd-hda-intel not working with alsa 1.0.14

Bug #135833 reported by Jan de Mooij on 2007-08-30
12
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
High
Ben Collins

Bug Description

Hi,

My sound card used to work okay with alsa 1.0.13. But with Gutsy (alsa 1.0.14) it stopped working.

So I asked on the alsa-devel list, and they wrote a patch for me. My sound works flawlessly with that patch, but with every kernel update I have to compile alsa-driver myself and install it.

The patch is here: http://mailman.alsa-project.org/pipermail/alsa-devel/2007-July/001784.html
Is it possible to include this in the kernel for Gutsy?

Thanks in advance!

Basilio Kublik (sourcercito) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux-source-2.6.22

Jan de Mooij (jandemooij) wrote :

Sorry for not adding the right package myself.

This patch is committed in 2.6.23, here is some more information: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=df802952b723cdb08f2f8a3cba396c357290850b

Thanks.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-audio
importance: Undecided → Medium
status: New → Triaged
Cody Russell (bratsche) wrote :

By "not working" did you mean that you can't load the snd-hda-intel module? I just did an upgrade from Feisty to Gutsy and I am unable to modprobe snd-hda-intel, even though it is installed. Just wondering if this is the same problem you had.

Jan de Mooij (jandemooij) wrote :

Hi Cody,

Yes that's right, I couldn't modprobe snd-hda-intel, and the following message appeared in dmesg:

[ 33.360190] stac92xx_auto_fill_dac_nids: No available DAC for pin 0x15

Do you get something similar?

Ben Collins (ben-collins) wrote :

Patch committed. Will try to get an upload for beta, otherwise it will be included for release.

Changed in linux-source-2.6.22:
assignee: ubuntu-audio → ben-collins
importance: Medium → High
status: Triaged → Fix Committed

@Ben Collins: Please could you check if this Bug - and the patch related to it - does affect Bug #131133 in any way?

AJ Slater (aj-slater) wrote :

Sound on my Macbook Pro seemed to be working immediately after I upgraded to gutsy as of RC1.
With yesterdays kernel update sound has ceased to work:

% lspci
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

# modprobe -v snd_hda_intel
insmod /lib/modules/2.6.22-14-generic/updates/sound/pci/hda/snd-hda-intel.ko

% dmesg | tail
[28561.040000] ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 21
[28561.040000] PCI: Setting latency timer of device 0000:00:1b.0 to 64
[28561.208000] hda_codec: STAC922x, Apple subsys_id=106b0200
[28562.240000] hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x011f1c00
[28562.488000] ACPI: PCI interrupt for device 0000:00:1b.0 disabled
[28562.488000] HDA Intel: probe of 0000:00:1b.0 failed with error -16

AJ Slater (aj-slater) wrote :

Figured this one out. The bad sound driver was coming from linux-backports-modules.

bushwakko (wakko-generation) wrote :

I have the same error on my mabook pro, except for the azx_get_response line. I have gutsy now, but I use my own kernel 2.6.23-kamikaze4 (which has alsa 1.0.15). It didn't work for me on 2.6.22 ubuntu kernel either, I had to do some ubuntu specific update-modules alsa stuff that I don't remember, and have no idea what means.. anyone know how to fix this?

The patch referenced in this bug report was included in the linux-ubuntu-modules-2.6.22 package. I'm marking this report as 'Fix Released'. If you are still experiencing problems, please test against the latest Hardy Alpha Release (http://cdimage.ubuntu.com/releases/hardy/) and verify this issue still exists. If so, please open a new report against the 'linux' source package since as of the Hardy release the kernel source package naming convention changed from just "linux-source-2.6.x' to just 'linux'. Thanks.

Changed in linux-source-2.6.22:
status: Fix Committed → Fix Released
josef (ok1dtm) wrote :

The same problem
dmesg:
 ....
[ 35.567422] PCI: Unable to reserve mem region #1:4000@febf8000 for device 0000:00:1b.0
[ 35.567426] ACPI: PCI interrupt for device 0000:00:1b.0 disabled
[ 35.567431] HDA Intel: probe of 0000:00:1b.0 failed with error -16
...
Sound worked only with acpi=off. In Gusty sound worked without this parameter.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers