Tribe 5: suspend hangs laptop

Bug #134476 reported by Willem Kan
36
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Won't Fix
High
Unassigned

Bug Description

Just installed Tribe 5 (gutsy gibbon) Kubuntu on my laptop. I installed to hard disk and started the newly installed system.
When putting the laptop in suspend, the laptop does NOT go into suspend and completely hangs.

Revision history for this message
Nicolas Robin (nicolas-robin-deactivatedaccount) wrote :

Hi Willem, thanks for your bug report.

Could you please precise the model of your laptop ?

Thanks.

Revision history for this message
Jérôme Guelfucci (jerome-guelfucci-deactivatedaccount) wrote :

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.
4. Please follow this procedure : https://wiki.ubuntu.com/DebuggingKernelSuspend

For your reference, the full description of procedures for kernel-related bug reports is available at [WWW] http://wiki.ubuntu.com/KernelTeamBugPolicies. Thanks in advance!

Revision history for this message
Willem Kan (wrkan-deactivatedaccount) wrote :

Requested info is the following:
Laptop: Toshiba Satellite A110-228

Uname -a: Linux gutsy-test-laptop 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686 GNU/Linux

Revision history for this message
Willem Kan (wrkan-deactivatedaccount) wrote :
Revision history for this message
Willem Kan (wrkan-deactivatedaccount) wrote :

Another dmesg file, created ASAP after hang of suspend (this time, suspend went OK, but laptop hanged on resume)

Revision history for this message
Jérôme Guelfucci (jerome-guelfucci-deactivatedaccount) wrote :

Thank you. I'm marking this as triaged. I extracted the 'hash matches' :

[ 15.958192] Magic number: 0:432:626
[ 15.958197] hash matches /build/buildd/linux-source-2.6.22-2.6.22/drivers/base/power/resume.c:28
[ 15.958343] hash matches device 0000:00:1b.0

Changed in linux-source-2.6.22:
importance: Medium → High
status: Incomplete → Triaged
assignee: nobody → ubuntu-kernel-team
Revision history for this message
Taneli Leppä (rosmiitto) wrote :

Something has definately happened since fix of bug #129226, my suspend has broken since that. I don't get any errors anymore in syslog, so I guess this is a different bug from the Macbook patch originated one. This is on Asus M2NPV-VM and Athlon X2 4600+.

Revision history for this message
Pablo Quirós (polmac1985) wrote :

I also have this problem in an Dell Inspiron 8600c. I add the information requested:

1. Linux pandora 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686 GNU/Linux
2. Log attached
3. (see next message)
4. I found the lines

[ 22.757716] Magic number: 7:139:988
[ 22.757724] hash matches device ttyd1

there where not 'hash matches' below that.

Revision history for this message
Pablo Quirós (polmac1985) wrote :

And the other log...

Revision history for this message
Willem Kan (wrkan-deactivatedaccount) wrote :

Question: I report several bugs for (k)ubuntu, like this one, but is anyone on earth working on these bugs? There is no feedback at all... Hope there will be a solution?

Revision history for this message
Willem Kan (wrkan-deactivatedaccount) wrote :

Error is still in 2.6.22-11 which I just downloaded.

Revision history for this message
checco (cescosa) wrote :

Hi,
i have found the same problem in this kernel version. I send to you my dmseg log...may be can help you.

Revision history for this message
Ketil (ubuntu-rytmisk) wrote :

Same thing here (probably)
Asus a9rp (https://wiki.ubuntu.com/LaptopTestingTeam/AsusA9RP) and it used to wrk perfectly under feisty. Have not worked during the last upgrades in gutsy.

Symptoms: Suspend to ram gives a black screen with a blinking underline in the left upper corner of the screen and a blinking light indicating that caps lock is turned on-off-on-off rapidly.... (Which it is of course not.) Suspend to disk just blankens the screen and then starts over back into gnome.

I'll attack my outputs as well.

Ketil

Revision history for this message
Ketil (ubuntu-rytmisk) wrote : My reports

uname -a
Linux ketil-laptop 2.6.22-11-generic #1 SMP Mon Sep 17 03:45:58 GMT 2007 i686 GNU/Linux

Revision history for this message
Ketil (ubuntu-rytmisk) wrote : and dmesg
Revision history for this message
Nicolás Schubert (nischg) wrote :

Same here with a Dell Inspiron 6400/e1505 with Ati Radeon X1300.
Would my information be helpful or is it enough with the reports already posted?

Revision history for this message
Terry L. Triplett (terry-triplett) wrote :

Superficially, this smells like a duplicate of the following:

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/121653
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/126214

The symptoms described are similar to what I and other have experienced, anyhow.

If the original reporter has an ATI graphics adapter and is using the fglrx driver, the problem is that fglrx is having problems with SLUB-enabled kernels (http://lwn.net/Articles/229984/). A workaround is to compile a custom kernel with SLAB enabled instead of SLUB.

Revision history for this message
Lynoure Braakman (lynoure) wrote :

I'm experiencing these symptoms on HP NC8230 (ati graphics card, but not fglrx driver).

Linux pkunk 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

Revision history for this message
Isaac Su (me-isaacsu) wrote :

I'm having similar problems with my 2.6.22-12 kernel, and I suspect it has to do with the SLAB/SLUB problem. I'm wanting to recompile my kernel. Can anyone show me how it's done. I tried doing it, and ended up with a bloated modules folder, and a non booting system. I'm having trouble at the "make menuconfig" part of the process - most of the configuration options are foreign to me (but I do see the SLAB/SLUB option). Is there any way to maybe get a .config file that is the same as the stock ubuntu one, and then just flick the switch on the SLAB/SLUB?

Help much appreciated.

Revision history for this message
Isaac Su (me-isaacsu) wrote :

I'd like to confirm that recompiling your kernel with SLAB instead of SLUB fixes this problem. Thanks to Terry for showing me how to do it.

Revision history for this message
Lynoure Braakman (lynoure) wrote :

Is it possible for the cause to be the same even if one doesn't use the fglrx driver? Because I honestly don't use it, and still have this problem. Should I start a new bug report instead?

Revision history for this message
Lynoure Braakman (lynoure) wrote :
Revision history for this message
parren (peter-arrenbrecht) wrote :

Could we have the recompile instructions here in the comments? I have the problem and an ATI with fglrx, too.

Revision history for this message
parren (peter-arrenbrecht) wrote :

SLAB instead of SLUB works for me too.

Revision history for this message
Lynoure Braakman (lynoure) wrote :

I'd be grateful if someone else tried with ati card, but without fglrx, too.

Revision history for this message
parren (peter-arrenbrecht) wrote : Re: [Bug 134476] Re: Tribe 5: suspend hangs laptop

My card is not supported by the X.org ATI driver.

On 10/3/07, Lynoure Braakman <email address hidden> wrote:
> I'd be grateful if someone else tried with ati card, but without fglrx,
> too.

Revision history for this message
parren (peter-arrenbrecht) wrote :

> On 10/3/07, Lynoure Braakman <email address hidden> wrote:
> > I'd be grateful if someone else tried with ati card, but without fglrx,
> > too.

I tried it on a Radeon 9800 notebook with the X.org ati driver. It
suspends, but when woken up again the screen stays blank.
Ctrl+Alt+BkSp does not help.

Revision history for this message
Paul Handly (mephaust) wrote :

My Thinkpad T60 (X1400 video) suspends fine with the xserver-xorg-video-avivo driver, with fglrx it would "stick" while blinking the suspend LED. No fglrx, no problem.

Revision history for this message
Willem Kan (wrkan-deactivatedaccount) wrote :

On My Toshiba Satellite A110-228, NO fglrx, BIG problem...

Paul Handly wrote:

> My Thinkpad T60 (X1400 video) suspends fine with the xserver-xorg-video-

> avivo driver, with fglrx it would "stick" while blinking the suspend

> LED. No fglrx, no problem.

>

>

_________________________________________________________________
http://www.live.com/?mkt=nl-nl
Live.nl

Revision history for this message
Ketil (ubuntu-rytmisk) wrote :

Latest update (actually a fresh install bit still) to 2.6.22.14 and the opensource ati-driver seems to have fixed the sleep issue. The rt kernel still refuses to go to sleep though, but it stops later than the blinking cursor. Shoould I file a seperate bug report?

Ketil

Revision history for this message
Nik (nicholas-tripp) wrote :

2.6.22-14-generic #1 SMP Wed Oct 10 06:00:47 GMT 2007 i686 GNU/Linux

I'm running into this problem too. I have an IBM x22 and Suspend has always worked (Edgy, Feisty, Fedora Core 5,6). I even had a custom 2.6.22 kernel that could resume. currently I put is to sleep and then it hangs when coming out of sleep the little moon light that indicates sleep mode flashes like it's resuming and continues to do so indefinetly. I am not suing fglrx (there are none for my Mobility 6L MY)

Revision history for this message
Nik (nicholas-tripp) wrote :
Revision history for this message
Nik (nicholas-tripp) wrote :

I did a recent upgrade (102 packeges) and now my Laptop fails to make it into sleep. The light starts flashing, USB peripherals are disconnected and then nothing else happens, except that the light indicating going into sleep continues to flash.

Revision history for this message
faif (faifcn) wrote :

Just confirm, My laptop IBM Thinkpad T60 with ATI Mobility Radeon X1300: Kernel 2.6.22-14-generic
1. With ATI restricted driver fglrx 8.37.6, Laptop cannot enter suspend mode. (crescent moon flashing, computer hang up, blank screen)
2. disable ATI restricted driver, xorg has vesa as generic driver, laptop CAN enter suspend mod and resume without problem.

Revision history for this message
Nik (nicholas-tripp) wrote :

Linux ubuntu 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

1. I haven't been using the fglrx driver (it's not available for my hardware ATI Radeon m6 ly) but instead the open source ATI driver. Could not suspend using 2.6.22-14 kernel, feisty kernel or custom 2.6.23.1. (with SLAB instead of SLUB)

2. changed to vesa as posted above and now laptop is able to resume from suspend.

laptop sleep issues extend beyond just the Proprietary ATI driver.

Revision history for this message
Willem Kan (wrkan-deactivatedaccount) wrote :

I do NOT have an ATI card and do NOT use the fglrx driver and still my laptop never wakes up from resume. In feisty, everything works fine. So again, for me, this bug is not related to either ATI or fglrx...

_________________________________________________________________
http://www.live.com/?mkt=nl-nl
Live.nl

Revision history for this message
Nik (nicholas-tripp) wrote :

I pointed that out mostly because the ATI fglrx problem made it into the release notes, but this problem doesn't appear to be getting the same attention (maybe do to some confusion).

Revision history for this message
David Oxland (doxland) wrote :

I have the same problem on a Dell Inspiron 9300 with Nvidia 6800

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Just a few things to mention. . . .

The symptom of this particular bug, failure to Suspend, is specific to the hardware used. So while many of you may have the same symptom they really should be different bugs since your hardware differs from the original bug reporter. It would be helpful if everyone were to test with the latest Hardy Alpha release, http://www.ubuntu.com/testing/ . You should be able to test using the LiveCD. However, note you can only test Suspend via the LiveCD, not Hibernate. If you still experience issues, and your hardware differs from the original bug reporters, please open a separate bug report for your hardware using "linux" as the package. The bug report should contain the information requested at http://wiki.ubuntu.com/KernelTeamBugPolicies . The following wiki may also help: https://wiki.ubuntu.com/DebuggingKernelSuspend. Additionally, it would be great if you made the titles of a new bug report contain information about your system. I apologize for any inconvenience this might cause but appreciate your cooperation.

After having said that, Willem can you comment if this is still an issue for you with the latest Hardy Alpha release? We'll keep this report open against the actively developed kernel but it will be closed against 2.6.22. Thanks.

Changed in linux-source-2.6.22:
status: Triaged → Won't Fix
Changed in linux:
status: New → Incomplete
Revision history for this message
Willem Kan (wrkan-deactivatedaccount) wrote :

Hello,

With Alpha 5 and all the latest Hardy updates this issue is currently
resolved on my laptop. Don't know if it will re-appear somewhen, but for
now I can confirm it's fine!

_________________________________________________________________
Nieuw: Windows Live Messenger 2008! Gratis downloaden
http://get.live.com/messenger

Revision history for this message
Lynoure Braakman (lynoure) wrote :

Does Launchpad not allow splitting bugs into different ones? At least some of the users do specify their hardware.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks for the update Willem. I'm glad to hear things are working for you. Since you are the original bug reporter, I'm going to go ahead and mark this "Fix Released" against the Hardy kernel.

Lynoure Braakman, unfortunately launchpad does not yet have the capability for splitting comments into new bug reports. So for those of you who are still experiencing issues, please open a new bug report. Thanks.

Changed in linux:
status: Incomplete → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers