Gutsy Tribe 5: Backlight does not come back on after resuming from suspend

Bug #134391 reported by Mike Richards on 2007-08-23
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

The machine is a Thinkpad T61 running Gutsy Tribe 5.

The bug is easy to reproduce: Go into suspend. When you come out of suspend, the backlight never comes back on.

Mike Richards (mrmikerich) wrote :

And here's the solution to this problem: Edit /boot/grub/menu.lst, adding "acpi_sleep=s3_bios" (no quotes) to the first kernel entry.

Elias Naur (elias-naur) wrote :

Suspend doesn't work for me, even using the acpi_sleep workaround. I'm on a Thinkpad t61 with the NVIDIA QUADRO NVS 140M (latest nvidia binary blob drivers), so I guess the original submitter has the intel x3100 variant.

Mike Richards (mrmikerich) wrote :

Yes, that is correct. I have the Intel graphics.

Elias Naur (elias-naur) wrote :

With the latest updates, suspend now works for me, except:

1. The wireless network doesn't work (probably an iwl4965 related bug)
2. I had to change POST_VIDEO to false in /etc/default/acpi-support

Mike Richards (mrmikerich) wrote :

Resuming from suspend still results in a blank screen for me unless I add the acpi_sleep line.

Elias, what did the POST_VIDEO change do? (why did you make that change?)

Elias Naur (elias-naur) wrote :

Without POST_VIDEO=false in acpi-support, the screen would briefly show a blinking cursor and then go blank when resuming. I guess the acpi_sleep trick is an alternative workaround, but I didn't get around to try it, since POST_VIDEO worked for me.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux-source-2.6.22.

Phil Sung (psung) wrote :

I'm also seeing this on Hardy with 64-bit kernel 2.6.24-2.4 on a Thinkpad X61s.

Neither the acpi_sleep nor the POST_VIDEO suggestions work for me, but I can get the backlight back by switching to another VT (e.g. with Ctrl+Alt+F6) and then back.

Hi All,

Just a first few things . . . Phil, care to open a new bug report? It looks like you have a different system than the original bug reporter. We prefer to have bug reports target a specific issue on a specific set of hardware. We can duplicate reports later on if necessary. Thanks!

Elias, you may want to do the same since you have a different video card.

Still feel free to still follow the dialog of this report if you find it helpful.

Mike, the Hardy Heron Alpha2 release will be out shortly. It would be great if you could test with the Alpha2 LiveCD and verify if this issue still exists. I'll update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete

I'm opened a new task against the actively developed kernel. However, because of the workaround mentioned, I'm closing the report against linux-source-2.6.22 as it does not meet the criteria for a stable release update. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Elias Naur (elias-naur) wrote :

I tried Hardy alpha 2 with the same results. It seemed to suspend alright, but resuming it resulted in a blank screen (but the system responded to ctrl-alt-delete by restarting and ejecting the cd).

On the plus side, the ubuntu splash screen now works, wohoo!

Matt Zimmerman (mdz) wrote :

I reported similar symptoms in bug 189260. I have not tried the s3_bios workaround yet.

Matt Zimmerman (mdz) wrote :

Setting to confirmed because this issue is definitely still present post-alpha2.

Changed in linux:
status: Incomplete → Confirmed

I'm experiencing same problem here on a Toshiba Tecra M2, but my screen comes back with the login dialog if a close the lid and open it again.

uname -a
Linux alfonso-laptop 2.6.24-7-generic #1 SMP Thu Feb 7 01:29:58 UTC 2008 i686 GNU/Linux

Tom Vetterlein (smbm) wrote :

Same problem here on an R61 X3100 up to date Hardy system.

Neither if these 2 fixes works.

I can get the backlight to work using the terminal switch method though.

Perhaps some work around with xbacklight might be in order?

For those still experiencing this issue, care to attach your dmesg output after a failed suspend/resume cycle as outlined in: https://wiki.ubuntu.com/DebuggingKernelSuspend . Thanks.

Changed in linux:
status: Confirmed → Incomplete
Tom Vetterlein (smbm) wrote :

Here is my dmesg.

The bit mentioned on the wiki page doesn't seem to be there.

Everything about the resume works except for the backlight not turning back on.

Sound, wireless etc are all fine once I've switched tty and back again.

Hi there,

on lenovo W500 with lenny+backports I have the same bug
(screen blancks but u can recover it by hibernating or restarting system).
This happens by using

echo -n "mem" > /sys/power/state

and by using

echo -n 3 >/proc/acpi/sleep

I can sleep and resume almost perfectly,
the only issue is that it suspends twice
(it suspends again after resume 1st time).
This behaviour happens every time I suspend the machine.

I have set in /etc/default/acpi-support
SUSPEND_METHODS="none"
but it still suspends twice.

I've too disabled suspend in

/etc/acpi/sleepbtn.sh
/etc/acpi/sleep.sh
/etc/acpi/actions/lm_lid.sh
/etc/acpi/lid.sh

and in gnome-power-manager
but it still suspends twice.

Is there any other place where I can disable suspend
to see where is the problem?

Thanks,

Victor.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments