Ubuntu

Backport support for ENE CB714 card readers

Reported by Mikko Virkkilä on 2007-08-18
2
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Low
Tim Gardner

Bug Description

My Acer Travelmate 6292 laptop has a built in flash memory card reader. lscpi tells me it's made by ENE Technologies. I tried plugging in a SecureDigital memory card, but it doesn't show up anywhere. After doing some research on the issue, I've come to believe the following patch adds SD and SDHC support for my card reader (0x0750 & 0x0751):

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=b8352260d28b30cb2bb2df99814fb9c360e38901

As you can see the patch has med it in to Linus' 2.6.23rc3, but as gutsy will be released with 2.6.22 (+ patches) I'm afraid that the fix won't get in by default, and I'm not looking forward to maintaining my own kernel. Therefore I'd like to see the patch backported to gutsys kernel if possible.

Me too! I have the same issue. Thanks Mikko!

Chuck Short (zulcss) wrote :

Thanks added to my git tree

Changed in linux-source-2.6.22:
status: New → Fix Committed
Tim Gardner (timg-tpi) wrote :

Please send a pull request to the kernel team mailing list. Kernel bug reports are not status 'Committed' until they land in the main repo.

Changed in linux-source-2.6.22:
assignee: nobody → zulcss
status: Fix Committed → In Progress
Tim Gardner (timg-tpi) wrote :

Gutsy commit 63e5606b3ab81b38133cefe7700d624b7eee4843

Changed in linux-source-2.6.22:
assignee: zulcss → timg-tpi
importance: Undecided → Low
status: In Progress → Fix Committed
Mikko Virkkilä (virkkila) wrote :

With the recent kernel update the card-reader has started working and I was able to read and write to a Secure Digital -card. Thank you Chuck Short, Tim Gardner and of course Leandro Dorileo for making it "just work".

Changed in linux-source-2.6.22:
status: Fix Committed → Fix Released
Matt LaPaglia (mlapaglia) wrote :

This bug is still not corrected. _Only_ the SD cards will work in my reader currently with Ubuntu Gutsy x86.

my LSPCI:
06:04.0 CardBus bridge: ENE Technology Inc CB-712/4 Cardbus Controller (rev 10)
06:04.1 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller (rev 01)
06:04.2 Generic system peripheral [0805]: ENE Technology Inc ENE PCI Secure Digital Card Reader Controller (rev 01)
06:04.4 FLASH memory: ENE Technology Inc SD/MMC Card Reader Controller (rev 01)

I insert an SD card, and it is recognized normally, but when a sony memory stick is inserted, it is not recognized and there is no dmesg about it. (I tried 4 different cards). The reader works under Windows so it isn't a hardware problem.

Changed in linux-source-2.6.22:
status: Fix Released → Incomplete
status: Incomplete → Confirmed
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers