linux-xen for x86_64

Bug #132726 reported by Bart Verwilst on 2007-08-15
10
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Medium
Chuck Short
Nominated for Feisty by Zac Bowling
Nominated for Gutsy by Zac Bowling

Bug Description

Binary package hint: linux-xen

I'm currently installing my new colocated server, with Gutsy and xen.. I've used the 2.6.18 directly from xensource, but i find that my ext3 partitions are getting more corrupt by the minute :)
I've noticed a linux-xen, linux-image-xen, ... in gutsy, but only for i386.. Could it be possible to compile this for amd64 as well?
Thanks a lot!

Chuck Short (zulcss) wrote :

I have the fix in my git tree will be pushed soonish.

Changed in linux-meta:
status: New → Confirmed
Tim Gardner (timg-tpi) wrote :

Gutsy commit 99b3465fe77281eeb12073e362cb4c7fc332095a and 3e2bfb423cb9cb16a89757909c2f3a41b3c4a5b9

Changed in linux-meta:
assignee: nobody → zulcss
importance: Undecided → Medium
status: Confirmed → Fix Committed
Ben Collins (ben-collins) wrote :
Download full text (4.0 KiB)

linux-source-2.6.22 (2.6.22-11.32) gutsy; urgency=low

  [Amit Kucheria]

  * Build system: Allow custom builds to comprise multiple patches
  * Move UME to a Custom build and add first setup of thermal framework

  [Ben Collins]

  * ubuntu: Enable CONFIG_BLK_DEV_IO_TRACE
  * bcm203x: Fix firmware loading
    - LP: #85247
  * ubuntu: mtd changes caused module renaming. Ignore
  * rt: Do not patch top level Makefile for SUBLEVEL. Will always end up
    breaking

  [Chuck Short]

  * [USB] Unusual Device support for Gold MP3 Player Energy
    - LP: #125250
  * [SIERRA] Adds support for Onda H600 ZTE MF330
    - LP: #129433
  * [HDAPS] Add Thinkpad T61P to whitelist.
    - LP: #133636
  * [USB] Add support for Toshiba (Novatel Wireless) HSDPA for M400.
    - LP: #133650

  [Kyle McMartin]

  * apparmor 10.3 hooks
  * unionfs 2.1 hooks
  * nuke UNION_FS stuff from fs/{Kconfig,Makefile}

  [Tim Gardner]

  * Paravirt-ops I/O hypercalls
  * Fix lazy vmalloc bug for Gutsy
  * bluetooth headset patch
    - LP: #130870
  * Add the PCI ID of this ICH4 in list of laptops that use short cables.
  * v2.6.22.5 merge
  * Update Xen config options.
    - LP: #132726
  * Remove mtd modules from ABI
  * Support parallel=<n> in DEB_BUILD_OPTIONS
    - LP: #136426

  [Upstream Kernel Changes]

  * hwmon: fix w83781d temp sensor type setting
  * hwmon: (smsc47m1) restore missing name attribute
  * sky2: restore workarounds for lost interrupts
  * sky2: carrier management
  * sky2: check for more work before leaving NAPI
  * sky2: check drop truncated packets
  * revert "x86, serial: convert legacy COM ports to platform devices"
  * ACPICA: Fixed possible corruption of global GPE list
  * ACPICA: Clear reserved fields for incoming ACPI 1.0 FADTs
  * AVR32: Fix atomic_add_unless() and atomic_sub_unless()
  * r8169: avoid needless NAPI poll scheduling
  * forcedeth: fix random hang in forcedeth driver when using netconsole
  * libata: add ATI SB700 device IDs to AHCI driver
  * Hibernation: do not try to mark invalid PFNs as nosave
  * i386: allow debuggers to access the vsyscall page with compat vDSO
  * x86_64: Check for .cfi_rel_offset in CFI probe
  * x86_64: Change PMDS invocation to single macro
  * i386: Handle P6s without performance counters in nmi watchdog
  * i386: Fix double fault handler
  * JFFS2 locking regression fix.
  * [Input]: appletouch - improve powersaving for Geyser3 devices
  * [Input]: add driver for Fujitsu serial touchscreens
  * [sdhci]: add support to ENE-CB714
  * v2.6.22.5
  * [MTD] Makefile fix for mtdsuper
  * ocfs2: Fix bad source start calculation during kernel writes
  * NET: Share correct feature code between bridging and bonding
  * sky2: don't clear phy power bits
  * uml: fix previous request size limit fix
  * i386: fix lazy mode vmalloc synchronization for paravirt
  * signalfd: fix interaction with posix-timers
  * signalfd: make it group-wide, fix posix-timers scheduling
  * DCCP: Fix DCCP GFP_KERNEL allocation in atomic context
  * IPV6: Fix kernel panic while send SCTP data with IP fragments
  * IPv6: Invalid semicolon after if statement
  * Fix soft-fp underflow handling.
  * Netfilter: Missing Kbuild entry for netfil...

Read more...

Changed in linux-source-2.6.22:
status: Fix Committed → Fix Released
Matt Brown (mattbrown) wrote :

Hi,

This package has built, but still doesn't seem to provide linux-image-xen for amd64/x86_64. Are you sure that it fixes this bug?

http://launchpadlibrarian.net/9160196/linux-source-2.6.22_2.6.22-11.32_amd64.changes

^^ no linux-image-xen in the new changes file.

Steven Wagner (stevenwagner) wrote :

I can 2nd what matt is saying.

Matt Brown (mattbrown) wrote :

Setting back to confirmed to ensure this doesn't slip off the radar unnoticed.

Changed in linux-source-2.6.22:
status: Fix Released → Confirmed
Zac Bowling (zac) wrote :

Confirmed as well here. This is a little anoying :-P

Zac Bowling (zac) wrote :
Download full text (4.1 KiB)

I added "xen" to "debian/rules.d/amd64.mk" to the "extra_flavours" and tried to build the deb package but the Xen build for AMD64 fails with:

In file included from /home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:36:
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.h:237: error: field 'card_tasklet' has incomplete type
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.h:238: error: field 'finish_tasklet' has incomplete type
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c: In function 'sdhci_finish_data':
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:556: warning: implicit declaration of function 'tasklet_schedule'
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c: In function 'sdhci_send_command':
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:627: warning: format '%08X' expects type 'unsigned int', but argument 3 has type 'long unsigned int'
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c: At top level:
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1174: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'sdhci_irq'
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c: In function 'sdhci_suspend':
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1281: warning: implicit declaration of function 'free_irq'
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1267: warning: unused variable 'ret'
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c: In function 'sdhci_resume':
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1312: warning: implicit declaration of function 'request_irq'
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1312: error: 'sdhci_irq' undeclared (first use in this function)
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1312: error: (Each undeclared identifier is reported only once
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1312: error: for each function it appears in.)
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1313: error: 'IRQF_SHARED' undeclared (first use in this function)
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c: In function 'sdhci_probe_slot':
/home/zbowling/linux-source-2.6.22-2.6.22/debian/build/custom-source-xen/drivers/mmc/mss/mss_sdhci.c:1547: warning: implicit declaration of function 'tasklet_init'
/home/zbowling/l...

Read more...

Zac Bowling (zac) wrote :

The mmc stuff I belive is an ubuntu addon if I'm not mistaken, that is not in the vanilla (linus's tree) version of the kernel.

Zac Bowling (zac) wrote :

Looking at debian/binary-custom.d/xen/patch.001 there is a lot of work to be done to support X86_64 Xen against the gusty kernel. The entire patch being applied only applies to "arch/i386" and nothing even touches the "arch/x86_64" tree.

This needs to be upgraded in severity.

Bart Verwilst (verwilst) wrote :

I'm running my home-compiled linux-image-2.6.22-11-xen_2.6.22-11.33_amd64.deb on amd64 just fine.. I'm using the git tree from git://kernel.ubuntu.com/zul/ubuntu-gutsy.git . I'm not sure how the merging/syncing with the normal tree goes, but Chuck said it would hit the repo's in a short while ( for amd64 that is ).

Zac Bowling (zac) wrote :

I seen the various git left overs in the deb but didn't know where it was.
THANKS!

Zac Bowling (zac) wrote :

This probably should make it into soon so it can have some time to before gusty releases to be tested.

Zac Bowling (zac) wrote :

I got an image going to make this work.

Depends on the other python bug getting fixed in xenman as well. If I patch both I can get it to boot. The restricted modules don't pull over, but there is not a lot in there that I'm worried about.

I can't find anything wrong with anything. What is holding up it getting uploaded?

Bart Verwilst (verwilst) wrote :

Other python bug? patches? I didn't have to patch anything to get it to build, but i presume you're using the ubuntu/ubuntu-gutsy.git?
And i agree, getting this out there while Gutsy is still in beta would be A Good Thing(tm) for the stability of things :) But at #ubuntu-kernel they said the amd64 xen kernel should be included in the next release next week.. Let's hope for the best ;)

Zac Bowling (zac) wrote :

I stuck new debs at http://polystimulus.com/ubuntu/ if anyone is interested.

Bart Verwilst (verwilst) wrote :

It arrived!

ftp://ftp.ubuntu.com/ubuntu/pool/universe/l/linux-source-2.6.22

See, a nice and shiny amd64 deb! ;)

Thanks a lot for all the hard work @ devs, now let's test this puppy!

Chuck Short (zulcss) wrote :

Closing

Changed in linux-source-2.6.22:
status: Confirmed → Fix Released
Todd Deshane (deshantm) wrote :

FYI: the linux-xen metapackage is still missing as of this comment.

Todd Deshane (deshantm) wrote :

This was fixed last week.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers