[gutsy] system locks up at boot with pata_it821x driver

Bug #131472 reported by Dmitry Ivanov on 2007-08-10
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
High
Unassigned

Bug Description

I tried to install Kubuntu tribe 4 but the system freezes at installation. The last thing I see is the progress dialog saying
"Loading linux kernel". Then black screen showes up and system freezes.

I guess my buggy ITE8211F controller causes lockups. After I turned it off and plugged my cdrom drive to the built-in IDE controller, I was able to boot up the kernel. The motherboard in question is ASUS P5WD2.

Please consider reverting to the old it821x driver (non-libata) because this is the second Ubuntu release (the first one was Feisty) where I expierence problems with this driver.

Is there a workaround (except turning of the controller) so I can boot the kernel and finish installation?

Changed in linux-source-2.6.22:
importance: Undecided → High
Dmitry Ivanov (vonami) wrote :

Just tried Tribe 5, the same story.

This week I'm going to try the latest kernel from git (2.6.23). I'll post the results.

PS. Is anyone from the Ubuntu kernel team paying attention to this bug? If you need additional information or testing
just let me know.

Dmitry Ivanov (vonami) wrote :

Tried 2.6.23-rc5, no luck.

It seems this issue was reported upstream a long time ago - http://bugzilla.kernel.org/show_bug.cgi?id=7507
I added some comments there and attached logs to draw attention of the kernel developers.

Henrik Nilsen Omma (henrik) wrote :

Thanks for testing the latest code (here and upstream).

How far do you get in the boot process? You say it freezes at installation, but I'm guessing you mean on booting the live CD? If so, could you please try the following: press F6 at the boot screen, remove 'splash' and 'quiet' from the line, boot and report the output you see before it freezes.

Thanks!

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
status: New → Incomplete
Dmitry Ivanov (vonami) wrote :

> You say it freezes at installation, but I'm guessing you mean on booting the live CD?

Right, I meant on booting the CD (I used the alternate install CD).

> If so, could you please try the following: press F6 at the boot screen, remove 'splash' and 'quiet' from the line, boot and report the output you see
> before it freezes.

Done. The output is attached below. Since it wasn't possible to save dmesg, I wrote down the output on paper and
then typed it into a file. Those are the last messages I see on the screen before it freezes.

Just to clear things up:
 - the hard drive is attacted to the onboard IDE controller (Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01))
   which works fine
 - the DVD drive is attached to this ITE controller which causes lockups
 - the old it821x driver doesn't freeze my system

Dmitry Ivanov (vonami) wrote :

Tried 2.6.23-rc6 and guess what? It works!

You may find a thread at http://bugzilla.redhat.com/show_bug.cgi?id=242229 useful.
Well, whatever the final decision on this issue I hope it will get fixed ASAP.

Henrik Nilsen Omma (henrik) wrote :

Thanks Dmitry!

Setting beta milestone as we seem to have fix identified upstream.

Changed in linux-source-2.6.22:
status: Incomplete → Triaged
Tim Gardner (timg-tpi) wrote :

Gutsy commit eda0e2ce30de9d3c6bb31524a4adce98abbb8dbe

Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-team → timg-tpi
status: Triaged → Fix Committed
Dmitry Ivanov (vonami) wrote :

Great!

As soon as the fixed kernel shows up in the repo I'll give it a try.

Tim Gardner (timg-tpi) wrote :

2.6.22-13.40

Changed in linux-source-2.6.22:
assignee: timg-tpi → nobody
status: Fix Committed → Fix Released
Tim Carmean (tecarmea) wrote :

Latest daily ISO (Oct. 6th) locks up booting shortly after loading the pata_it821x module. Hard drive and optical drive are P-ATA.

00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
01:03.0 Mass storage controller: Integrated Technology Express, Inc. ITE 8211F Single Channel UDMA 133 (ASUS 8211 (ITE IT8212 ATA RAID Controller)) (rev 11)

linux-source-2.6.22 package on cd suggests the kernel is 2.6.22-13.40.

Tim Carmean (tecarmea) wrote :

Copied wrong lspci output:

00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE (rev 01)
01:03.0 Mass storage controller: Integrated Technology Express, Inc. ITE 8211F Single Channel UDMA 133 (ASUS 8211 (ITE IT8212 ATA RAID Controller)) (rev 11)

Tim Carmean (tecarmea) wrote :

After reconfiguring where the disks were plugged in and turning off the ITE chipset I was able to boot the gutsy installer perfectly. I'll be willing to test in the old hardware configuration provided instructions on what to do.

Dmitry Ivanov (vonami) wrote :

2.6.22-13 fixed the bug for me.

I haven't tested daily ISO yet. I'll post results if pata_it821x doesn't work on it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.