3G/UMTS driver for Lenovo/IBM Thinkpad X61/T61 is not loaded automatically

Bug #131167 reported by cygnus on 2007-08-08
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Low
Unassigned

Bug Description

The 3G/UMTS driver for Sierra Wireless devices in X61/T61 Lenovo Thinkpads isn't loaded correctly (vendor/product id isn't recognized).

A rule in /etc/udev/rules.d fixes this (I don't know whether this is the correct way to handle this)

50-sierra-umts.rules:
SUBSYSTEM=="usb", SYSFS{idProduct}=="6813", SYSFS{idVendor}=="1199", RUN+="/sbin/modprobe usbserial vendor=0x1199 product=0x6813"
SUBSYSTEM=="usb", SYSFS{idProduct}=="6813", SYSFS{idVendor}=="1199", RUN+="/sbin/modprobe sierra"

Carlos Perelló Marín (carlos) wrote :

Using the information found from Windows driver, it's an MC8775 device too.

The attached diff should be enough to get it working well with Gutsy.

Mikael Sennerholm (mikannet) wrote :

Patch works for me with my Thinkpad X61s

Tim Gardner (timg-tpi) wrote :

Gutsy commit 6a7024949b3c26ce3027995218159d49b151ff67

Changed in linux-source-2.6.22:
importance: Undecided → Low
status: Confirmed → Fix Committed
Ben Collins (ben-collins) wrote :

linux-source-2.6.22 (2.6.22-11.34) gutsy; urgency=low

  [Alan Stern]

  * USB: disable autosuspend by default for non-hubs
    - LP: #85488

  [Ben Collins]

  * ubuntu: Enable LEDS_TRIGGERS and related options
    - Needed for iwlwifi
  * ubuntu: Add real ABI files for virtual flavour
  * ubuntu: Re-enable missing CONFIG_SERPENT for hppa64
    - Noticed by Lamont
  * ubuntu: Add linux-headers postinst to handle hooks
    - LP: #125816
  * ubuntu: Add support for /etc/kernel/headers_postinst.d/ to
    headers-postinst
    - LP: #120049
  * cell: Add binary-custom flavour "cell" to support ps3

  [Mattia Dongili]

  * sony-laptop: restore the last user requested brightness level on
    resume.
    - LP: #117331

  [Tejun Heo]

  * ata_piix: fix suspend/resume for some TOSHIBA laptops
    - LP: #139045
  * PCI: export __pci_reenable_device()
    - needed for ata_piix change

  [Tim Gardner]

  * Enable Sierra Wireless MC8775 0x6813
    - LP: #131167

  [Zhang Rui]

  * ACPI: work around duplicate name "VID" problem on T61
    - Noted by mjg59

 -- Ben Collins <email address hidden> Sun, 16 Sep 2007 22:31:47 -0400

Changed in linux-source-2.6.22:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers