Please upgrade Thinkpad_acpi to 0.19-20080321 to solve problems for recent Thinkpads

Bug #129125 reported by Darren Albers on 2007-07-29
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: linux-source-2.6.24 (and 2.6.26 for post-Hardy)

Thinkpad_acpi 0.19-20080321 is available for 2.6.23 through 2.6.26, so the backporting effort should be essentially done for the Ubuntu team. The current version packaged with Hardy (2.6.24-based) is 0.17. The litany of features and fixes can be found in the release notes for the intervening releases, including a number of issues for newer Thinkpad laptops and tablets including:

  * Fix numerous problems and bugs in the NVRAM polling support
  * Fix severe problems in the 16-level brightness support
  * Add functionality to disable brightness support if there is ACPI standard support for it in the BIOS
  * Update backlight support according to comments from the linux-acpi ML. Now it can be selected at runtime
  * Fix brightness error path
  * Notify userspace of hot-unplug events that wake up the box
  * Lenovo keymap changes to avoid duplicate brightness up/down events.
  * Fix NVRAM polling support to deal properly with hotkey_mask
  * Reason for wake-up reporting added (mainly for eject/undock)
  * New *61 HKEY events
  * poll()/select() support in a few key attributes
  * Fixes to the NVRAM polling interface
  * always track input device open/close
  * synchronize input device switches
  * switch Lenovo BIOS to ACPI backlight mode
  * make the video output feature optional
  * issue input events for tablet swivel events
  * improve thinkpad-acpi input device documentation
  * minor hotkey_radio_sw fixes
  * tablet-mode reporting
  * enhance box identification output
  * rate-limit CMOS/EC unsynced error messages
  * fix brightness dimming control bug
  * add support to leds with readable status
  * prepare light and LED for sysfs support
  * add sysfs led class support for thinklight (v3)
  * Add support for hardware accelerated LED flashing
  * Fix led trigger/list_lock locking bugs

http://sourceforge.net/project/showfiles.php?group_id=117042

Sitsofe Wheeler (sitsofe) wrote :

Here's the git tree for the driver http://repo.or.cz/w/linux-2.6/linux-acpi-2.6/ibm-acpi-2.6.git . It would be interesting to find out whether this newer version would autoload the thinkpad_acpi module on the lenovo T60 I am using...

Ankit Jain (luckyankit) wrote :

Can you please list what are the issue resolved by this patch?

Christoph Lechleitner (lech) wrote :

thinkpad_acpi 0.16 from
http://sourceforge.net/project/showfiles.php?group_id=117042&package_id=230205
can easily applied to Ubuntu's 2.6.22 kernel source.

I am not sure what it does solve (e.g. for my T61p), I am still fighting for suspend/resume ;-))

Also, I still have two /proc/acpi/video/VID entries.

Robbob (rob-kirkbride) wrote :

Please see bug #139089 which is related.

Henrik Nilsen Omma (henrik) wrote :

Wishlist item: please backport the Thinkpad_acpi driver from 2.6.23.

Changed in linux-source-2.6.22:
importance: Undecided → Wishlist
status: New → Confirmed
relik (dkennedy) wrote :

Agreed, would also like to see this.

Is this possible before the gutsy realease?
or should I learn how to compile my own kernel?

Eric S. Raymond (esr-thyrsus) wrote :

Another vote.

Paul C. Bryan (pbryan) wrote :

Another vote too!

Mats Sjöberg (mats-sjoberg) wrote :

Yes another vote. This has started to annoy me since I found a work-around for the suspend-issue I had (bug #153545 https://bugs.launchpad.net/bugs/153545).

Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Changed in linux:
status: New → Incomplete

Not fixed on T61 Kubuntu 64bit on Hardy 2.6.24.3 kernel

Daniel Hahler (blueyed) on 2008-01-16
Changed in linux:
status: Incomplete → Confirmed

Can you be a little more specific about what's not fixed with the latest 2.6.24 kernel? Or better yet, open a new bug report? The reason I say this is that the thinkpad_acpi driver is currently at version 0.17 for the Ubuntu kernel 2.6.24. This resolves the original request (at least for Hardy) for wanting a newer version of the driver included. Thanks.

Changed in linux:
status: Confirmed → Fix Released
Noel J. Bergman (noeljb) wrote :

> the thinkpad_acpi driver is currently at version 0.17 for the Ubuntu kernel 2.6.24.

Yes, but ThinkPad ACPI is currently at either 0.18 with a bunch of T61 specific fixes, or 0.19 for the current code (which documents that it may have a T61 related regression). Unfortunately, this very much seems to be hitting a moving target at the moment. The upstream site indicates that the current code is the basis for what should be in 2.6.25. What is planned to be the kernel for Hardy?

Noel J. Bergman (noeljb) wrote :

> What is planned to be the kernel for Hardy?

Yes, I know what it is today. Just wasn't sure if there was any thought to anything other than 2.6.24.x-y prior to the Ubuntu I-release.

Hi Noel,

As of now the version of thinkpad_acpi that will be in Hardy will most likely be 0.17. However, it looks like the upstream mainline kernel has already moved to version 0.19. I can ask the kernel to team to consider syncing with the 0.19 version from the upstream mainline kernel. Let me know if this is what you'd like to have happen since you mentioned it may have T61 related regressions. Thanks.

Changed in linux:
status: Fix Released → Incomplete

Also just adding a note that we'll be keeping this report open against the actively developed kernel but against linux-source-2.6.22 this will be closed. Thanks.

Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Noel J. Bergman (noeljb) wrote :

Leannn,

Is the upstream kernel that has moved to 0.19 going to be pulled into Hardy? I ask in part because of the hotswap bay regression, which I keep checking each time there is a new kernel for Hardy, and it is still broken.

As for 0.19, all that I know of it is what they say in http://sourceforge.net/project/shownotes.php?release_id=576304&group_id=117042 and the other release notes (http://sourceforge.net/project/showfiles.php?group_id=117042&package_id=230205)

0.19 is a date-stamped-work-in-progress, with that particular T61 related regression being less than a week old. Who knows what will be the case by KernelFreeze?

Hi Noel,

I see what you're asking now :) So the Hardy kernel was most recently synced with the upstream stable 2.6.24.2 release. Hardy development recently entered Feature Freeze which most likely means that there will be no more upstream syncing (ie Hardy will not be synced with an upstream 2.6.25-rcX release). Typically only bug fixes will be going in. Since the upstream thinkpad_acpi 0.19 version of the driver seems to be under development it will most likely not be pulled into Hardy. Care to maybe update the title and summary of this bug report to reflect the newer version you'd like to see pulled in and we'll target getting things resolved in Hardy+1. Thanks.

Noel J. Bergman (noeljb) wrote :

Leann,

As you can see from http://sourceforge.net/project/showfiles.php?group_id=117042 there is a new release for 2.4.26 AND backports already provided for 2.6.23+, including the 2.6.24 backport necessary for Hardy. Since the 2.6.24 backport has already been done, can we get that pulled over before kernel freeze?

Noel J. Bergman (noeljb) wrote :

> Care to maybe update the title and summary of this bug report to reflect the newer version

Done.

description: updated
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

In the meantime as a possible solution here, you may want test the Intrepid Ibex 8.10 kernel? It was most recently rebased with the upstream 2.6.25 kernel (which contains version .20 of the driver) and is currently available in the following PPA:

https://edge.launchpad.net/~kernel-ppa/+archive

If you are not familiar with how to install packages from a PPA basically do the following:

Create the file /etc/apt/sources.list.d/kernel-ppa.list to include the following two lines:

deb http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main
deb-src http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main

Then run the command:

sudo apt-get update

You should then be able to install the linux-image-2.6.25 kernel package. I'll try to bring this to the kernel teams attention for consideration for Hardy's 8.04.1 point release. Thanks.

Noel J. Bergman (noeljb) wrote :

Leann,

I did as you suggested to /etc/apt/sources.list.d/kernel-ppa.list. But I don't see linux-image-2.6.25 as an available package:

# apt-cache show linux-image-2.6.25
W: Unable to locate package linux-image-2.6.25
E: No packages found

I did see, and install:
# dpkg -l | grep 2.6.25
ii linux-doc-2.6.25 2.6.25-1.2ubuntu3 Linux kernel specific documentation for vers
ii linux-headers-2.6.25-1 2.6.25-1.2ubuntu3 Header files related to Linux kernel version
ii linux-headers-2.6.25-1-generic 2.6.25-1.2ubuntu3 Linux kernel headers for version 2.6.25 on x
ii linux-image-2.6.25-1-generic 2.6.25-1.2ubuntu3 Linux kernel image for version 2.6.25 on x86
ii linux-libc-dev 2.6.25-1.2ubuntu3 Linux Kernel Headers for development
ii linux-source-2.6.25 2.6.25-1.2ubuntu3 Linux kernel source for version 2.6.25 with

We'll see if it helps. Mind you, not having the restricted modules may be an issue.

Noel J. Bergman (noeljb) wrote :

Yeah, with the above I can test the proposed 2.5 kernel, but with only basic graphics and no wireless. Gives me some hope for the Ibex test cycle.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Սահակ (petrosyan) wrote :

the new 2.6.27 kernel resolves this bug.

The new kernel uses ThinkPad ACPI Extras v0.21

Changed in linux:
status: Triaged → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers