[gutsy] no sound with SAA7134 - pci id 1102:0005

Bug #128585 reported by Åskar on 2007-07-26
4
Affects Status Importance Assigned to Milestone
GStreamer
Unknown
High
alsa-driver (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Undecided
Ubuntu Audio Team
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

There is no sound in my Ubuntu, When I choose volumecontrol all I see is "SAA7134 (alsa mixer)" in the titlebar of the window, the rest is gray.

Marco Rodrigues (gothicx) wrote :

What version of Ubuntu are you running ?

Marco Rodrigues (gothicx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the information requested from the "Reporting Sound Bugs" section of [WWW] https://help.ubuntu.com/community/DebuggingSoundProblems as separate attachments.

Åskar (olskar) wrote :

Im using gutsy gibbon with all latest updates.

Åskar (olskar) wrote :

I attach a tar.gz file with textdocuments.
Here is an explanation of the files:

"1.txt" is output of "tail -2 /proc/asound/oss/sndstat"
"2.txt" is output of "amixer"
"3.txt" is output of "lspci -nv"
"4.txt" is output of "asoundconf list"
"dmesg.txt" is output of "dmesg"
"6.txt" is output of "cat /proc/interrupts"

Changed in alsa-driver:
assignee: gothicx → nobody
status: Incomplete → Confirmed
assignee: nobody → ubuntu-audio
Åskar (olskar) wrote :

I also reported this bug to bugzilla.gnome.org, you find it here
http://bugzilla.gnome.org/show_bug.cgi?id=462799

They say among other things this:
"There is a problem with your alsa-plugin (alsasink). You need to discuss this
with your distribution."

Changed in alsa-driver:
importance: Undecided → Medium
status: Confirmed → Triaged
Marco Rodrigues (gothicx) wrote :

Try now with Gutsy Beta to see if you have the same problem. A lot of things have changed...

Christopher Denter (dennda) wrote :

Hi.
This is Gutsy with latest updates.
I have the very same problem.
The system tells me it's the sound device mentioned in the topic.
It worked out of the box with Feisty, but after upgrading to gutsy sound fails miserably.
So unfortunately, nothing has changed with Gutsy Beta regarding this issue.

00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
---------------------------
dennda@blackbox:~$ cat /proc/asound/cards
 1 [SAA7134 ]: SAA7134 - SAA7134
                      saa7134[0] at 0xfebffc00 irq 22
---------------------------
"aplay --list-devices" doesn't show devices.
---------------------------
00:10.1 Audio device [0403]: nVidia Corporation MCP51 High Definition Audio [10de:026c] (rev a2)
        Subsystem: Micro-Star International Co., Ltd. Unknown device [1462:7350]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0 (500ns min, 1250ns max)
        Interrupt: pin B routed to IRQ 10
        Region 0: Memory at f9ff8000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
---------------------------

So sound doesn't work at all.

If you need any further information, please feel free to tell me.
I am very eager to getting this bug fixed.

regards

Christopher Denter (dennda) wrote :

(Where's the edit-button?)

I attached the files requested by the above mentioned wiki.

regards

Christopher Denter (dennda) wrote :

Hi.
While you read the below, keep in mind that this system originally was a server system. I then added the packages I needed and upgraded from feisty to gutsy.

So now, with help from a nice guy on #ubuntu+1, I was able to solve this issue.
The system ran with Kernel 2.6.22-12-386.
I needed to modprobe snd-hda-intel.
This wasn't provided by 2.6.22-12-386, so I did:
- sudo apt-get install apt-get install linux-image-2.6.22-12-generic linux-restricted-modules-2.6.22-12-generic
The module snd-hda-intel is provided by linux-ubuntu-modules-2.6.22-12-generic.
So:
- sudo apt-get install linux-ubuntu-modules-2.6.22-12-generic
Then load the module:
- sudo modprobe snd-hda-intel

And now, listen to some nice music. That's all. Sound then worked for me.
But I still am wondering: Why didn't this work out of the box? Why did it work with Feisty out of the box, but not with gutsy? Due to the upgrade? Will it work if I perform a fresh gutsy install? Or do I have to repeat these steps?

regards.

Åskar (olskar) wrote :

Any progress on this one? :)

Emil Sit (emilsit) wrote :

Can you confirm that the same problems still exists for you with Gutsy final, with the same error logs? Have you tested a Hardy installation/LiveCD?

Thanks!

Åskar (olskar) wrote :

This problem is still in latest hady installation but bug 63352 is better place to discuss this I think

Emil Sit (emilsit) wrote :

Hardy also has bug 212271.

Changed in gstreamer:
status: Unknown → Invalid
Daniel T Chen (crimsun) wrote :

Does this issue still exist in the Hardy Heron 8.04 LTS release? If so, the Intrepid Ibex 8.10 Alpha2 is also scheduled for release today. It will appear at the following when available: http://www.ubuntu.com/testing/intrepid/alpha2 . It contains the actively developed 2.6.26 Ubuntu kernel. It would be great if you could test this upcoming release via a LiveCD and verify if the issue still exists. If so, please include the appropriate debugging information as outlined at https://wiki.ubuntu.com/DebuggingSoundProblems . Thanks in advance.

Changed in alsa-driver:
status: New → Won't Fix
Changed in linux-source-2.6.22:
assignee: ubuntu-audio → nobody
status: Triaged → Won't Fix
Changed in linux:
assignee: nobody → ubuntu-audio
status: New → Incomplete
Åskar (olskar) wrote :

The problem was with my Creative SB-x-fi card and the bug for that is bug 63352 .

I dont think the problem was with saa7134 and this bug can now be closed.

Hi,

You are correct. PCI ID 1102:0005 is a first-generation X-Fi, not an
SAA7134.

William

On Fri, 2008-07-18 at 11:13 +0000, Åskar wrote:
> The problem was with my Creative SB-x-fi card and the bug for that is
> bug 63352 .
>
> I dont think the problem was with saa7134 and this bug can now be
> closed.
>

Changed in linux:
status: Incomplete → Invalid
Changed in gstreamer:
importance: Unknown → High
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.