CPU fan no longer runs after upgrade to Gutsy

Bug #127772 reported by Scott Kitterman on 2007-07-23
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

On a Dell Latitude L400, the CPU fan no longer runs (and the CPU overheats under stress) after upgrade from Feisty to Gutsy. Additionally (I'll file a separate bug for this) the battery is no longer detected by ACPI.

During boot, before the kernel is started, the fan will run, so it's not a hardware failure. Requested attachments in just a moment.

Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :
Scott Kitterman (kitterman) wrote :

Added since this is may be ACPI related.

Tataucska (tataucska) wrote :

I have Feisty 7.0.4 running on a Dell Latitude L400 as well and I noticed, that the cooling fan only switches on for a few seconds at start up. Than it stops and does not start anymore although the CPU temperature used to go up to 80 C and more. Sometimes it is getting so hot that the laptop switches of. I could not find any configuration possibility. I run the laptop from AC supply. In Gnome Power Management the fan is 2 times mentioned, but without configuration possibilities.

Would be pleased if somebody can help, searching on internet did not give results.

Scott Kitterman (kitterman) wrote :

Odd as the fan worked for me under 7.04, it's just since the upgrade to Gutsy that I've had a problem.

Scott Kitterman (kitterman) wrote :

Still no fan with 2.6.22-9-386

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Medium
status: New → Triaged
Scott Kitterman (kitterman) wrote :

Marking invalid because my fan came back in Gutsy without a new kernel, so wherever the problem was, it wasn't the kernel. Works now in any case.

Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-acpi → nobody
status: Triaged → Invalid
Tataucska (tataucska) wrote :

My fan problem is solved, but in a rigorous way. Originally I worked with 7.0.4 upgraded from 6.10 when the fan did not work. I backed up my data and through off everything and installed a clean Feisty 7.0.4. Now everything is working fine. An other problem I had has been solved as well. It was the printer properties, which I couldn't adjust, now it works. So I think that during upgrading from an older version some administrative handling is getting corrupt.

Scott Kitterman (kitterman) wrote :

Marking this back to NEW as the fan no longer runs after the initial boot.

Changed in linux-source-2.6.22:
status: Invalid → New
Scott Kitterman (kitterman) wrote :

And now it runs again after updating acpi and hal to the latest just now. Back to invalid ....

Changed in linux-source-2.6.22:
status: New → Invalid
Scott Kitterman (kitterman) wrote :

This problem recurred some time ago, but I was attempting to troubleshoot it further before reopening. I downgraded HAL several revisions with no affect. . With all other packages current, the fan works properly with the -9 kernel. It does not work with either -10 or -11, so I'm pretty certain it's a kernel related issue.

Changed in linux-source-2.6.22:
status: Invalid → Confirmed
Scott Kitterman (kitterman) wrote :

Of course just after I posted the last comment, it doesn't work on -9 either anymore after a number of upgrades, so now I'm guessing it's a combination of different pacakges not communicating effectively. Ugh.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-acpi
Brian Murray (brian-murray) wrote :

Could you please add the a tarball of your '/proc/acpi' directory to your bug report? Thanks in advance.

Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-acpi → brian-murray
status: Confirmed → Incomplete
Scott Kitterman (kitterman) wrote :

Here it is.

Changed in linux-source-2.6.22:
assignee: brian-murray → ubuntu-kernel-acpi
status: Incomplete → Triaged
Scott Kitterman (kitterman) wrote :

So, oddly enough, after an unexpected shutdown last night due to overheating, the system now has a running cooling fan again, but I don't see any recent updates that I would have expected to affect this. ACPI on this system still has issues. This is while on battery:

acpi -Vs
     Battery 1: slot empty
     Thermal 1: ok, 50.0 degrees C
  AC Adapter 1: on-line

Thermal always says 50.0 degrees C

Scott Kitterman (kitterman) wrote :

And after today's acpi update and a reboot. No fan again ...

Scott Kitterman (kitterman) wrote :

And today it works again after the kernel upgrade.

Scott Kitterman (kitterman) wrote :

Apparently the working is unrelated to the updates. Today after rebooting with no updates in between it worked/didn't work. I guess I'll try and get the /proc/acpi added to the bug for when it's not working.

Changed in linux-source-2.6.22:
status: Triaged → Incomplete
Scott Kitterman (kitterman) wrote :

It appears that if the laptop is hot and so the fan is running when the kernel takes control, it's able to control the fan, but if the fan is not running when the kernel takes over, it never runs, the machine overheats, and shuts down.

Here's the /proc/acpi diff between when there is a fan and there is no fan. Please let me know if additional information would be helpful
diff -ruN fan/acpi/processor/CPU0/power nofan/acpi/processor/CPU0/power
--- fan/acpi/processor/CPU0/power 2007-09-18 16:41:08.000000000 -0400
+++ nofan/acpi/processor/CPU0/power 2007-09-18 16:08:24.000000000 -0400
@@ -1,7 +1,7 @@
 active state: C2
 max_cstate: C8
-bus master activity: ffffffff
+bus master activity: ffc0ffff
 maximum allowed latency: 8000 usec
 states:
- C1: type[C1] promotion[C2] demotion[--] latency[000] usage[00001660] duration[00000000000000000000]
- *C2: type[C2] promotion[--] demotion[C1] latency[010] usage[00044141] duration[00000000000404148212]
+ C1: type[C1] promotion[C2] demotion[--] latency[000] usage[00007420] duration[00000000000000000000]
+ *C2: type[C2] promotion[--] demotion[C1] latency[010] usage[00561247] duration[00000000006395914844]

Changed in linux-source-2.6.22:
status: Incomplete → Triaged
Scott Kitterman (kitterman) wrote :

Changing the boot options to acpi=off works around this problem for me.

wkjam (smeadspam) wrote :
Download full text (3.2 KiB)

if i could interject something. BIOS updatat A08 modified some of the acpi thermal zones for the L400 and might lead to issues of over heating for Linux (actually this issue can be seen with Windows 2000 also). I have found that rolling back to BIOS A06 brought ACPI back for Linux. I'll attatch the a tarred /proc/acpi from Xubuntu 7.04 running the A06 BIOS for possible comparision.

[ 0.000000] ACPI: BOOT (v001 PTLTD $SBFTBL$ 0x20010709 LTP 0x00000001) @ 0x0ffffbd9
[ 0.000000] ACPI: DSDT (v001 PTL BX-TJ 0x20010709 MSFT 0x01000007) @ 0x00000000
[ 0.000000] ACPI: PM-Timer IO Port: 0x8008
[ 10.616886] ACPI: Core revision 20060707
[ 10.618760] ACPI: Looking for DSDT in initramfs... file /DSDT.aml not found, using machine DSDT.
[ 10.623205] ACPI: setting ELCR to 0200 (from 0c00)
[ 10.631384] ACPI: bus type pci registered
[ 10.649941] ACPI: Interpreter enabled
[ 10.649954] ACPI: Using PIC for interrupt routing
[ 10.650862] ACPI: PCI Root Bridge [PCI0] (0000:00)
[ 10.651698] PCI quirk: region 8000-803f claimed by PIIX4 ACPI
[ 10.652220] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[ 10.654566] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGP_._PRT]
[ 10.655385] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 *10 11 14 15)
[ 10.656130] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 *10 11 14 15)
[ 10.656706] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 11 14 15) *0, disabled.
[ 10.657309] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 *11 14 15)
[ 10.700500] ACPI: Device [FDDA] status [00000008]: functional but not present; setting present
[ 10.703142] ACPI: Device [CDRM] status [00000008]: functional but not present; setting present
[ 10.709888] ACPI: Power Resource [PFN0] (off)
[ 10.710196] ACPI: Power Resource [PFN1] (off)
[ 10.710363] pnp: PnP ACPI init
[ 10.788292] pnp: PnP ACPI: found 12 devices
[ 10.788308] PnPBIOS: Disabled by ACPI PNP
[ 10.788467] PCI: Using ACPI for IRQ routing
[ 10.792240] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 10
[ 10.792257] ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[ 12.992957] ACPI: (supports S0 S3 S4 S5)
[ 15.679079] ACPI: Transitioning device [FAN0] to D3
[ 15.679089] ACPI: Transitioning device [FAN0] to D3
[ 15.679100] ACPI: Fan [FAN0] (off)
[ 15.679241] ACPI: Transitioning device [FAN1] to D3
[ 15.679248] ACPI: Transitioning device [FAN1] to D3
[ 15.679256] ACPI: Fan [FAN1] (off)
[ 15.692135] ACPI: CPU0 (power states: C1[C1] C2[C2])
[ 15.692151] ACPI: Processor [CPU0] (supports 8 throttling states)
[ 15.700460] ACPI: Thermal Zone [THRM] (50 C)
[ 11.064000] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
[ 11.064000] ACPI: PCI Interrupt 0000:00:07.2[D] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
[ 11.172000] ACPI: PCI Interrupt 0000:00:0d.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[ 31.044000] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10
[ 31.044000] ACPI: PCI Interrupt 0000:00:08.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
[ 32.384000] ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> ...

Read more...

My BIOS rev is A03, so that's not the fundamental problem (although it's
good to know).

wkjam (smeadspam) wrote :

Adding Infomation on the BIOS upgrades past A03 on the L400 from Dell.

==============================
A09 = A08 + the following changes:

Issues Fixed:
1. Fixed System intermittently shutdown issue on W2K.
2. Modified the help text on Battery Auto-Learning page.
3. Fixed an intermittent standby / resume issue when RBATT drains completely.

==============================
Enhancements in A08:

Updated thermal monitoring of BIOS.

==============================
Issues Fixed in A06:

1. Saving and restoring the registers of Cardbus controller properly during
suspend/resume for Softex on APM system.

2. NT4 image will be corrupted when RBat and main battery drain entirely
off.

==============================
Enhancements in A05:

1.Allow HDD Master password to be collaterally checked on every password
prompt.

Fixes:

1.corrected Keyboard description under WinNT4.
2.Fixed "OFF" function for Resume On Modem Ring setting in BIOS.
3.Corrected Power Management functions in MS-DOS.
4.Added PXE boot.

==============================
Enhancements in A04:

1.Advanced thermal support under ACPI.
2.Implemented Auto-shutdown support under APM (NT4).

Scott Kitterman (kitterman) wrote :

Tested with linux-image-2.6.24-1-generic and the CPU fan works just fine.

Changed in linux:
importance: Undecided → Medium
status: New → Fix Released
Scott Kitterman (kitterman) wrote :

Fixed in the developmental release and not SRU worthy, so wontfix for Gutsy.

Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-acpi → nobody
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers