Ubuntu

internal microphone does not work (macbook pro c2d 15)

Reported by ruebezahl on 2007-07-22
10
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by ruebezahl

Bug Description

Binary package hint: linux-source-2.6.22

will ad lspci output tomorrow...

xtknight (xt-knight) wrote :

Possibly related to Bug 127584?

"sudo lspci -vv" would be helpful.

ruebezahl (ruebezahl) wrote :

requested lspci

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output requested at https://help.ubuntu.com/community/DebuggingSoundProblems as attachments? Thanks in advance.

Changed in linux-source-2.6.22:
assignee: nobody → brian-murray
status: New → Incomplete
ruebezahl (ruebezahl) wrote :

ahhhm, which one?
or all of them?

Brian Murray (brian-murray) wrote :

Yes, all of the information in the Reporting Bugs section is necessary for a developer to be able to help you.

ruebezahl (ruebezahl) wrote :

requested outputs follow...

ruebezahl (ruebezahl) wrote :

tail -2 /proc/asound/oss/sndstat

ruebezahl (ruebezahl) wrote :

amixer

ruebezahl (ruebezahl) wrote :

lspci -nv

ruebezahl (ruebezahl) wrote :

asoundconf list

ruebezahl (ruebezahl) wrote :

dmesg

ruebezahl (ruebezahl) wrote :

cat /proc/interrupts

Changed in linux-source-2.6.22:
assignee: brian-murray → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-team → ubuntu-audio
Brian Murray (brian-murray) wrote :

Your dmesg file actually shows you running "[ 0.000000] Linux version 2.6.20-15-generic" which is not Gutsy's kernel. Could you please provide the dmesg file from the right kernel? Additionally this may have been fixed with some recent updates to Gutsy. Are you still having this issue? Thanks again.

Changed in linux-source-2.6.22:
assignee: ubuntu-audio → brian-murray
status: Triaged → Incomplete
Daniele Dellafiore (ildella) wrote :

now it works for me on same hardware.
never worked before.
checked with sound recorder and skype 1.4

I need to enable both capture and mux to get a good input. With just one of the two, the rec volume is very very low.

well done! :)

Changed in linux-source-2.6.22:
assignee: brian-murray → nobody
status: Incomplete → Confirmed
Henrik Nilsen Omma (henrik) wrote :

Marking as Fix Released. ruebezahl, if you are still experiencing the problem, please wait for the 2.6.24 Hardy kernel to be released (in a week or so) and retest with that, then open a 2.6.24 task on this bug if the problem remains.

Changed in linux-source-2.6.22:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers