Ubuntu

gutsy livefs causes random hangs or modprobe crashes

Reported by Martin Pitt on 2007-07-19
34
Affects Status Importance Assigned to Milestone
linux-source-2.6.22 (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

A lot of people have trouble booting the live system (i386 and amd6) of current gutsy Tribe3 candidates.

* Sometimes it gets until X and hangs
* Sometimes modprobe crashes a lot and dmesg is filled with "modprobe: segmentation fault rip:...", and the VTs only show "Module is unknown" lines (and no getty, ethernet, etc.)
* Sometimes it eternally hangs during boot even before X. In the latter case I tried sysrq+8 and syqrq+T to get a call trace, and I saw a lot of processes hanging in a semaphore in squashfs. I couldn't capture this as a screenshot unfortunately. I have a screenshot which hangs in a unionfs semaphore, I'll attach that just in case it might be useful.

Martin Pitt (pitti) wrote :

this is the screenshot from one sysrq+t which seemed very common.

Oliver has hardware which reliably reproduces such hangs (in wildly different manners), and according to him Tribe2 worked on the same hw.

Martin Pitt (pitti) wrote :

http://geekosophical.net/random/gutsytesting/RIMG0308.JPG is elkbuntu's variant of that: modprobe failure. But since this is not reproducible, it might just be a fallout from the same race condition.

Martin Pitt (pitti) wrote :

No chance to fix this for Tribe3, but we should really aim to fix this soon.

Changed in linux-source-2.6.22:
importance: Undecided → Critical
TJ (tj) wrote :

I captured all the logs from this issue and am investigating in as much as it is possible. I've attached the log tarball to this comment for anyone else who wants to take a look.

Martin Pitt (pitti) wrote :

Tentatively assigning to Phillip, since he is currently debugging this and it seems to be a file system corruption in either squashfs or unionfs.

Changed in linux-source-2.6.22:
assignee: nobody → phillip-lougher

OK guys, please give the following liveCD a test http://people.ubuntu.com/~pkl/test-gutsy-desktop-i386.iso

This has a fix for a Squashfs race condition that slipped into the code in April. A fix was released in May, but due to some oversight, the Gutsy kernel code wasn't updated.

This fix makes the liveCD not hang on my tests.

TJ (tj) wrote :

Looks okay to me Phillip.

I did four boots with it and each one loaded the Gnome desktop correctly. There were various errors reported during start-up with udev and acpi (from scripts) but I suspect they're the result of other issues. One time Gnome reported HAL failed at start but I suspect that isn't related either.

Martin Pitt (pitti) wrote :

For more widespread testing I put this on cdimage, for rsyncability against the Tribe image:

  rsync -vP rsync://cdimage.ubuntu.com/cdimage/bug-fix-tests/gutsy-desktop-i386.126964.iso gutsy-desktop-i386.iso

Melissa Draper (melissa) wrote :
  • id Edit (16.6 KiB, application/octet-stream)

Phillip's image boots to the desktop for me, but has a "failed to initialize HAL!" Internal error.

On opening a terminal: /bin/sh: Can't open id

/usr/bin/id is also in an interesting state to say the least:

ubuntu@ubuntu:~$ file /usr/bin/id
/usr/bin/id: MPEG ADTS, layer I, v1, 256 kBits, 44.1 kHz, Monaural

the id file is attached

Works like a charm. Thanks.

On 7/19/07, Phillip Lougher <email address hidden> wrote:
>
> OK guys, please give the following liveCD a test
> http://people.ubuntu.com/~pkl/test-gutsy-desktop-i386.iso
>
> This has a fix for a Squashfs race condition that slipped into the code
> in April. A fix was released in May, but due to some oversight, the
> Gutsy kernel code wasn't updated.
>
> This fix makes the liveCD not hang on my tests.
>
> --
> gutsy livefs causes random hangs or modprobe crashes
> https://bugs.launchpad.net/bugs/126964
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Phil Norbeck
412.398.8130
<email address hidden>

working here too.

Great work, pkl. :)

Phils iso fixes the boot for me, too. Thank you. (Laptop, Samsung X30, before it came until gui mode, but only mouse pointer, no menues)

Please give the following liveCD a test http://people.ubuntu.com/~pkl/test-gutsy-desktop-i386.iso

This has a fix for the occasional file corruption that some people have experienced.

Thanks

Changed in linux-source-2.6.22:
status: New → In Progress
Martin Pitt (pitti) wrote :

Thanks a million, Phillip!

I put the updated CD on http://cdimage.ubuntu.com/bug-fix-tests/ again (including updated md5sum), for rsync love.

Changed in linux-source-2.6.22:
status: In Progress → Fix Released
Mark Stover (mark-stover) wrote :

I saw both problems on an IBM T30. Tribe 3 hung on start up, I restarted with failsafe graphics & got the HAL error. This image fixed both problems. Thanks!

Ludwik Trammer (ludwik) wrote :

I just want to report that I had this problem with Tribe 3 (more information under http://ubuntuforums.org/showthread.php?t=511716) and Phillip's iso fixed it for me. Now after system boots it states in this only-a-cursor-and-plain-background state noticeably longer than under 7.04, but than screen turns black for a second and gnome starts in about 2 seconds.

description: updated
Mellotron (krisajw) wrote :

I am getting this problem, and I am running gutsy 7.10 (released) on a fairly fresh install.
Its 64 bit, and I am also getting a bug that when I try to go to the "Quit" selection (logoff, restart, shuttdown) my computer hangs
is there an actual fix?

Hi,

Mellotron [2007-10-27 9:00 -0000]:
> I am getting this problem, and I am running gutsy 7.10 (released) on
> a fairly fresh install. Its 64 bit, and I am also getting a bug
> that when I try to go to the "Quit" selection (logoff, restart,
> shuttdown) my computer hangs is there an actual fix?

The hangs most other persons were experiencing were actually fixed in
Gutsy final. So it seems you are experiencing a different problem.
Please try to switch to a text console, does that work? If so, if you
type 'dmesg', do you see an "oops"?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers