[Gutsy Tribe 2, Intrepid Alpha 2+] Illuminated keyboard not working on MacBook Pro rev.3 (santa rosa)

Bug #125918 reported by Mike Matis on 2007-07-14
36
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HAL
Invalid
Undecided
Unassigned
Mactel Support
Low
Henrik Rydberg
hal (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Low
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
pommed (Ubuntu)
Undecided
Unassigned

Bug Description

I know, I know, its silly. But hey, a bug's a bug. The keyboard on Apple's latest revision of the MacBook Pro does not illuminate in low light conditions. The problem is probably not so much the keyboard, but the light sensors that trigger the LED's.

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Did this work previously? If so with which version of Ubuntu? Thanks in advance.

Mike Matis (mmatis) wrote :

I've tried Feisty with the MBP Santa Rosa and it didn't work. Don't have a previous gen MBP to try. I'll blow the dust off an Edgy CD and post results.

Brian Barnes (bcbarnes) wrote :

Would this be fixed by having the latest version of the pommed package included in gutsy?

Brian Barnes (bcbarnes) wrote :

Bleh, I want to edit my last comment! hehe. Anyway, maybe applesmc needs to be updated? Pepe claims to have illumination working here (I do not know if it is automatic via sensors):

Keyboard
Works, including illumination via applesmc driver and hotkeys via pommed.

https://cbg.dyndns.org/wiki/ReadingCorner/LinuxOnMacbookPro

Changed in linux-source-2.6.22:
assignee: brian-murray → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
pepe (field-trial) wrote :

It's not automatic. Maybe a question of thresholds in pommed.

With applesmc loaded, you'll get access to the light sensors and kb led via sysfs. pommed is said to be able to adjust these automatically. The keyboard shortcuts work in console and X, as long as you don't use the evdev driver for X. Didn't investigate automatic switching, it looks cool but is only disturbing to me.

till busch (buti) wrote :

after updating pommed from svn to pommed v1.8 ($Rev: 336 $) automatic kbd backlight works fine for me.
i do have to modprobe applesmc manually before starting pommed, though. this was not necessary for feisty.

function-keys work fine: with fnmode=2 i get normal linux-like behaviour for f1-f12 with fn+f8, fn+f9, fn+f10 for the keyboard backlight. in kubuntu, mixer-settings via keyboard (f3-f5) work as well.

i'm unsure how well other pommed related stuff (appleir, ...) works.

Guillaume Pujol (guill-p) wrote :

pommed 1.8 has been officialy released on July, 27th. http://blog.technologeek.org/2007/07/27/69
It includes full support for the MBPv3 (both keyboard and LCD backlight), and makes the automagic backlight adjustement working again with linux 2.6.22.

Please push it for inclusion in Gutsy =).

Blaiz (blaiz) wrote :

Here is how to get the latest pommed working: http://ubuntuforums.org/showpost.php?p=3130398&postcount=176 .

I confirm that it works very well.

Guillaume Pujol (guill-p) wrote :

pommed 1.8 has been commited to Gutsy.
Can someone with a MBPv3 confirm that this bug is fixed ?

Mike Matis (mmatis) wrote :

No, it does not. Installing pommed from the repo fixes the display backlight, but the keyboard backlight is stilll unresponsive. In order to get it to work, you need to install the stuff from mactel-linux (applesmc), at least, that was my experience. Any way to include this?

Mike Matis (mmatis) wrote :

Correction. After installing pommed 1.8 and doing sudo modprobe applesmc in a terminal, the keyboard backlight can be adjusted with the function keys. This can be automated by editing /etc/init.d/pommed and adding "modprobe applesmc" to the "start" section to the script. NOTE: the light sensors do not adjust the brightness, but for me, I'd rather just adjust it myself anyway.

I confirm this bug for Ubuntu 8.10 Alpha 2 64-Bit on a MacBook Pro rev. 3, fully updated. Pressing Fn+F8 has no effect whatsoever, nor does pressing Fn+F9 or Fn+F10.

Can bug # 128786 be regarded as a duplicate of this bug?

Changed in mactel-support:
importance: Undecided → Low

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Changed in linux:
status: Incomplete → New

I see this was confirmed to still be an issue against Intrepid. Can whomever tested against Intrepid attach their dmesg output and also the output of 'cat /proc/version_signature' when running Intrepid? Thanks.

Changed in linux:
status: New → Incomplete

Sorry, no longer have it installed.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Seems like 2.6.27 came earlier than announced. This problem persists with 2.6.27.

Can you attach your dmesg output as well as 'cat /proc/version_signature' ? Thanks.

$ cat /proc/version_signature
Ubuntu 2.6.27-2.3-generic

I don't know how to send you the dmesg output. If I type "dmesg", ENTER I get too much output for the terminal.

Ricky Campbell (cyberdork33) wrote :

pipe the output to a file...

[code] dmesg > dmesg_output.txt [/code]

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Low
status: Incomplete → Triaged
Michael Magua (m-magua) wrote :

Running Intrepid with all updates to date.

(~) michael $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu intrepid (development branch)
Release: 8.10
Codename: intrepid

(~) michael $ cat /proc/version_signature
Ubuntu 2.6.27-3.4-generic

However I compiled 1.20 manually (as it worked for me in Hardy) but no joy.

(~) michael $ pommed -v
pommed v1.20 ($Rev: 494 $) Apple laptops hotkeys handler
Copyright (C) 2006-2008 Julien BLACHE <email address hidden>

Henrik Rydberg (rydberg) wrote :

I believe there are now two problems affecting this bug present in Intrepid:

1. The applesmc might not generate events via /sys/devices/platform/applesmc.768/light, which would be related to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/102270

2. The leds device name changed again, to /sys/class/leds:smc::kbd_backlight/brightness. A possible patch can be found here: http://launchpadlibrarian.net/17832556/fix-leds-filename.patch

Joakim Recht (recht) wrote :

I don't know if it's related, but after upgrading to Interprid, backlight cannot be controlled from X, but if I switch to console, fn+f[789] works as expected.

Henrik Rydberg (rydberg) wrote :

Joakim,

I think that behavior - which I also experience - is due to HAL, which seems to have gradually taken over more and more of the hot key stuff. The problem is that the supplied addons for macbookpro only work for some models up to 3,1, and only barely. This bug seems relevant: https://bugs.launchpad.net/ubuntu/+source/hal/+bug/226894

Henrik Rydberg (rydberg) wrote :

Ok, I have submitted a set of patches upstream, which should fix the keyboard backlight on MBP31, MBP41, and MBA. With the patches, pommed will not be needed on my MBA, but lcd backlight, keyboard backlight, and volume control works via HAL and power management. I am attaching them here, in case somebody would like to try them out.

Henrik Rydberg (rydberg) wrote :
Henrik Rydberg (rydberg) wrote :
Michael Magua (m-magua) wrote :

Do these patches need to be applied to package Hal? If so, what version of Hal? Will it work on Intrepid?

Henrik Rydberg (rydberg) wrote :

The patches are to the upstream git tree, which is at 0.5.12. Intrepid is at 0.5.11. The patches are not likely to appear upstream before 0.5.13, I am awaiting response myself, and will post more info as it becomes available.

Henrik Rydberg (rydberg) wrote :

I have not gotten any response upstream yet - is there any hal maintainer listening on this bug, who would like to test and commit the patches? It would be great to see this in Intrepid. If there are other (better) suggestions on how to solve the problem, I would be happy to hear them.

Neil J. Patel (njpatel) wrote :

Doesn't work with Intrepid beta, fully updated. Function keys work fine from a non-X VT, but not VT-7.

In a (maybe) related matter, the NumLock key(F6) doesn't seem to work either, and neither it or the Caps Lock key illuminate when they are "active".

Ricky Campbell (cyberdork33) wrote :

This seems to be consistant with what is discussed here:
http://ubuntuforums.org/showpost.php?p=5922363&postcount=23

The NumLock Key is the Clear key...

Neil J. Patel (njpatel) wrote :

I've added a couple of other bugs for Intrepid + mactel support:

- Num lock key does not work
  https://bugs.edge.launchpad.net/hal/+bug/282419
- Caps Lock and Num Lock key's "active"light does not switch on
  https://bugs.edge.launchpad.net/hal/+bug/282415

Neil J. Patel (njpatel) wrote :

I've added a couple of other bugs for Intrepid + mactel support:

- Num lock key does not work
  https://bugs.edge.launchpad.net/hal/+bug/282419
- Caps Lock and Num Lock key's "active"light does not switch on
  https://bugs.edge.launchpad.net/hal/+bug/282415

Help is appreciated in getting these bugs noticed by the right projects (i'm unsure which ones to add).

Henrik Rydberg (rydberg) wrote :

Did anyone try the hal patches? They work fine in this end (Intrepid on a Macbook Air).

Krzysztof Janowicz (janowicz) wrote :

i have the same bug, backlight also does not work and the solution described here (https://bugs.launchpad.net/ubuntu/+source/hal/+bug/226894) does not solve the problem.

Henrik Rydberg (rydberg) wrote :

This bug is about the keyboard backlight. The bug you refer to is about the screen backlight. Which backlight type do you have problems with?

Henrik Rydberg (rydberg) wrote :

The hal-applesmc package, available in the mactel ppa, adds support for keyboard backlight via the applesmc sysfs interface. If you have a MacbookPro 3,1 or later, first:

# Remove your machine model from file /usr/share/hal/fdi/policy/10osvendor/10-macbookpro-utils.fdi

# Add mactel PPA to /etc/apt/sources.list
deb http://ppa.launchpad.net/mactel-support/ubuntu intrepid main
deb-src http://ppa.launchpad.net/mactel-support/ubuntu intrepid main

# Update sources
sudo apt-get update

# Get the hal-applesmc
sudo apt-get install hal-applesmc

Changed in mactel-support:
assignee: nobody → rydberg
status: New → Fix Released

Note that there still seem to be people writing on the duplicate.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Pedro Villavicencio (pedro) wrote :

rydberg is there an upstream bug for the patch? may you please tell us the number ? Thanks in advance.

Pedro Villavicencio wrote:
> rydberg is there an upstream bug for the patch? may you please tell us
> the number ? Thanks in advance.
>

The patches were sent to the hal mailing list many months ago, and I
recently got an answer from <email address hidden> saying they wont be
needed anymore (as of some unspecified version of hal), as the applesmc
device should now be picked up by the leds interface.

If it does not work in jaunty, the appropriate action is most likely to
file a new bug against hal.

Cheers,
Henrik

I'll close the upstream HAL bug watch for now until there is a bug # to associate it with.

Changed in hal:
status: New → Invalid

Can anyone confirm this issue remains with Jaunty? http://www.ubuntu.com/getubuntu/download . Thanks.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Kenneth Perry (thothonegan) wrote :

I can confirm its still an issue for the default install of Kubuntu Jaunty (reinstalled it a week ago) for MacBookPro 4,1.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

If this is about the "ambient light sensor" it does not work on Jaunty 64-bit installed on a MBP5,1.

Nikos

Changed in linux (Ubuntu):
status: Confirmed → Invalid

Is this still an issue for you? What Ubuntu version do you use? Thank you for telling us!

Changed in pommed (Ubuntu):
status: New → Invalid
Changed in hal (Ubuntu):
status: New → Incomplete
Changed in hal (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers