[gutsy] 2.6.22 kernel option vga=xxx does not work

Bug #120747 reported by C de-Avillez on 2007-06-16
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

linux-2.6.22-generic does not have the vesafb module available. As a result, an upgrade that has grub (or lilo) using a VGA=xxx kernel parameter ends up with an unusable console.

Ben Collins (ben-collins) wrote :

Not so, vesafb is built into the kernel now.

Changed in linux-source-2.6.22:
status: Unconfirmed → Rejected
Martin-Éric Racine (q-funk) wrote :

Built-in or not, vga=XXX fails with this kernel, which, as the original reporter mentioned, leaves someone without a console after a dist-upgrade. This needs to be fixed ASAP, as the console often is the only way to rescue a system, especially in the case of a server.

Martin-Éric Racine (q-funk) wrote :

Yes, so. It doesn't support vga=XXX as expected. Reopening.

Changed in linux-source-2.6.22:
status: Invalid → Confirmed
C de-Avillez (hggdh2) wrote :

Hum. Further tests show that I can get it working *IF* I specify the VGA option with a hex value. For example, I had my systems originally set with 'vga=792' -- which, we know already, does not work. Now, by bootting with 'vga=0x31a' I did get my FB console.

So. It would be nice if this was documented -- if indeed, this is how it should work.

Adam (adam.russell) wrote :

I was using vga=0x31B in Feisty, but it no longer works in Gutsy. I don't think it has to do with being represented in hex value.

Henrik Nilsen Omma (henrik) wrote :

Hi, could you test if the fix described in bug 129910 works in your case as well. If it does please mark this as a duplicate of 129910. Thanks.

Changed in linux-source-2.6.22:
status: Confirmed → Incomplete
Martin-Éric Racine (q-funk) wrote :

Yes, adding 'fbcon' to the initramfs modules list fixes it for me.

C de-Avillez (hggdh2) wrote :

did not work with me, at 2.6.22-11. Will now try previous kernel levels to see what happens.

Adam (adam.russell) wrote :

The fix works for me, as well, but hggdh is the original reporter. If it doesn't work for him, it must not be the same bug.

C de-Avillez (hggdh2) wrote :

it is now the same bug :-)

it works now, as long as I pass the vga= in hex.

C de-Avillez (hggdh2) wrote :

marked as duplicate of bug 129910

komputika (info-komputika) wrote :

Got no luck with the workaround here.
using vga=0x318

maddler@aubergine [4|~/thunderbird-maddler] $ uname -a
Linux aubergine 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce Go 7600] (rev a1)

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers