Ubuntu

Gutsy shutdown doesn't

Reported by jerrylamos on 2007-06-08
This bug report is a duplicate of:  Bug #181892: Hardy Alpha Shutdown Doesn't. Edit Remove
26
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

Gutsy shutdown hangs, no message on screen, keyboard unresponsive
- No message on screen - other Linux's will display "system will halt now" or other such indication. Screen below the progress bar is just blank.
- Edgy shutsdown just fine on the same system.
- Feisty also fails with similar indications; I don't know if the problem is the same. I'll look to see if there is a Fesity "workaround".
- after I THINK Gutsy has stopped, I do reset, then power off. So far no fsck problems?

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
4. Please run the command 'sudo dmidecode > dmidecode.log' and attach the resulting file 'dmidecode.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in linux-source-2.6.22:
status: Incomplete → Invalid
jerrylamos (jerrylamos) wrote :

Here's uname -a:

Linux linuxGutsy 2.6.22-10-generic #1 SMP Wed Aug 22 08:11:52 GMT 2007 i686 GNU/Linux

Attached is dmesg.log

jerrylamos (jerrylamos) wrote :

Attached is lspci-vvnn.log

jerrylamos (jerrylamos) wrote :

Here's output from sudo dmidecode > dmidecode.log

jerrylamos (jerrylamos) wrote :

The following patch worked for Tribe 5. Strange how Edgy and Dapper and Puppy ... shutdown O.K. but Feisty and Gutsy Tribe 5 don't. Maybe there's a clue for you in what the fix may do.

Cheers, Jerry

"Shutdown" doesn't
This system powers off with Edgy, Dapper, Knoppix, ... but not Feisty. If I select Shutdown after a while nothing's happening, there's no message on the screen, and the keyboard and mouse are dead. Someone on some forum (where?) suggested:
Do sudo gedit /etc/modules. Add the following line, then save:
apm power_off=1
do sudo gedit /boot/grub/menu.lst (where the l is a lower case L). Find the line that start with "kernel" and add this onto the end, no carriage return, all on the same line which probably wraps over:
acpi=off apm=power_off
then save. Power off however you can, power back up and on "Shutdown" it should. Mine did.
Usual cautions apply when changing system files.....

Changed in linux-source-2.6.22:
assignee: brian-murray → ubuntu-kernel-acpi
importance: Undecided → Medium
status: Invalid → Triaged
Adam Barbary (home-adambarbary) wrote :

I can confirm a similar scenario with Gutsy. Clicking the shutdown just hangs the system with the desktop image. Virtual consoles cannot be opened and a hard reset is required.

AMD 2400
nForce motherboard
1GB Ram
nVidia FX5500
IDE Main drive (XP,Ubuntu)
SATA Raid1 storage

Jouke74 (hottenga) wrote :

Same problem here. Beta Xubuntu Alternate and Desktop CD Hang on shutdown. Never had this problem before. Feisty runs fine.

AMD 4200 X2
nforce4 A8N SLI Premium.
2 GB ram.
ASUS ATI X1600Pro
WD 74 GB raptor + WD 250 GB caviar.
XP + Ubuntu Gutsy

Noel L. Vivar (nlvivar) wrote :

Same problem here. Here's the requested attachments.

Noel L. Vivar (nlvivar) wrote :
Noel L. Vivar (nlvivar) wrote :

Linux megatron 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

jerrylamos (jerrylamos) wrote :

Released Gutsy Ubuntu 7.10 still hangs on shutdown on this computer. Here's the old workaround from Feisty from 6 months ago:
Do sudo gedit /etc/modules. Add the following line, then save:
apm power_off=1
do sudo gedit /boot/grub/menu.lst (where the l is a lower case L). Find the line that start with "kernel" and add this onto the end, no carriage return, all on the same line which probably wraps over:
acpi=off apm=power_off
then save. Restart. On "Shutdown" it should. Mine did.
Usual cautions apply when changing system files.....
Jerry

larryleezard (grantburns) wrote :

I don't know if this is related but I had a shutdown issue with feisty and gutsy, it was module snd-hda-intel that would hang. (black screen no info) So what I did was went to the script for the actual halt command in /etc/init.d opend the halt script and at the top of it added rmmod snd-hda-int so it unloads that modual at the start of shutdown. Works a charm.

larryleezard (grantburns) wrote :

Sorry the command at the top of the halt script is rmmod snd-hda-intel

Glenn (glenn-e-williams) wrote :

I am experiencing this issue on an Inspiron 700m laptop. It happens about 50% of the time. I installed Gutsy fresh, not an upgrade.

glenn@Argon:~$ uname -a
Linux Argon 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

dmesg.log is attached.

Glenn (glenn-e-williams) wrote :

Here is the next attachment

Glenn (glenn-e-williams) wrote :

And the last attachment

marpau (tallman14) wrote :

Same problem here on a Compaq Presario 6000.

uname -a:
Linux marpau-desktop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

marpau (tallman14) wrote :
marpau (tallman14) wrote :
Durand D'souza (durand1) wrote :

Thanks Jerry, worked like a charm :)

ThomThom (thomas-thomthom) wrote :

I'm having this issue on my VIA EPIA SP 13000.

When I disable the boot splash screen I'm faced with this:

---
 System is shutting down, please wait...
---

NetworkManager: <WARN> mn_signal_handler(): caught signal 15,
shutting down normally.

NetworkManager: <info> Caught termination signal

NetworkManager: <debug> [1193573771.092816] nm_print_open_socks()
Open sockets List:

NetworkManager: <debug> [1193573771.092816] nm_print_open_socks()
Open sockets Done.

NetworkManager: <WARN> nm_hal_deinit(): libhal shutdown failed -
Did not receive a reply. Possible causes include: the remote
application did not send a reply, the message bus security policy
blocked the reply, the reply timeout experied, or the network
connection as broken.

[ 226.137045] System halted.

"sudo dmidecode > dmidecode.txt" returns dmidecode.txt with just this;

# dmidecode 2.9
# No SMBIOS nor DMI entry point found, sorry.

thomas@Mini-Me:~$ uname -a
Linux Mini-Me 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

I'm not sure if it's relevant, but upon boot I see a message saying something like; "no DMI BIOS year, acpi=force is required to enable ACPI"

ThomThom (thomas-thomthom) wrote :
ThomThom (thomas-thomthom) wrote :

Turns out that ACPI was my problem. I force enabled it and it now shuts down correctly. I suppose it's the BIOSs fault for not identifying it's year? It's from 2005.

Ron Rhodes (owdronrhodes) wrote :

Only needed to add apm power_off=1 to /etc/modules after installing ubuntu/xubuntu gutsy on a couple of old Win98 desktops.

Not sure this is the same bug but :

Recent desktop system (AMD Sempron, NVidia chipset) which was shutting down perfectly with Feisty now sporadically hangs on shutdown after upgrade to Gutsy (kernel 2.6.22-14-generic).

Not easy for me to be very specific, the machine is 400 miles away, it's a friend's machine which I administer from remote using SSH and of course I have no access to it when hanged on shutdown... According to the reports I got from her, machine stays forever on shutdown splash screen and nothing else happens. I have remotely deactivated the splash screen in grub's menu.lst to see if it can help or check last system messages from now on.

Syslog doesn't show anything special after such a hang.

She reported to me having had some filesystem errors reported at mount time after a forced reboot in such situation, so that's possible that hanging happens before the system is actually completely down.

Machine uses the NVIdia proprietary X11 driver as well as ndiswrapper + sis163u driver for a Wi-Fi USB thing and I was suspecting one of them to be the cause of the issue - I've seen that losing the Wi-Fi connection sometimes hangs the system in Gutsy where it wouldn't happen in Feisty, although the "Windows" driver used by ndiswrapper is the same, so I was suspecting something weird could happen when shutting down networking.

carpelo (carpelo) wrote :

Same here. Didn't shutdown on Feisty or Gutsy.

When booting i get the message:
DMI not present or invalid
ACPI: No DMI bios year, acpi=force is required to enable ACPI

My bios is from 2004.

uname -a
Linux dunduntu 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

sudo dmidecode:
# dmidecode 2.9
# No SMBIOS nor DMI entry point found, sorry.

dmesg.log attached.

carpelo (carpelo) wrote :

lscpi-vvnn attached.

carpelo (carpelo) wrote :

Well, i think i've fixed it :)

ThomThom, me too, my bios doesn't identify itself as a 2004 bios and the kernel avoids loading acpi.

I added this option to force it:
acpi=force
at the end of the kernel booting line at /boot/grub/menu.lst:
kernel /boot/vmlinuz-2.6.22-14-generic root=... ro quiet splash acpi=force

Now my computer shutdowns under Gutsy :)

I hope this helps!

Glenn (glenn-e-williams) wrote :

Ok, I tried the acpi=force workaround and it's worked for 3 shutdowns. Unfortunately, since my problem only happened about 50% of the time, I can't say for certain if it's fixed the problem, but it looks good so far.

Glenn (glenn-e-williams) wrote :

Ok - this bug is clearly conscious, intelligent and mischievous. It waited until I had made that last post, then came back. acpi=force did not work for me, unfortunately.

I too have this bug. It is really quite irritating!

Uname -a: Linux steve-desktop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

I am also experiencing same issue on my Dell Inspiron 700m laptop.
I have installed fresh ubuntu 7.10.

I have tried all below specified options :
1) adding "acpi=force"
2) removing "splash"
3) removing "ro quiet splash"

Nothing worked for me.

Only shutdown works from command prompt with following commad.
shutdown -P now

As Glenn mentioned this bug is clearly conscious on 700m laptop

jerrylamos (jerrylamos) wrote :

This works for me as on my post dated 2007-08-23. Take caution on changing system files:
Do sudo gedit /etc/modules. Add the following line, then save:
apm power_off=1
do sudo gedit /boot/grub/menu.lst (where the l is a lower case L). Find the line that start with "kernel" and add this onto the end, no carriage return, all on the same line which probably wraps over:
acpi=off apm=power_off
then save. Power off however you can, power back up and on "Shutdown" it should. Mine did.
Jerry

Applied changes as per instruction.
Now system sometime shutdowns without issue. sometime not.
Unpredictiable.
Issue is not completly resolved.

After every 37 times boot.
System gives error /dev/sda3 is mounted 37 times.

I got this error message 3 times in week.
It seems to be during shutdown disk is not getting umounted.

jerrylamos (jerrylamos) wrote :

Linux does a scheduled fsck (file system check) after a certain number of boots. It takes a while and there should be a progress bar. I've seen 27, 37, you name it. Any time it finds what it thinks is an error it will give directions and ask permission to fix something. Any time I've had an fsck failure fsck screwed up a fix and it was time to re-format the partition. It's been possible to save files from the partitions before the re-format.

If I fumble around the help files it will say how to set the scheduled mounts per fsck for a partition. I've tried 1000000 without much luck. I don't know the max.

fsck is similar to the Windoze file system check it does when it thinks the system was turned off without shutdown. fsck seems to be a common tool across different Linux's.

Now if I do an install on a dual or triple or quad boot, install changes the partition's UUID. This is messy because booting one of the other images won't be able to find the previous UUID to do an fsck on it so fsck fails. Do an "exit" to continue, or Ctrl-Alt-Del. With a bit of editing on /boot/grub/menu.lst and /etc/fstab this can be straightened out. As far as I can tell, Ubuntu developers have no intention of fixing this mess.
Jerry

I switched to the i810 driver and loaded the 915resolution package to display resolution too 1280x800. Now shutdown/restart/hibernate issue is completely got resolved for my laptop 700m.

Below are step to switch back to i810 drivers.
Issue following command either from the command line or by botting in recovery mode

sudo dpkg-reconfigure xserver-xorg

Select i810 graphics driver.

This will give you 1024x768 mode, to get resolution 1280x800 install 915resoluation using following command.

sudo apt-get install 915resolution

Then edit /etc/default/915resolution to contain:

MODE=auto
XRESO=1280
YRESO=800

And reboot your system.

This worked for me. Refer below URL for more detail
http://wiki.ubuntuforums.org/showthread.php?t=579781&page=9

After some tests with a machine that wouldn't shut down since upgraded to Gutsy and was shutting down perfectly in Feisty, I could trace the problem down to the "Network Manager".

This machine uses a Wi-Fi network connection using ndiswrapper + Network Manager, and hangs shutting down in Gutsy.

I have moved the network connection out of the Network Manager, to standard "Debian" interface management defined with all relevant parameters in /etc/network/nterfaces.

This has solved the problem immediately, and now the machine shuts down perfectly.

I feel this bug puts together a number of issues that may be different albeit with the same end effect : machine doesn't halt properly, but it seems that the question doesn't always relate to kernel or ACPI.

It would be interesting to isolate the problem for machine which used to shut down properly in Feisty but don't anymore in Gutsy. In my case, the Network Manager is clearly the cause.

Bambur (stub2003) wrote :

I faced the same problem with my old IBM Thinkpad 380Z after installing Ubuntu 7.10 onto it -- the laptop did not shutdown. However, with Ubuntu 6.06.10 it used to. I added acpi=off and apm=on to the kernel booting line in /boot/grub/menu.lst, and also apm power_off=1 to /etc/modules. And I confirm Ubuntu starts up without "acpi=force is required" message and the laptop shutdowns properly.

filoart (filoart) wrote :

I've solved the problem as jerrylamos suggests, but only modifying the file /etc/modules.
I've no touched the menu.lst and the laptop shuts down properly.

these are my files:
a name:
Linux alberto-laptop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

dmesg attached

filoart (filoart) wrote :

next file attached

filoart (filoart) wrote :

last file attached

Buffaloed (buffaloed) wrote :

uname -a Linux cheeseburger 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Shutdown problem occurred when I disabled Power Management in System--->Preferences--->Sessions
Screen froze, no mouse/menus unresponsive
keyboard shortcut: Ctrl+Alt+Backspace used to shutdown from login options menu

Problem resolved immediately with re-enabling Power Management and has not recurred.

Logs attached in tar to show both conditions. The logs appended with "1" are when shutdown failure was occurring. Hope that helps!

I've had this issue before with the 2.4 kernel. I fixed it on my 2.6 kernel by adding the following to the end of the to the grub menu.lst kernel line:

acpi=force apm=off

Chris Haag (chaag123) wrote :

+1 to this causing/fixing the issue
Shutdown problem occurred when I disabled Power Management in System--->Preferences--->Sessions

Linux xxx 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

Running an old Dell Dimension 3000

Matt Jones (mjones41) wrote :

Jerry's first mod works for me so far:

Do sudo gedit /etc/modules. Add the following line, then save:
apm power_off=1

But the second mod causes a bios error after grub on loading (not the end of the world) but then I cannot see my laptop battery charging.

do sudo gedit /boot/grub/menu.lst (where the l is a lower case L). Find the line that start with "kernel" and add this onto the end, no carriage return, all on the same line which probably wraps over:
acpi=off apm=power_off

But so far great, with just altering the modules.

Cheers Jerry, an annoying bug patched.

baasha (baasha) wrote :

Unfortunately, none of the above fixes work on my machine (Asus A7N8X motherboard with Nvidia chipset)). Sometimes a change to the /boot/grub/menu.lst file will result in a proper shutdown but only once. After the next boot shutdown results in a reboot. The same thing happens if I use the terminal and do a shutdown -P now command. The only way I can do a complete shutdown is to let it reboot and then shutdown from the options on the login screen. All this make me wonder if there is something in the bootup process that is over-riding the changes. I hope someone can figure this out soon, it's driving me crazy.

Hi All,

The symptom of this particular bug, failure to power off when shutting down, is specific to the hardware and BIOS used. So while many of you may have the same symptom they really should be different bugs. It would be helpful if everyone were to test with a Hardy Alpha build, http://www.ubuntu.com/testing/ , You should be able to test via the LiveCD. If this issue still persists, please open a separate bug report for your hardware using "linux" as the package. The bug report should contain the information requested at http://wiki.ubuntu.com/KernelTeamBugPolicies and the output of 'sudo dmidecode'. Additionally, it would be great if you made the titles of a new bug report contain information about either your motherboard or system. I apologize for any inconvenience this might cause but appreciate your cooperation and your helping to make Ubuntu better.

If the original bug reporter, jerrylamos, can comment here if the newer Hardy release resolves the issue or not, that would be great. Thanks.

Changed in linux-source-2.6.22:
status: Triaged → Incomplete
jerrylamos (jerrylamos) wrote :

Leann, I just entered bug #181892 from Hardy Alpha daily build 20080109, the latest Hardy I could find. Yes it hangs on shutdown.

By the way, CD Live, this version is a little jerky on youtube my impression better than the original Alpha.

Jerry

I now use Vista on my main machine pretty much soley because of the wasted time this bug was causing me.

Glenn (glenn-e-williams) wrote :

Do I not understand the "duplicate" status. When I work on bugs a duplicate is only applicable to the same stream. If you mark this as a duplicate to a bug found in Hardy, will it still be fixed in Gutsy? If so, then I have no problem with it being marked as a duplicate.

jerrylamos (jerrylamos) wrote :

This won't shut down bug cropped up on Feisty in the middle of February on the early builds just after a whole load of stuff from Debian got dumped on Ubuntu, as far as I can see replacing good code with defective code. Not that I can perceive that fast, but it seems to me that the "power off" signal is now much shorter than it had been.

It hasn't been fixed on Feisty, or Gutsy, or Hardy Alpha. Whatever developer is responsible hasn't been motivated yet. The Edgy code certainly worked so they do have a fix if they wanted to use it.

The temporary workaround I described on 2007-08-23 has to be applied with each install. I don't expect hardly any "ordinary desktop user" to know about or apply such a fix.

As I remember I did poke around on Feisty and saw that the code that did "power off" was different and larger than it had been for Dapper, Edgy, and early Feisty.

Don't hold your breath.

Jerry

I'm not questioning why this hasn't been fixed, I'm questioning why this has
been marked a duplicate. In my experience marking something as a duplicate
means that you have a duplicate bug report in the same stream. This is being
marked as a duplicate to a bug found in Hardy. I understand that it MAY be
the same bug as the one being reported in the other stream, but that does
not mean it shouldn't be fixed in this stream also.

Incidentally, the workaround you described on 8/23 did not solve the issue
for me unfortunately.

On Jan 19, 2008 9:06 PM, jerrylamos <email address hidden> wrote:

> *** This bug is a duplicate of bug 181892 ***
> https://bugs.launchpad.net/bugs/181892
>
> This won't shut down bug cropped up on Feisty in the middle of February
> on the early builds just after a whole load of stuff from Debian got
> dumped on Ubuntu, as far as I can see replacing good code with defective
> code. Not that I can perceive that fast, but it seems to me that the
> "power off" signal is now much shorter than it had been.
>
> It hasn't been fixed on Feisty, or Gutsy, or Hardy Alpha. Whatever
> developer is responsible hasn't been motivated yet. The Edgy code
> certainly worked so they do have a fix if they wanted to use it.
>
> The temporary workaround I described on 2007-08-23 has to be applied
> with each install. I don't expect hardly any "ordinary desktop user" to
> know about or apply such a fix.
>
> As I remember I did poke around on Feisty and saw that the code that did
> "power off" was different and larger than it had been for Dapper, Edgy,
> and early Feisty.
>
> Don't hold your breath.
>
> Jerry
>
> --
> Gutsy shutdown doesn't
> https://bugs.launchpad.net/bugs/119308
> You received this bug notification because you are a direct subscriber
> of the bug.
>

baasha (baasha) wrote :

Unfortunately, Gerry's workaround didn't work for me either, nor any of
the other fixes that have been posted. I find it bizarre that the
problem is being blamed on our hardware and/or BIOS. Even a casual
perusal of the postings for this bug will show that it has affected a
large number of people with different hardware and bios'. The one
common thread among all these people is that the problem began with an
upgrade to a new version of Ubuntu, some to Feisty, some to Gutsy. It
would seem to me that the problem is originating in the code, not the
hardware or the bios. If that is not the case, then perhaps someone can
explain why the problem suddenly appeared on a machine that has had the
same hardware and bios for several years, and has also run Ubuntu
successfully up until the Gutsy upgrade. I really don't understand why
this problem isn't being taken seriously by the developers. As the most
successful Linux OS, and given that the number of computers is predicted
to double to over 2 billion in the next five years, this is hardly the
time to let a bug like this go un-fixed. It would be a deciding factor
to most people trying out Ubuntu for the first time. Don't we want to
attract all those new users to Linux, or are we just going to abandon
them to a world full of windows and gates?

Shimatta (shimatta1) wrote :

I have been having this problem with a fresh install of both Ubuntu 8.04, 7.10, and Xubuntu 8.04 on a Dell Inspiron 700m. Currently, I'm using Xubuntu 8.04 exclusively. There appears to be multiple triggers for this bug, hence the wildly different fixes that work for different people.

The first trigger for me was fixed by the 915resolution package. This would consistently happen on logout as well as any flavor of shutdown.

The second, more obnoxious trigger seems to be when the machine is permitted to go idle. If I use the machine constantly, I never have the problem. If I forget about it for an hour or so, it happens. I was able to reduce the incidence of this by extending the time before power management features kick in, but obviously this is not an ideal solution, as my laptop's batteries are being unnecessarily drained, making resolution of this bug critical for me. However, even in this case, if the machine is idle long enough, it will fail to shutdown, suspend, or hibernate.

I have used the /boot/grub/menu.lst changes suggested without having the problem fixed, however, I have not had the /etc/modules fix in place, so I will see how that is behaving.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Curtis Hovey (sinzui) on 2012-04-21
Changed in linux-source-2.6.22 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions