powernow-k8 module gets stuck switching power levels on dualcore AMD64

Bug #96592 reported by Babassu on 2007-03-26
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cpufreqd
Invalid
Medium
linux (Ubuntu)
High
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.20-12-generic

powernow-k8 module reports "Hardware error - pending bit very stuck - no further
pstate changes possible" switching from a high power state to a low power state
and power management fails after this error.

Hardware: ASUSTeK Computer INC. A8V-MX Dual core AMD 64 3800
Same error Using SMP AMD64 kernel versions 2.6.17-10-generic, 2.6.17-11-generic, 2.6.20-12-generic

Steps to reproduce:
Loaded powernow-k8 module and governors (cpufreq-ondemand or
cpufreq-conservative (in /etc/modules). Loaded each core to 100% using the
following commands

ssh-keygen -G moduli.1 -b 1024 &
ssh-keygen -G moduli.2 -b 1024 &

Upon killing the load processes the module reports these errors (dmesg) and
power-management does not work anymore (gets stuck on the high level frequency
2GHz but low core voltage 1.17V ):

[ 454.266700] powernow-k8: Hardware error - pending bit very stuck - no further
pstate changes possible
[ 454.266709] powernow-k8: transition frequency failed
[ 455.504471] powernow-k8: failing targ, change pending bit set

The last message repeats a lot after.

Cesare Tirabassi (norsetto) wrote :

You will be better off reporting this upstream (http://kernel.org/).

If I were you I would also try to gather myself as much information as possible about the whereabouts of the problem occurring.
To do so one way is to raise the console loglevel to 8 to see all the dprintk.

The error you are reporting can actually occur in writing a new vid or fid (since you have the new vid set is most probably the fid).

Take note of the fid, lo and hi values reported just before the error message.

Cesare Tirabassi (norsetto) wrote :

Well, I see you have done it already :)

Changed in cpufreqd:
status: Unknown → Confirmed
Tim Gardner (timg-tpi) wrote :

The kernel was just sync'd with upstream stable 2.6.20. Lots of bug fixes in lib-ata and ACPI. Try it from the daily ISO http://cdimage.ubuntu.com/daily-live/current/ on Monday 4/2. The kernel version must be 2.6.20-14 or higher.

Changed in linux-source-2.6.20:
assignee: nobody → timg-tpi
status: Unconfirmed → Needs Info
assignee: timg-tpi → ubuntu-kernel-acpi
status: Needs Info → Confirmed

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Changed in cpufreqd:
status: Confirmed → In Progress

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Jesse Gilles (jesse-gilles) wrote :

I am running Ubuntu 8.04 amd64 with kernel 2.6.27-2-generic and am still seeing this issue.

Hardware: MSI K9VGM-V mainboard, AMD Athlon X2 5200+

Sep 2 18:30:03 jjg-linux kernel: [34971.601129] powernow-k8: Hardware error - pending bit very stuck - no further pstate changes possible
Sep 2 18:30:03 jjg-linux kernel: [34971.602955] powernow-k8: transition frequency failed
Sep 2 18:30:12 jjg-linux kernel: [34980.056013] powernow-k8: failing targ, change pending bit set

The last message was repeated very frequently for almost 45 minutes (the machine was under a load at the time). I then got the following at the end:

Sep 2 19:12:33 jjg-linux kernel: [37520.820036] powernow-k8: error - out of sync, fix 0x2 0xe, vid 0x8 0x8

The machine locked up sometime after that and required a hard reset.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: Incomplete → Triaged
Changed in cpufreqd:
status: In Progress → Confirmed

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

kernel-janitor (kernel-janitor) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
autra (autra) wrote :

Does anyone still have this issue ?

Changed in cpufreqd:
status: Confirmed → Incomplete
Fail2Ban (failtoban) on 2010-02-20
tags: added: kernel-bug verification-needed
Mitch Towner (kermiac) wrote :

@ Fail2Ban: please do not assign tags without first reading https://wiki.ubuntu.com/Bugs/Tags
Thanks in advance!

tags: removed: kernel-bug verification-needed

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux (Ubuntu):
status: Incomplete → Invalid

Thank you for taking the time to report this bug and helping to make Ubuntu better. My apologies as I should not have changed this to Invalid. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in linux (Ubuntu):
status: Invalid → Incomplete
Jeremy Foshee (jeremyfoshee) wrote :

closing as Invalid for the Kernel task due in large part to the extreme amount of time this issue has been open and the length of time since there was traffic on it. If this issue, or one like it, is encountered in the current development release please file a new bug with relevant information included.

Thanks!

~Jfo

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in cpufreqd:
importance: Unknown → Medium
Changed in cpufreqd:
status: Incomplete → Invalid
Curtis Hovey (sinzui) on 2012-04-09
Changed in linux-source-2.6.20 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.