Ubuntu

X crashes when trying to use LCD brightness buttons on Thinkpad X60

Reported by thomerz on 2007-03-25
12
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: linux-source-2.6.20

Hi, I don't know if this is a x.org or a kernel related bug. If i use my LCD brightness buttons (FN Keys) on my Thinkpad X60, X crashes and I have to restart it. If I blacklist the module "video" it stops X from crashing but I'm still not able to change brightness. If I don't use X, the keys seem to work. The problem is also described here: http://www.thinkwiki.org/wiki/Problem_with_LCD_brightness_buttons

thomerz (thomas-ulz-admex) wrote :
thomerz (thomas-ulz-admex) wrote :
Thomas Hotz (thotz) wrote :
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
status: Unconfirmed → Confirmed
Mark Reitblatt (mark-reitblatt) wrote :

Setting as "High" importance since this is a very easy way for unsuspecting users to kill X.

Changed in linux-source-2.6.20:
importance: Undecided → High
assignee: ubuntu-kernel-team → ubuntu-kernel-acpi
Joel Garske (joel-garske) wrote :

Hi there, i can reproduce the error.

With me its not, that X is actually crashing, according to the Xorg log, it just seems that the output routing is messed up...

I have produced 2 Xorg Log snippets: One with Xorg Log for changing from Terminal to x and back without pressing the brightness control, another one with brightness control.... seems like a problem with the output redirection.

By the way, thanks for linking the ThinkWiki link :).

May it be that there already is a hotfix?

Joel Garske (joel-garske) wrote :
Joel Garske (joel-garske) wrote :
Joel Garske (joel-garske) wrote :

The differences are shown here:

1609a1610,1635
> (II) PM Event received: Capability Changed
> I830PMEvent: Capability change
> (II) I810(0): Next ACPI _DGS [0] 0x80000100
> (II) I810(0): ACPI Toggle devices 0x1
> (II) I810(0): ACPI Toggle to 0x1
> (II) I810(0): Hotkey switch to 0x800.
> (II) I810(0): Attachable device 0x80000100.
> (II) I810(0): Attachable device 0x80000410.
> (II) I810(0): Requested display devices 0x800.
> (II) I810(0): Toggle (1) 0x1
> (II) I810(0): Detected duplicate devices. Toggling (0x1)
> (II) I810(0): Detected display change operation (0x0, 0x800, 0x1).
> (II) I810(0): Clearing Clone mode
> (II) I810(0): Primary pipe is now A.
> (--) I810(0): A non-CRT device is attached to pipe A.
> No refresh rate overrides will be attempted.
> (II) I810(0): Display plane A is enabled and connected to Pipe A.
> (II) I810(0): Display plane B is disabled and connected to Pipe B.
> (II) I810(0): Enabling plane A.
> (II) I810(0): Display plane A is now enabled and connected to Pipe A.
> (II) I810(0): Display plane B is now disabled and connected to Pipe B.
> (II) I810(0): PIPEACONF is 0x80000000
> (II) I810(0): PIPEBCONF is 0x00000000
> (II) I810(0): Mode bandwidth is 47 Mpixel/s
> (II) I810(0): maxBandwidth is 1152 Mbyte/s, pipe bandwidths are 252 Mbyte/s, 0 Mbyte/s
> (WW) I810(0): Changing XVideo pipe (1 to 0).
1614c1640
< (--) I810(0): A non-CRT device is attached to pipe B.
---
> (--) I810(0): A non-CRT device is attached to pipe A.

Joel Garske (joel-garske) wrote :

btw... brightness control is still possible using the gnome brightness control applet

apelete (apelete) wrote :

Exactly the same problem here. Using fn keys to adjust brightness make the screen to switch off, but using gnome brightness control applet (or gnome power manager brightness sliders) work.

Id2ndR (id2ndr) wrote :

Same problem for me on a Toshiba U200 laptop (GMA945). Gnome applet works fine, but no fn keys (however pressing fn keys several times allow me to get back the screen).

Id2ndR (id2ndr) wrote :

Sorry, I don't see exactly the same problem because X don't crach. I just have no output on internal LCD screen.

Id2ndR (id2ndr) wrote :

I solved my problem installing xserver-xorg-video-intel and using intel video driver instead of i810 one.

Serge (serge-de-souza) wrote :

Looks like this is fixed according to bug #119362

Curtis Hovey (sinzui) on 2012-04-09
Changed in linux-source-2.6.20 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers