feisty herd5 AMD64 fails to detect SATA drive

Bug #94820 reported by Matthias Blankertz on 2007-03-22
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Medium
Ben Collins

Bug Description

Binary package hint: linux-source-2.6.20

When booting the feisty-alternate-amd64 image, the kernel fails to detect the second SATA hard disk.
I have a MSI K9N Platinum motherboard with a nForce 570. A Seagate ST3320620AS, 3.AAE is connected to the 1. SATA port nativly, a Seagate ST360021A, 3.19 is connected to the 2. SATA port via a SATA-to-PATA converter board. The chip on the converter board is a "SiliconImage SataLink Sil3611CT80".
This setup works fine with the kernel Ubuntu 2.6.17-11.35-generic. Relevant part of dmesg:
[ 20.625918] SCSI subsystem initialized
[ 20.628792] libata version 1.20 loaded.
[ 20.629657] sata_nv 0000:00:05.0: version 0.8
[ 20.630034] ACPI: PCI Interrupt Link [LSA0] enabled at IRQ 23
[ 20.630039] GSI 16 sharing vector 0xD9 and IRQ 16
[ 20.630045] ACPI: PCI Interrupt 0000:00:05.0[A] -> Link [LSA0] -> GSI 23 (level, low) -> IRQ 217
[ 20.630121] PCI: Setting latency timer of device 0000:00:05.0 to 64
[ 20.630185] ata1: SATA max UDMA/133 cmd 0xC400 ctl 0xC082 bmdma 0xB880 irq 217
[ 20.630199] ata2: SATA max UDMA/133 cmd 0xC000 ctl 0xBC02 bmdma 0xB888 irq 217
[ 20.833387] ata1: SATA link up 3.0 Gbps (SStatus 123)
[ 20.997248] ata1: dev 0 cfg 49:2f00 82:346b 83:7d01 84:4023 85:3469 86:3c01 87:4023 88:407f
[ 20.997252] ata1: dev 0 ATA-7, max UDMA/133, 625142448 sectors: LBA48
[ 21.005234] ata1: dev 0 configured for UDMA/133
[ 21.005236] scsi0 : sata_nv
[ 21.208850] ata2: SATA link up 1.5 Gbps (SStatus 113)
[ 21.372713] ata2: dev 0 cfg 49:2f00 82:346b 83:4b01 84:4000 85:3469 86:0201 87:4000 88:203f
[ 21.372717] ata2: dev 0 ATA-5, max UDMA/100, 117231408 sectors: LBA
[ 21.372718] ata2(0): applying bridge limits
[ 21.380704] ata2: dev 0 configured for UDMA/100
[ 21.380706] scsi1 : sata_nv
[ 21.381247] Vendor: ATA Model: ST3320620AS Rev: 3.AA
[ 21.381254] Type: Direct-Access ANSI SCSI revision: 05
[ 21.384753] Vendor: ATA Model: ST360021A Rev: 3.19
[ 21.384760] Type: Direct-Access ANSI SCSI revision: 05
[ 21.385166] ACPI: PCI Interrupt Link [LSA1] enabled at IRQ 22
[ 21.385171] GSI 17 sharing vector 0xE1 and IRQ 17
[ 21.385176] ACPI: PCI Interrupt 0000:00:05.1[B] -> Link [LSA1] -> GSI 22 (level, low) -> IRQ 225
[ 21.385262] PCI: Setting latency timer of device 0000:00:05.1 to 64
[ 21.385311] ata3: SATA max UDMA/133 cmd 0xB800 ctl 0xB482 bmdma 0xB000 irq 225
[ 21.385324] ata4: SATA max UDMA/133 cmd 0xB400 ctl 0xB082 bmdma 0xB008 irq 225
[ 21.388728] SCSI device sda: 625142448 512-byte hdwr sectors (320073 MB)
[ 21.388739] sda: Write Protect is off
[ 21.388741] sda: Mode Sense: 00 3a 00 00
[ 21.388751] SCSI device sda: drive cache: write back
[ 21.388794] SCSI device sda: 625142448 512-byte hdwr sectors (320073 MB)
[ 21.388800] sda: Write Protect is off
[ 21.388802] sda: Mode Sense: 00 3a 00 00
[ 21.388811] SCSI device sda: drive cache: write back
[ 21.388814] sda: sda1 sda2
[ 21.393229] sd 0:0:0:0: Attached scsi disk sda
[ 21.393801] SCSI device sdb: 117231408 512-byte hdwr sectors (60022 MB)
[ 21.394377] sdb: Write Protect is off
[ 21.394380] sdb: Mode Sense: 00 3a 00 00
[ 21.394403] SCSI device sdb: drive cache: write back
[ 21.394451] SCSI device sdb: 117231408 512-byte hdwr sectors (60022 MB)
[ 21.394457] sdb: Write Protect is off
[ 21.394459] sdb: Mode Sense: 00 3a 00 00
[ 21.394468] SCSI device sdb: drive cache: write back
[ 21.394470] sdb: sdb1 sdb2 sdb3
[ 21.409498] sd 1:0:0:0: Attached scsi disk sdb
[ 21.588320] ata3: SATA link down (SStatus 0)
[ 21.588324] scsi2 : sata_nv
[ 21.792024] ata4: SATA link down (SStatus 0)
[ 21.792029] scsi3 : sata_nv
[ 21.792435] ACPI: PCI Interrupt Link [LSA2] enabled at IRQ 21
[ 21.792440] GSI 18 sharing vector 0xE9 and IRQ 18
[ 21.792446] ACPI: PCI Interrupt 0000:00:05.2[C] -> Link [LSA2] -> GSI 21 (level, low) -> IRQ 233
[ 21.792525] PCI: Setting latency timer of device 0000:00:05.2 to 64
[ 21.792572] ata5: SATA max UDMA/133 cmd 0xAC00 ctl 0xA882 bmdma 0xA400 irq 233
[ 21.792584] ata6: SATA max UDMA/133 cmd 0xA800 ctl 0xA482 bmdma 0xA408 irq 233
[ 21.995732] ata5: SATA link down (SStatus 0)
[ 21.995736] scsi4 : sata_nv
[ 22.199441] ata6: SATA link down (SStatus 0)
[ 22.199445] scsi5 : sata_nv

With the kernel Ubtuntu 2.6.20-12.19-generic on the xubuntu Feisty Herd 5 AMD64 alternate cd, it fails to detect the second hard drive (the one on the adaptor). The dmesg is:
[ 67.306690] sata_nv 0000:00:05.0: version 3.3
[ 67.307044] ACPI: PCI Interrupt Link [LSA0] enabled at IRQ 21
[ 67.307087] ACPI: PCI Interrupt 0000:00:05.0[A] -> Link [LSA0] -> GSI 21 (level, low) -> IRQ 21
[ 67.307187] PCI: Setting latency timer of device 0000:00:05.0 to 64
[ 67.307245] ata1: SATA max UDMA/133 cmd 0x000000000001c400 ctl 0x000000000001c082 bmdma 0x000000000001b880 irq 21
[ 67.307307] ata2: SATA max UDMA/133 cmd 0x000000000001c000 ctl 0x000000000001bc02 bmdma 0x000000000001b888 irq 21
[ 67.307360] scsi0 : sata_nv
[ 67.773462] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 67.794731] ata1.00: ATA-7: ST3320620AS, 3.AAE, max UDMA/133
[ 67.794765] ata1.00: 625142448 sectors, multi 16: LBA48 NCQ (depth 0/32)
[ 67.814747] ata1.00: configured for UDMA/133
[ 67.814786] scsi1 : sata_nv
[ 68.041028] usb 2-4: new high speed USB device using ehci_hcd and address 3
[ 68.173229] usb 2-4: configuration #1 chosen from 1 choice
[ 68.173371] hub 2-4:1.0: USB hub found
[ 68.173431] hub 2-4:1.0: 4 ports detected
[ 68.280685] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 68.301948] ata2.00: ATA-5: ST360021A, 3.19, max UDMA/100
[ 68.301982] ata2.00: 117231408 sectors, multi 16: LBA
[ 68.302014] ata2.00: applying bridge limits
[ 68.763897] usb 1-1: new low speed USB device using ohci_hcd and address 2
[ 68.977754] usb 1-1: configuration #1 chosen from 1 choice
[ 69.283087] usb 1-9: new low speed USB device using ohci_hcd and address 3
[ 69.512923] usb 1-9: configuration #1 chosen from 1 choice
[ 69.516474] usbcore: registered new interface driver hiddev
[ 69.523933] input: B16_b_02 USB-PS/2 Optical Mouse as /class/input/input2
[ 69.523993] input: USB HID v1.10 Mouse [B16_b_02 USB-PS/2 Optical Mouse] on usb-0000:00:02.0-1
[ 79.531263] drivers/usb/input/hid-core.c: usb_submit_urb(ctrl) failed
[ 79.531301] drivers/usb/input/hid-core.c: timeout initializing reports
[ 79.531504] input: Logitech Logitech Extreme 3D as /class/input/input3
[ 79.531642] input: USB HID v1.10 Joystick [Logitech Logitech Extreme 3D] on usb-0000:00:02.0-9
[ 79.531732] usbcore: registered new interface driver usbhid
[ 79.531765] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
[ 98.253893] ata2.00: qc timeout (cmd 0xef)
[ 98.253930] ata2.00: failed to set xfermode (err_mask=0x4)
[ 98.253963] ata2: failed to recover some devices, retrying in 5 secs
[ 103.881105] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 133.854242] ata2.00: qc timeout (cmd 0xef)
[ 133.854274] ata2.00: failed to set xfermode (err_mask=0x4)
[ 133.854308] ata2.00: limiting speed to UDMA/100:PIO3
[ 133.854339] ata2: failed to recover some devices, retrying in 5 secs
[ 139.481458] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 169.454595] ata2.00: qc timeout (cmd 0xef)
[ 169.454629] ata2.00: failed to set xfermode (err_mask=0x4)
[ 169.454661] ata2.00: disabled
[ 169.957899] scsi 0:0:0:0: Direct-Access ATA ST3320620AS 3.AA PQ: 0 ANSI: 5
[ 169.958574] ACPI: PCI Interrupt Link [LSA1] enabled at IRQ 20
[ 169.958614] ACPI: PCI Interrupt 0000:00:05.1[B] -> Link [LSA1] -> GSI 20 (level, low) -> IRQ 20
[ 169.958713] PCI: Setting latency timer of device 0000:00:05.1 to 64
[ 169.958755] ata3: SATA max UDMA/133 cmd 0x000000000001b800 ctl 0x000000000001b482 bmdma 0x000000000001b000 irq 20
[ 169.958818] ata4: SATA max UDMA/133 cmd 0x000000000001b400 ctl 0x000000000001b082 bmdma 0x000000000001b008 irq 20
[ 169.958872] scsi2 : sata_nv
[ 170.269321] ata3: SATA link down (SStatus 0 SControl 300)
[ 170.279599] ATA: abnormal status 0x7F on port 0x000000000001b807
[ 170.279642] scsi3 : sata_nv
ata4: SATA link down (SStatus 0 SControl 300)
[ 170.599098] ATA: abnormal status 0x7F on port 0x000000000001b407
[ 170.599464] ACPI: PCI Interrupt Link [LSA2] enabled at IRQ 23
[ 170.599497] ACPI: PCI Interrupt 0000:00:05.2[C] -> Link [LSA2] -> GSI 23 (level, low) -> IRQ 23
[ 170.599588] PCI: Setting latency timer of device 0000:00:05.2 to 64
[ 170.599614] ata5: SATA max UDMA/133 cmd 0x000000000001ac00 ctl 0x000000000001a882 bmdma 0x000000000001a400 irq 23
[ 170.599675] ata6: SATA max UDMA/133 cmd 0x000000000001a800 ctl 0x000000000001a482 bmdma 0x000000000001a408 irq 23
[ 170.599724] scsi4 : sata_nv
[ 170.908321] ata5: SATA link down (SStatus 0 SControl 300)
[ 170.918599] ATA: abnormal status 0x7F on port 0x000000000001ac07
[ 170.918642] scsi5 : sata_nv
[ 171.227822] ata6: SATA link down (SStatus 0 SControl 300)
[ 171.238100] ATA: abnormal status 0x7F on port 0x000000000001a807

Ben Collins (ben-collins) wrote :

Can you provide lspci -vv for this system (attach do not paste into comments as you've done for the dmesg out, makes it hard to read via the web interface).

Thanks

Changed in linux-source-2.6.20:
assignee: nobody → ben-collins
status: Unconfirmed → Needs Info
Thomas Hotz (thotz) on 2007-03-22
Changed in linux-source-2.6.20:
status: Needs Info → Unconfirmed
Changed in linux-source-2.6.20:
importance: Undecided → Medium
status: Unconfirmed → Fix Committed
Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released

The bug still occurs with the feisty-alternalte-amd64.iso from 2007-04-12 14:20 using kernel 2.6.20-14.

chrysoberyl (lnxme1) wrote :

Same here with Feisty I386 and 2.6.20-16-generic #2 SMP
my ATA-to-PATA converter board is a silicon image "SataLink Sil3611CT80" too.
Was working without problems with Edgy

description: updated
rex_the_first (rex-the-first) wrote :

I skipped out Feisty because of this. It still exists in Gustsy. I found that changing where SATA connected to my motherboard (slot 0 instead of slot 1) fixed the problem see http://ubuntuforums.org/showthread.php?t=450302. My motherboard is First International Computer P4-865G Series/VL35G. I will provided information if it helps as losing hard drives is bad.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers