2.6.20-16 stops during boot asking for resume image

Bug #94450 reported by Guy Van Sanden on 2007-03-21
4
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Undecided
Brian Murray

Bug Description

Binary package hint: linux-source-2.6.20

Today's upgrade updated the kernel to 2.6.20-12. This version stops during bootup with a blinking cursor.
Switching to VT1 reveals the messages:

kinit: No resume image, doing normal boot...
resume: libgcrypt version 1.2.3
resume: could not stat the resume device file.
             please type in the file name and try again or press ENTER to boot the system:

Pressing enters continues the normal boot.

The -11 kernel works correct.

This machine was not suspended, so it cannot be a residual image.

Guy Van Sanden (gvs) wrote :

The machine in question is a Dell Latitude D600 notebook (forgot to mention this). I have not tested it on another system.

Paul Sladen (sladen) wrote :

Can you attach the output of 'lspci -n', 'lspci -v'. I'm particularly interested in whether you have an ICH6 sata controller, as this maybe indirectly related to: bug #93648.

Please confirm, does the -12 kernel *boot* on this system, and it's just hibernation that fails?

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
status: Unconfirmed → Needs Info
Guy Van Sanden (gvs) wrote :

I will attach them tomorrow (the laptop is at work).

To be clear, no attempt to hibernate or suspend was made, this happens during normal bootup (cold start/reboot).

The laptop does continue booting after switching to VT1 (CTRL-ALT-F1) and pressing ENTER as instructed.

Guy Van Sanden (gvs) wrote :

Another update, as far as I can find on the net, the laptop does not have SATA (which would surprise me considering it's age).

This is the one: http://reviews.cnet.com/Dell_Latitude_D600/4507-3121_7-20906166.html

The files will follow tomorrow when I'm back at work.

Guy Van Sanden (gvs) wrote :

lspci -n

Guy Van Sanden (gvs) wrote :

lspci -v

Guy Van Sanden (gvs) wrote :

After today's update to linux-image-2.6.20-12.20, the problem was gone...

Tim Gardner (timg-tpi) on 2007-03-22
Changed in linux-source-2.6.20:
status: Needs Info → Fix Released
Guy Van Sanden (gvs) wrote :

The problem returned after installing 2.6.20-16, this is the same machine as before.

It's very annoying, the boot process stops on a blank screen and I have to CTRL-ALT-F1 to get to the message where I can press enter to boot furhter.

Changed in linux-source-2.6.20:
status: Fix Released → Unconfirmed
Brian Murray (brian-murray) wrote :

Could you please add the full contents of your '/boot/grub/menu.lst' and '/etc/fstab' as separate attachments? Thanks in advance.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → brian-murray
status: New → Incomplete
Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in linux-source-2.6.20:
status: Incomplete → Invalid
Guy Van Sanden (gvs) wrote :

Strange, I did not get a mail notify for the previous comment... In any case, here are the requested files

Guy Van Sanden (gvs) wrote :

fstab

Changed in linux-source-2.6.20:
status: Invalid → Incomplete
Brian Murray (brian-murray) wrote :

Could you please also provide the full contents of '/etc/initramfs-tools/conf.d/resume'? I suspect that says something like 'RESUME=/dev/hda5' and that it should be updated with the UUID of your swap partiiton. For example, 'RESUME=UUID=95a50650-c5c1-47b2-be9b-4e57d307e7f7" after which you will need to update your initramfs via 'sudo update-initramfs -u'. Thanks!

Guy Van Sanden (gvs) wrote :

The resume file

Guy Van Sanden (gvs) wrote :

The uid looks ok...

Brian Murray (brian-murray) wrote :

Did you also trying updating your initramfs via 'sudo update-initramfs -u'?

Guy Van Sanden (gvs) wrote :

update-initramfs fixed it!

Brian Murray (brian-murray) wrote :

This bug report is being closed due to your last comment regarding this being fixed with a configuration change. For future reference you can manage the status of your own bugs by clicking on the package name in the yellow line and then choosing a new status in the drop down box. You can learn more about bug statuses at http://wiki.ubuntu.com/BugSquad/ManagingStatus . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux-source-2.6.20:
status: Incomplete → Fix Released
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers