2.6.20-12 fails to boot with ICH6 SATA (ahci_init_one/pci_iounmap BUG at lib/iomap.c:254)

Bug #93648 reported by Paul Sladen on 2007-03-19
142
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Critical
Ben Collins

Bug Description

Binary package hint: linux-source-2.6.20

After an update have installed kernel 2.6.20-12, the system rebooted but the usplash progress bar never updates beyond 1%. Flicking around the consoles eventually showed the error message:

  [udevd]: abnormal exit running '/sbin/modprobe'

or similar. Eventually after a time-out (there's no root filesystem yet), I was handed the initramfs busybox shell.

Is the kernel with crashing when udev+modprobe attempt to load the driver for the SATA controller (ahci).

This bunch are looking quite similar to bug #84964 and its duplicates, but is definitely still present in -12.

00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller
00:1f.2 0101: 8086:2653 (rev 03) (prog-if 80 [Master])

Paul Sladen (sladen) on 2007-03-19
Changed in linux-source-2.6.20:
importance: Undecided → High
Daniel T Chen (crimsun) wrote :

Regression (doesn't boot) from -11.18 on this Canonical-sponsored IBM/Lenovo X41-2527[0]. Relevant information inlined below.

$ sudo lspci -vvn -s 00:1f.2
00:1f.2 0101: 8086:2653 (rev 03) (prog-if 80 [Master])
        Subsystem: 1014:056a
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Region 0: I/O ports at 01f0 [size=8]
        Region 1: I/O ports at 03f4 [size=1]
        Region 2: I/O ports at 0170 [size=8]
        Region 3: I/O ports at 0374 [size=1]
        Region 4: I/O ports at 1810 [size=16]
        Capabilities: [70] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

$ dmesg
[ 3.288000] ata_piix 0000:00:1f.2: version 2.00ac7
[ 3.288000] ata_piix 0000:00:1f.2: MAP [ P0 P2 IDE IDE ]
[ 3.288000] PCI: Setting latency timer of device 0000:00:1f.2 to 64
[ 3.288000] ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma 0x1810 irq 14
[ 3.288000] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x1818 irq 15
[ 3.288000] scsi0 : ata_piix
...
[ 3.492000] scsi1 : ata_piix
[ 3.648000] scsi 0:0:0:0: Direct-Access ATA HITACHI_DK13FA-4 00MC PQ
: 0 ANSI: 5
[ 3.656000] SCSI device sda: 78140160 512-byte hdwr sectors (40008 MB)
[ 3.656000] sda: Write Protect is off

[0] https://wiki.ubuntu.com/LaptopTestingTeam/ThinkpadX41-2527

Changed in linux-source-2.6.20:
status: Unconfirmed → Confirmed

Hand copied crash from 'cat /proc/kmsg' within initramfs busybox after 3 minute timeout:

  udevd-event[NNNN]: run_program: '/sbin/modprobe' abnormal exit

  kernel BUG at lib/iomap.c:254!
  invalid opcode: 0000 [#1]
  SMP
  EIP 0060:[<c01f241c>]
  EFLAGS: 00010287 (2.6.20-12-generic #2)
  EIP is at pci_iounmap+0x1c/0x20
  Process modprobe (pid: ...)
  Call trace:
    pcim_iounmap
    pcim_iomap_table
    pcim_iomap_regions
    ahci_init_one [ahci]
    ...

Changed in linux-source-2.6.20:
importance: High → Critical

Same problem on Dell Inspiron 9300. Attaching screenshot of console when hung.

Same problem here with an Dell Inspiron 9300. What information do you need from me?

Joachim Ziegler (ziegler) wrote :

I have a similar problem on my IBM T21 laptop, but I don't know whether this is a seperate problem:

Since 2.6.20-12 (every -XX version before working fine), my laptop stops the boot process with a rescue shell, saying that fsck did not succeed.

Strangely, my root partition /dev/hda2 is mounted as /dev/sda2, though I surely have no SCSI devices.

Contact me if you need more information

Palindrom (demarcheb) wrote :

Same problem here with Inspiron 9300

Paul Sladen (sladen) on 2007-03-20
description: updated
Paul Sladen (sladen) on 2007-03-20
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team

I can confirm this bug on a Asus W3000A.
from lspci:
IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 04)

Fails with the same error as in the foto above.

Paul Sladen (sladen) on 2007-03-20
description: updated
UBfusion (ubfusion) wrote :

Judging from the photo above, and the "abnormal exit" message, I think this bug is somehow related to the also critical bug #84964, which involves 965 chipsets and ICH5, ICH7R and ICH8 controllers. However, on the bug's discussions, the Jmicron controller is mostly blamed, and not so much ICHx. Please have a look at this bug symptoms.

Rocco (rocco) wrote :

My Dell Inspirion 9300 works OK with the 2.6.20-9 from Herd5.

Anthony Mercatante (tonio) wrote :

I can confirm the exact same behavior on my vaio fj3sw, with a sata hdd.
Here is the error message:
udevd-event[NNNN]: run_program: '/sbin/modprobe' abnormal exit

Tarek Loubani (tareko) wrote :

Same error on an HP NC4200

gnu_lx (linux-planet) wrote :

Same error on DELL D810. since last update; 2.6.20-11 works fine.

Kevin Kubasik (kkubasik) wrote :

For the record, my Dell D820 (almost the exact same machine) is running *-12 fine. If someone wants to check the specs and see whats different, that might a good clue.

Paul Sladen (sladen) wrote :

Hi Kevin, people could you attach the output from:

  lspci -v
  lspci -n

on the machine that /is/ booting, and 'gnu_lx', could you do this on your Dell model that isn't booting with -12.

Adi Roiban (adiroiban) wrote :

I can confirm this problem on my Thinkpad Z60m

udevd-event[NNNN]: run_program: '/sbin/modprobe' abnormal exit

Kevin Kubasik (kkubasik) wrote :
Kevin Kubasik (kkubasik) wrote :
Paul Sladen (sladen) wrote :

Kevin: Yup, that newer Dell is an ICH7 chipset. Newer model, newer chipset so makes sense that it isn't affected. It just appears to be ICH6 that is (PCI ID: 8086:2653).

johanjpk (johan-stevon) wrote :

Output of
lspci -v
lspci -n

gnu_lx (linux-planet) wrote :

lsvpi outputs, and yes it's ICH6 Family.

I also have this problem on a Dell Latitude D610 laptop. Here is the output of lspci using kernel 2.6.20-11

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → ben-collins
status: Confirmed → In Progress
Ben Collins (ben-collins) wrote :

Testers please:

http://people.ubuntu.com/~bcollins/kernels/bug-93648/linux-image-2.6.20-12-generic_2.6.20-12.20_i386.deb

8172368b874be9ed6777c818052e08a4 linux-image-2.6.20-12-generic_2.6.20-12.20_i386.deb

Beta is pending this fix, so the quicker I get confirmed tests, the better. Please email directly to <email address hidden>

Changed in linux-source-2.6.20:
status: In Progress → Fix Committed
Jan Mynarik (jan-mynarik) wrote :

Thanks! It fixes the problem here (Dell Latitude D610).

Bart Cerneels (stecchino) wrote :

Booted successful on a Asus W3000A.

gnu_lx (linux-planet) wrote :

kernel of Ben Collins, works for me on DELL D810. thanks.

Rene Paap (arpi) wrote :

Thanks! the Ben Collins kernel also worked for me (Dell D610)

The fix works for me and resolvs some (previously hidden) problems
regarding proper DMA detection of my DVD drive. Good work, thank you!

2007/3/21, Ben Collins <email address hidden>:
> Testers please:
>
> http://people.ubuntu.com/~bcollins/kernels/bug-93648/linux-
> image-2.6.20-12-generic_2.6.20-12.20_i386.deb
>
> 8172368b874be9ed6777c818052e08a4 linux-
> image-2.6.20-12-generic_2.6.20-12.20_i386.deb
>
> Beta is pending this fix, so the quicker I get confirmed tests, the
> better. Please email directly to <email address hidden>
>
> 2.6.20-12 fails to boot with ICH6 SATA (ahci_init_one/pci_iounmap BUG at lib/iomap.c:254)
> https://launchpad.net/bugs/93648

Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released
Rocco (rocco) wrote :

I confirm that it works OK with -12.20 on Dell Inspiron 9300.

Rob Miracle (rob-robmiracle) wrote :

This now works on my Dell D610. Thanks for the quick fix!

Nicolas DERIVE (kalon33) wrote :

This doesn't fix my problem unfortunately... See bug #94718.

Regards,

kalon33.

johanjpk (johan-stevon) wrote :

Works for me, inspiron 9300

saads (shakhshir) wrote :

I am unable to boot into an installed Feisty Beta on an acer travelmate 270. I can boot the live CD and install goes ok. Afterwards I can't boot into the installed system - it hangs with the same error message described in this bug report:

       [udevd]: abnormal exit running '/sbin/modprobe'

I have seen a similar report related to a jMicron controller, but lspci on my system doesn't show any such controller. I also do not have any SATA drives on this laptop. What information can I provide that would be helpful to fix this?

Mirco Müller (macslow) wrote :

Since 2.6.20-13-generic Feisty Fawn installs and boots on my Sony Vaio VGN-S580BH, which has a ICH6M-based sata-controller, on the sata-harddisk. I used the daily-built feisty ISO from 23th march 2007. So finally I'm able to run Feisty on the laptop, thanks for that!

vorian (vasco-kk) wrote :

10x Mirco,
I already upgraded to 2.6.20-13. Thanks to the great linux community,
there is also a patch for 2.6.20-12 which fixes this bug.
Regards

On 3/26/07, Mirco Müller <email address hidden> wrote:
> Since 2.6.20-13-generic Feisty Fawn installs and boots on my Sony Vaio
> VGN-S580BH, which has a ICH6M-based sata-controller, on the sata-
> harddisk. I used the daily-built feisty ISO from 23th march 2007. So
> finally I'm able to run Feisty on the laptop, thanks for that!
>
> --
> 2.6.20-12 fails to boot with ICH6 SATA (ahci_init_one/pci_iounmap BUG at lib/iomap.c:254)
> https://launchpad.net/bugs/93648
>

cYbErMo (cybermohamed) wrote :

I have the same problem as saads, instalation went ok with no problem, only the gparted that doesn't start when I wanted to format hdd but i did it speratly with partition magic. now ht einstalation is done successfully but wehn booting the new instaled os it freezes after 30 seconds.
the machine is an acer laptop aspire 1694 wlmi

To post a comment you must log in.