Some Thinkpads do not hibernate

Bug #92461 reported by Stephan Buys on 2007-03-15
24
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

I am using the latest/up-to-date Feisty and unfortunately my machine refuses to hibernate.

MACHINE SPECIFICATIONS

Model: IBM ThinkPad R60
CPU Type: Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz
Installed Memory: 1024MB
Graphics: ATI Technologies Inc Radeon Mobility X1400 (fglrx)

CURRENT SYMPTOMS

Symptoms at current on Feisty with full updates as of 15/03/2007:

From choosing "System>Quit>Hibernate"

1. Screen Blanks
2. Sleep light starts blinking
3. Terminal (non-X) cursor appears
4. Lots of disk activity
5. X11 returns
6. Screen-saver password prompt

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at http://wiki.ubuntu.com/DebuggingKernelProblems . Thanks in advance!

Stephan Buys (stephan-buys) wrote :

1. uname -a
Linux laptopname 2.6.20-10-generic #2 SMP Mon Mar 12 00:02:49 UTC 2007 i686 GNU/Linux

2. see attachment

Stephan Buys (stephan-buys) wrote :

3. see attachment

Changed in linux-source-2.6.20:
assignee: brian-murray → nobody
status: Needs Info → Confirmed
Michael R. Head (burner) wrote :

I'm seeing this too, with 2.6.20-12-lowlatency on a Thinkpad T30. (opensource ATI drivers for Radeon 7500, P4 @2Ghz, orinoco_pci wireless, e100 ethernet).

Hibernation used to work fine in edgy and in previous feisty kernels, though there had been a regression with hibernation+sound (vis. bug 80893).

Michael R. Head (burner) wrote :
Michael R. Head (burner) wrote :

May be a dupe of 90942?

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Medium
Albert Cardona (cardona) wrote :

T60 Thinkpad is also affected. And this bug is terrifying: I have restarted my thinkpad about 100 times in the last 3 weeks, because it hangs when going to sleep. Combined with fdisk changing the UUID label for the swap partition every couple of reboots (and thus failing to mount a swap without telling me), the usage of this machine is nearly unbearable.

Linux pad 2.6.17-11-generic #2 SMP Thu Feb 1 19:52:28 UTC 2007 i686 GNU/Linux

I'm attaching file with:
uname -a
lspci -vvnn
dmesg

Ramesh Krishna (rmkrish) wrote :

Same problem here on a Thinkpad T40. Hibernate has not worked since I began using Feisty Herd 4 (around 2.6.20-8 kernel). Hibernate has worked fine under Edgy though. Suspend to ram works Fine under Feisty. I have attached uname -a, lspci -vvnn, and dmesg after hibernate attempt.

angel1127 (huxiaoping1127) wrote :

some time it is because the feisty identify the disk as a sata
first you can
$swapon -a
if no output.it show your swap is on.can't hibernate is caused by some other reason.
else
it's because swap not mount right
you can edit /etc/fstab and /etc/initramfs-tools/conf.d/resume
give the correct partition to swap and resume
like
#/etc/fstab
/dev/sda1 .... swap

#resume
resume=/dev/sda1

Albert Cardona (cardona) wrote :

Update: Thinkpad T60p sleeps and resumes flawlessly with latest Feisty.

Linux pad 2.6.20-14-generic #2 SMP Mon Apr 2 20:37:49 UTC 2007 i686 GNU/Linux

The trick is to:
1) disable the graphics card warm up (for ATI cards).
2) disable/reenable powernowd in the sleep/resume acpi sequence:
http://www.thinkwiki.org/wiki/Installing_Ubuntu_7.04_(Feisty_Fawn)_on_a_ThinkPad_T60

Shoichi Chou (mgdesigner) wrote :

My thinkpad R31 have the same problem in Feisty(Eddy is still ok),too.Mine originally is updated from Eddy and it happen.But on the day before yesterday,for some my fail hacking,I need to reinstall it.After doing a clean installing,I found that hibernating to disk work again(with some console messages not showing the usplash)!Maybe something wrong in updating?

Just with a little new problem :after hibernating to disk powered off,I powered it on .It come back to gnome fine with the hibernate LED light no stopping twinkling.

And also another one.Hibernating to RAM sometime work fine,but sometimes not.

Chris (poser) wrote :

Hi all,

Albert Cardona says...

> Update: Thinkpad T60p sleeps and resumes flawlessly with latest Feisty.
>
> Linux pad 2.6.20-14-generic #2 SMP Mon Apr 2 20:37:49 UTC 2007 i686 GNU/Linux
>
> The trick is to:
> 1) disable the graphics card warm up (for ATI cards).
> 2) disable/reenable powernowd in the sleep/resume acpi sequence:
> http://www.thinkwiki.org/wiki/Installing_Ubuntu_7.04_(Feisty_Fawn)_on_a_ThinkPad_T60

...but I'm not sure about Step 1. What is the graphics card warm up (and how does one disable it)? I think I am up against Bugs 109403 and/or 109762 (hibernate works, but resume fails (after suspend) with SCSI I/O "dead device" errors...). I'm flailing pretty hard, here, so I thought I'd give this a whirl.

Thanks,
-Chris

Chris (poser) wrote :

Never mind,

Presumably, this is referring to the POST_VIDEO option from /etc/default/acpi-support. Still no dice.

Thanks,
-Chris

Chris (poser) wrote :

Also,

How sure are we that bug 109403 is really a duplicate of this one? I hadn't actually read the description of _this_ bug until now...but it seems to be more about hibernation than suspend. *shrug* (Incidentally, I recently fixed my own hibernation problems with information from bug 88377.)

Good luck all,
-Chris

Felix Hagemann (flixh) wrote :

The same problem with hibernating disappeared on my Samsung X20 with
Feisty (upgraded from Edgy last week), when I stopped mounting my swap
partition by label
LABEL=somelabel
in /etc/fstab and instead gave the correct device name.

Interesting enough the swap partition was in use without any problems before
that change (as well as after) but hibernating now works.

Felix

Chris (poser) wrote :

I tried removing my /sys/power/image_size hack and editing /etc/fstab to mount swap the "normal" way, and things still hung when resuming from hibernation. *shrug* For me, manually setting image_size to something less-than-or-equal-to swap size definitely seems to be the fix. (Note: my default /etc/fstab--from a clean Feisty install--does not use the LABEL convention; it uses the UUID=<blah blah blah> convention.)

Torsten Spindler (tspindler) wrote :

Has the situation improved with the 2.6.20-16 kernel?

Aurelbu (aurelbu) wrote :

I have the same problem on my thinkpad T42 and feisty.
Same problem with 2.6.20-16 kernel...

Stephan Buys (stephan-buys) wrote :

My Thinkpad R60 hibernates fine with the latest (2007/07/16) release of Feisty

My thinkpad R31 hibernates still fail with (2007/07/16) release of
Feisty.It will come back to the X-screensaver.

2007/7/16, Stephan Buys <email address hidden>:
>
> My Thinkpad R60 hibernates fine with the latest (2007/07/16) release of
> Feisty
>
> --
> Some Thinkpads do not hibernate
> https://bugs.launchpad.net/bugs/92461
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
行而不思則惘,思而不行則怠。
http://magicdesign.blogspot.com/
魔法設計師

Aurelbu (aurelbu) wrote :

I still have the problem with my t42 with latest release...

Nevertheless, I found a workaround :
Install uswsusp
edit /etc/uswsusp.conf to add/change :

early writeout = y
shutdown method = shutdown

and the enjoy s2disk...

If one of these 2 lines is not set, the s2disk does not work (same behaviour than with /etc/acpi/hibernate.sh)
I hope it will help...

Christian Schlauer (cs-usenet) wrote :

I can confirm this -- 7.04 (Feisty, fresh *install* from the *alternate* CD) on a Thinkpad R40:

$ uname -a
Linux whisker 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

As the original poster writes: From choosing "System>Quit>Hibernate"

1. Screen Blanks
2. Sleep light starts blinking
3. X11 returns
4. Screen-saver password prompt

I found out that my swap wasn't used:

$ swapon -s
Filename Type Size Used Priority

That was all -- but I have a swap partition!

Then I found out that I had exactly the same problem as in bug 90526: the UUID of the swap partition as given by "ls -l /dev/disk/by-uuid/" didn't match the UUID of the swap partition in /etc/fstab. I replaced the UUID in /etc/fstab with the one found with "ls -l /dev/disk/by-uuid/", and after that, suspend to disk (a.k.a. hibernate) works. Now I'm waiting for the next routine run of fsck to see if it breaks again.

Christian Schlauer (cs-usenet) wrote :

Following up on my comment above: the routine fsck run did occur, but it didn't break anything. Suspend to disk is still working.

Dara Adib (daradib) wrote :

This bug has been inactive for a awhile. Can someone report the status of this bug?

Additionally, this bug may be related to (or a duplicate of) bug 50031. Can someone confirm?

Dara Adib (daradib) wrote :

This bug may also be related to Bug 68199, which is currently marked as a duplicate of Bug 63418. Please check if this is correct. Thanks.

Albert Cardona (cardona) wrote :

This bug and related are very much on: Thinkpads with ATI graphics card don't hibernate with gutsy.

We are enduring the pain.

Dara Adib (daradib) wrote :

This looks like Bug 121653, which is for no suspend/hibernate with fglrx.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

To find out more about Twitter, visit the link below:

http://twitter.com/i/84cea0c366440263c2ba7a24186f0d8ae1cf4af7

Thanks,
-The Twitter Team

About Twitter

Twitter is a unique approach to communication and networking based on the simple concept of status. What are you doing? What are your friends doing—right now? With Twitter, you may answer this question over SMS, IM, or the Web and the responses are shared between contacts.

This message was sent by a Twitter user who entered your email address. If you'd prefer not to receive emails when other people invite you to Twitter, click here:
http://twitter.com/i/optout/f3ca3e3151b9993f480fc4aa39df7486320a03bf

Shoichi Chou (mgdesigner) wrote :

I am very sorry that I use twitter wrong >_<, pls delete the last one I post.

*This is an automated response*

This bug report is being closed because we received no response to the previous request for information. Please reopen this if it is still an issue in the actively developed pre-release of Jaunty Jackalope 9.04 - http://cdimage.ubuntu.com/releases/jaunty . To reopen the bug report simply change the Status of the "linux" task back to "New".

Changed in linux:
status: Incomplete → Won't Fix
Curtis Hovey (sinzui) on 2012-04-09
Changed in linux-source-2.6.20 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers