kernel lockup on feisty because of rt61 driver

Bug #91192 reported by Andris Sprūds on 2007-03-10
48
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

Computer freezes when running Feisty. This happens when using LiveCD, but also with HDD-based-version with all updates installed. System stops responding, mouse cursor freezes, no response to any keyboard input, including Num Lock. Freezes occur on average every 2-3 minutes. Only reboot helps after a freeze. When using console, the following message is displayed:

[64.036621] BUG soft lockup detected on CPU#0!8

The above mentioned error was displayed when I booted the system, waited for graphical login screen to appear, then immediately switched to console by pressing Ctrl+F2, and started to type sudo apt-get, when the system froze. I did not even manage to press enter key to execute the command.

Edgy runs pretty stable on the same hardware.

The output of uname -a is "Linux john-desktop 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux".

Andris Sprūds (aspruds) wrote :
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at http://wiki.ubuntu.com/DebuggingKernelProblems . Thanks in advance!

Andris Sprūds (aspruds) wrote :

Thank you very much for your quick response. The output of uname -a is "Linux desktop 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux".

Andris Sprūds (aspruds) wrote :
Andris Sprūds (aspruds) wrote :

Please let me know if I can add any other information. This bug is a showstopper for me for obvious reasons (freeze every 2-3 minutes :)

Andris Sprūds (aspruds) on 2007-03-10
description: updated
description: updated
Mattias Bengtsson (benmat) wrote :

I had the exact symptoms as John described in the initial bug-report.

After I read the post at http://ubuntuforums.org/showthread.php?t=251944 I removed my rt61 WLAN card, rebooted with the Herd 5 Live CD, and now my computer no longer freezes!

This means the problem is probably related to the rt2x00 package, which explains why this problem is not present in Edgy.

Andris Sprūds (aspruds) wrote :

Mattias, thank you for your post. At least we are getting somewhere :)

This could indeed be the problem as I actually have rt61 card, too. I recompiled my kernel using sources from kernel.org, afterwards I had no wireless support, but also no freezes. There has to be something wrong with rt61 driver included with Feisty.

Andris Sprūds (aspruds) wrote :

This bug seems to be pretty similar: https://launchpad.net/ubuntu/+bug/83009

Mattias Bengtsson (benmat) wrote :

This bug seems similar too: https://launchpad.net/ubuntu/+bug/90243

I've blacklisted the rt61 module and my system is stable now.

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team

Unable to get LIVE Feisty Beta CD to fully run on an old HP Pavilion 510a desktop with a newly added Linksys WMP54G wireless adapter card.

Various problems but no obvious pattern - highly erratic.

Variously: get all the way to desktop but no mouse; get all the way to the flashscreen with 3 loaded icons but unable to proceed to desktop; just get the x cursor on a black screen; or get message [202.238794] BUG: soft lockup detected on CPU#0!

The computer boots fine into Edubuntu Dapper (installed ages ago) even though the wireless card has been added.

Andris Sprūds (aspruds) wrote :

I can now confirm this - if rt61 is blacklisted, the problem is gone. If I leave rt61, the system is unstable even with completely up-to-date Feisty Beta.

I remember reading that rt2x00 drivers do not like SMP kernels. Maybe that's somehow connected?

Bart Verwilst (verwilst) wrote :

I'm seeing the same bug on my system.. A little while after the soft lock, i see messages starting with rt61Mrle ..... I don't have the correct message, but i could write it down and mention it here if it's needed.

Thanks!

Bart Verwilst (verwilst) wrote :

Blacklisting the rt61 module makes the system function flawlessly! ( Without wireless ofcourse but i don't use that anyways ;) )

Bart Verwilst (verwilst) wrote :

Browsing the rt2x00 forums showed several cases where users reported system lockups. The advice that was giving was almost always the same: "Do you run an SMP kernel? If yes, recompile it with SMP support because the rt61 driver cannot handle it" .. Sound strange, but hey :) My kernel lockups started after switching from a singlecore AMD64 to a core 2 duo system, so it might make sense!

Gianni Moschini (gianni.net) wrote :

Someone needs to test with the new driver from upstream rt2x00 CVS:
http://sourceforge.net/tracker/index.php?func=detail&aid=1687350&group_id=107832&atid=648844

Lennart Hansen (lahansen) wrote :

I've tested with the latest daily CVS tarball, it's still crashes the kernel.

After reading on there forum etc, I found it's NOT supported on SMP enabled kernels, ubuntu comes with this as default,
I solved the issue by compiling a new kernel without SMP and PREEMPT, it now work flawlessly, though this is not optimal.

Lennart Hansen (lahansen) wrote :

Did some more testing today, with a brand new installation of feisty.

It seems to be running fairly stable, but still hungs the host some times.

Managed to catch a crash yesterday, which i have attached here.

alun phillips (acw-phillips) wrote :

Not sure if this is the relevant bug report but I am having the exact same random lockups, sometimes occuring prior to entering X sometimes after an hour or two, Slight difference is i have been using Feisty since Beta with no issues or Hardware changes (incl RT61 modules) and it has only begun to lockup in the last couple of days.. ie since the last batch of updates on Friday night

$uname -a
Linux ubuntu 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

alun phillips (acw-phillips) wrote :

and heres lspci-vvnn.log

Mike.x (mxcarr) wrote :

I have the same problem as well with a DLINK wireless card that uses the rt61 driver. I have temporarily switched to using the windows driver supplied with the card with ndiswrapper. This works fine (no lock ups).

nixnoob (blazercist) wrote :

can you guys try commenting out eth0 from /etc/network/interfaces on my system I get the lockup if I bring up whilel eth0 is already up, if I down eth0 and bring up ra0 it does not crash.

illiadum (illiadum) wrote :

Tried commenting out the eth0 in the /etc/network. No effect. This is not related to whether the wireless is connected to the router or not either. Everything around me is ecrypted and I have not yet entered the encryption key. I get soft lockup at random several minutes after boot. Its got to be a bug with the RT61 drivers themselves. I had a similar problem in Gentoo on a different machine, my stable system began to lock at random as soon as I installed the RT61. My solution for that machine had been to buy a different wireless card (Atheros chipset) and reinstall OS. I'd prefer it if the drivers could be fixed for RT61, buying two wireless cards per machine is getting expensive rather quickly.

Jeff Rousseau (drzaiusx11) wrote :

http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=3509&postdays=0&postorder=asc&start=45

The RT61 "Enhanced Legacy Drivers" version nightly has been working stable for me for over a week. (The driver that shipped with Feisty would lockup my machine after less than an hour of heavy usage)

The Daily Build can be found here:
http://rt2x00.serialmonkey.com/rt61-cvs-daily.tar.gz

You'll need the kernel headers, gcc, and the usual suspects (gnu make, etc) in order to compile it against your current Feisty kernel--but it works and when you're done you wont have to reboot your PC every 10 minutes because of a buggy network driver. (make sure you remove the old rt61.ko module first and then do a "depmod" after compiling and installing the new one)

Hope this helps,
- Jeff Rousseau

Andris Sprūds (aspruds) wrote :

Hey Jeff, these are great news. Does anybody have an idea on when this bugfix might end up in 'regular' Feisty updates?

Brendan (schismoid) wrote :

I can confirm this bug. Also, I just switched to the CVS version, and so far so good, no freezes. For the record, I had this bug on Edgy too, so I don't think it's a Feisty-only issue.

Casey Rodarmor (rodarmor) wrote :

Just wanted to confirm this bug. Man, I was freaking out until I figured it out.

Javier Jardón (jjardon) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → nobody
Aaron (soulblade) wrote :

Hi, thanks for checking up on this report.

The issue still seemed present in 7.04 and 7.10

I have removed the card from my PC and using the Powerline plugs for now. I'm hoping that 8.10 (Kernel 2.6.24) will fix this issue.

Andris Sprūds (aspruds) wrote :

I have no lockups in Gutsy right now. However, as I experimented with manually compiling rt2x00 drivers, etc, I do not have the stock Gutsy anymore.

Shaun Crampton (fasaxc) wrote :

I have no lockups on Gutsy, but I have manually compiled the RT61 driver from the manufacturer. I didn't see any lockups after using a Hardy live CD for a few minutes.

I fixed this by getting a CVS snapshot of the drivers, which worked. So no
its not currently a problem.

Javier Jardón (jjardon) wrote :

Hello,

Ralink drivers are now in the kernel tree since 2.6.24 (the version that hardy use). See bug 134660

However this issue is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the actively developed release. You can find out more about the development release at http://www.ubuntu.com/testing/

Comment any progress in bug 134660

Thank you

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
Shaun Crampton (fasaxc) wrote :

My Wifi works 100% out-of-the-box in Hardy Final. Thanks!

Jenxie (jenxie) wrote :

I have Gigabyte GN-WP01GS (RT61 wifi card) and Ubuntu 8.04 with kernel 2.6.24 and in gnome system hangs..

I also experience the exact same problem in Slackware 12.0 and 12.1 =/

Aaron (soulblade) wrote :

Have rested in 8.04 and the issue is gone !

Thank you.

Aaron (soulblade) wrote :

My system still hangs with WMP54G v4.1 it just took longer than before to appear. I mistakenly thought it was ETQW that was causing the issue so I filed a new bug...
https://bugs.launchpad.net/ubuntu/+bug/236537

Since then I have marked bug 236537 as a duplicate.

When 8.04 crashes it does not seem to leave any logs of it crashing. It does leave for following error over and over...
"Jun 1 00:55:01 one kernel: [13186.364591] Please file bug report to http://rt2x00.serialmonkey.com."

However the usb key that I'm using for WIFI (rt73usb) leaves the same error over and over ( up to 35mb of logs for that error per day) without a single crash.

Hi Everyone,

It seems a few have reported that this bug has been resolved with Hardy. However, some are still experiencing issues. For those of you running Hardy with the latest updates, if you can try install the 'linux-backports-modules' package it contains an updated version of the rt2x00 drivers from serialmonkey. Please let us know your results.

If the issue still exists, it would be great if you could then test the latest Alpaha for the upcoming Intrepid Ibex 8.10 release. More information regarding the latest Alpha release can be found at - http://www.ubuntu.com/testing . It will be good to know if this will continue to be an issue with the upcoming release. We'll continue to keep this report open against the actively developed kernel but against 2.6.20 this will be closed. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Brad Figg (brad-figg) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04. To reopen the bug, click on the current status, under the Status column, and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions