Ubuntu

rt2570 conflict with rt73 in feisty freezes the system

Reported by Daniele Martini on 2007-03-03
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Kyle McMartin

Bug Description

Binary package hint: linux-image-2.6.20-9-generic

Hi,

I'm using Ubuntu Feisty, with D-Link DWLG122- REV C1 as usb wireless adapter.

When I plug the adapter the system freeze.

The problem is that the rt2570 tries to register the USB devices
while the correct driver for this adapter is rt73 !

The kernel log is:

[ 157.416000] usb 5-5: new high speed USB device using ehci_hcd and address 3
[ 157.684000] usb 5-5: configuration #1 chosen from 1 choice
[ 157.812000] idVendor = 0x7d1, idProduct = 0x3c03
[ 157.812000] usbcore: registered new interface driver rt2570
[ 157.840000] rtusb init ====>
[ 157.840000] usbcore: registered new interface driver rt73
[ 157.912000] RT25usb Driver version 1.0.0

A quick work-around is to blacklist the rt2570 module (it works!).

ProblemType: Bug
Date: Sat Mar 3 21:39:41 2007
DistroRelease: Ubuntu 7.04
Uname: Linux laptop 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux

Thanks for taking the time to report this bug. Unfortunately we can't fix it, because your description doesn't yet have enough information.

Please include the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at http://wiki.ubuntu.com/DebuggingKernelProblems . Thanks in advance!

Changed in linux-source-2.6.20:
assignee: nobody → caravena
status: Unconfirmed → Needs Info
Kyle McMartin (kyle) wrote :

Ergh. Ignore Cristian, he is just pasting without reading reports. Annoying.

Anyway, there's been a few reports of rt2570 working where rt73 doesn't... If you blacklist rt73 instead, does it continue to work? This datapoint is important in knowing what to do about a number of other bug reports.

Could you also attach "lsusb -v" output to this bug?

Thanks!
 Kyle

Changed in linux-source-2.6.20:
assignee: caravena → kyle
Daniele Martini (cyrax) wrote :

I tried to blacklist rt73 instead of rt2570 and the system freezed.

Since I have a rev D-Link dwl-g122 rev. C1 the correct driver should be the rt73,
while the correct driver for a rev. B1 would be the rt2570.

I think that the problem is in the rt2570 driver trying to handle the device.

I attach here a "lsusb -v" for you.

Thank you.

Yigal Weinstein (yigal) wrote :

There is something going on with rt2570. I found this on my own system. rt2570 and rt73 were loading at the same time. So I blacklisted rt2570 as I knew rt73 worked for my wifi. I decided today to do a little bit more research - this is actually how I found your bug report - this is my bug report https://answers.launchpad.net/ubuntu/+ticket/4149. I rmmod rt73 and depmod rt2570. It slowed my computer down and then I had to Alt+PrtScr+b as trying to rmmod rt2570 had no effect, I could even umount some partitions as I would have wanted to. I tried to build rt2570 with serialmonkey but the linux-headers have SMP enabled for some reason and rt2570 won't build with this in the kernel.

We are of course using different usb wifi sticks but the same chip so more or less the same monster.

Thorsten Peter (e1) wrote :

I also have the DWL-G122 rev C1 and can confirm the problem.
Searching Launchpad for answers I found some similar reports that should be marked as duplicates of this bug: Bug #89665 and Bug #95889.

Javier Jardón (jjardon) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 134660, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers