[needs-packaging] Microdia SN9C201 webcam driver

Bug #87054 reported by beerleader on 2007-02-22
90
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-panel (Ubuntu)
Undecided
Ubuntu Desktop Bugs
Intrepid
Low
Unassigned
linux (Ubuntu)
Medium
Unassigned
Intrepid
Medium
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Note: This is about the SN9C201 driver not the SN9C102 which is already in mainline kernel.org

Including this driver in Ubuntu would enable 22 new types of webcams to work in Ubuntu (it's pretty much all the 0c45:* cams but also a few 045e:* cams that use the same sensor chip as the 0c45:* cams).

NOTE: These are cams that lack _any_ driver at all today and they all have status "SUPPORTED" with this out-of-tree driver, while another 3 has status "Under development" and might work reasonably but not perfect):
http://groups.google.com/group/microdia/web/project-status

Webcams that will be fixed by this inclusion includes:
* Sonix webcam (0c45:624f)
* LifeCam VX-6000 (045e:00f4) which uses the same camera sensor

beerleader (sascha-beerleader) wrote :
description: updated
Chuck Short (zulcss) wrote :

http://www.linuxsoft.cz/en/sw_detail.php?id_item=8781

Driver can be downloaded from here. Ill look into this

Changed in linux-source-2.6.20:
assignee: nobody → zulcss
status: Unconfirmed → Confirmed
beerleader (sascha-beerleader) wrote :

This is the SN9C102 driver but I need the SN9C201 driver. They are different.

description: updated
description: updated
Sebastien Bacher (seb128) wrote :

not a gnome-panel problem

Changed in gnome-panel:
assignee: nobody → desktop-bugs
status: Unconfirmed → Rejected
beerleader (sascha-beerleader) wrote :

yes I know, but a problem...

Victor Noël (victornoel) wrote :

the guys from spca50x are working on it, just wait a little and it will be available with the gspca package :)

PromoGest (m3nt0r3) wrote :

maybe we are near to have a working driver for this webcam ....

http://www.linux-projects.org/modules/news/article.php?storyid=121

Victor Noël (victornoel) wrote :

Looks like linux-projects.org has a working driver, but it is a closed source one and there is only a deb for feisty ...

I guess w will have to wait for spca50x :)

vivalant (antvival) wrote :

This webcam is well supported by the Generic driver SN9CXXX driver at http://www.linux-projects.org. Do not confuse the SN9CXXX with the SN9C1xx.

Changed in linux-source-2.6.20:
assignee: zulcss → ubuntu-kernel-team
intel (intel-tg) wrote :

A free driver for SN9C201 is under development at the following
https://groups.google.com/group/microdia/

please join the effort.

GSPCA has been promising SN9C201 support for over 2 years now,
Linux-Projects driver is trialware /closed source and also has issues.
Sonix themselves had released a binary only driver for FC6

All discussions about this driver/webcam at
https://groups.google.com/group/microdia/

Matt LaPaglia (mlapaglia) wrote :

I confirm exactt's test version, it works.

I should say that the mentioned test version does work for me in both Skype and Ekiga, but doesn't work with gstreamer and hence refuses to work with Cheese. Anyway, that's much better than having a webcam that's not working at all.

exactt (giesbert) wrote :
Evgeny Kuznetsov (nekr0z) wrote :

For my camera, a manually compiled driver (from http://repo.or.cz/r/microdia.git) works significantly better than the packaged one.

Beginning with the Hardy Heron 8.04 development cycle the kernel source package naming convention changed from "linux-source-2.6.xx" to just "linux". Going forward, kernel bugs should now be reported against the "linux" package. I'm going to automatically retarget this bug against the "linux" package.

Hi All,

Just curious if anyone knows if there has been any effort to get this driver merged into the upstream kernel? The reason I ask is because it is a lot of extra effort for the kernel team to maintain out of tree patches/drivers. As such, they typically require upstream submission first before agreeing to maintain patches locally.

Also note that we'll keep this report open against the actively developed kernel but against 2.6.20 this will be closed as it does not qualify for a Stable Release Update - http://wiki.ubuntu.com/StableReleaseUpdates . Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

intel (intel-tg) wrote :

1) Driver is reportedly working with Linux v2.6.27-x
     See success reports here
    https://groups.google.com/group/microdia/browse_thread/thread/dd27cb256652c5d1

2) DKMS driver source has been packaged for Intrepid/Hardy/Gutsy available here
    https://launchpad.net/~nickel62metal/+archive
    These packages are maintained directly by upstream driver developers
    https://groups.google.com/group/microdia/browse_thread/thread/954d27915c91457d

 For any further assistance email <email address hidden>

Changed in linux:
status: Triaged → Fix Committed
Matt LaPaglia (mlapaglia) wrote :

I'm on the latest intrepid updates, my webcam responds to lsusb, but skype doesn't see the camera, and using the ppa sources intel listed the driver fails to compile during installation. I get the following error:

------------------------------------------------------------------------------------------------
mlapaglia@amanda-laptop:~$ sudo apt-get install microdia-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  microdia-dkms
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/80.8kB of archives.
After this operation, 627kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  microdia-dkms
Install these packages without verification [y/N]? Y
Selecting previously deselected package microdia-dkms.
(Reading database ... 116746 files and directories currently installed.)
Unpacking microdia-dkms (from .../microdia-dkms_2008.09-0ubuntu1~ppa2i_all.deb) ...
Processing triggers for man-db ...
Setting up microdia-dkms (2008.09-0ubuntu1~ppa2i) ...
Loading new microdia-2008.09 DKMS files...

Creating symlink /var/lib/dkms/microdia/2008.09/source ->
                 /usr/src/microdia-2008.09

DKMS: add Completed.
Installing prebuilt kernel module binaries (if any)
Building module...

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=2.6.27-4-generic KVER=2.6.27-4-generic src=/var/lib/dkms/microdia/2008.09/build....(bad exit status: 2)

Error! Bad return status for module build on kernel: 2.6.27-4-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/microdia/2008.09/build/ for more information.
0
0
dpkg: error processing microdia-dkms (--configure):
 subprocess post-installation script returned error exit status 10
Errors were encountered while processing:
 microdia-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
------------------------------------------------------------------------------------------------

is this because my kernel is too new, or because it's i686?
I had manually installed the drivers on Gutsy a few months ago, and it was working fine.

Matt LaPaglia (mlapaglia) wrote :

On a clean install of the beta, and adding the PPA archives from

http://ppa.launchpad.net/nickel62metal/ubuntu intrepid main

then installing microdia-dkms

my webcam now works with skype.

Evgeny Kuznetsov (nekr0z) wrote :

I can confirm that: PPA version works perfectly on Intrepid (though I had to reinstall it after upgrade, as the upgrade process broke it).

Øyvind Stegard (oyvinst) wrote :

Tested PPA@http://ppa.launchpad.net/nickel62metal/ubuntu on 2008-12-15 with the following cam:
Bus 001 Device 006: ID 0c45:627b Microdia PC Camera (SN9C201)

Does not work, testing in gstreamer-properties fails (V4L2 source). Camera light switches on but there is no image, and gstreamer-properties hangs hard and must be killed.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

My camera fails to be recognized by gstreamer using PPA driver, but works with Skype. By the way, is there any way to reenable camera (at least in Skype) after suspend-to-disk? Restarting microdia (rmmod and modprobe back) doesn't help, and neither does restarting videodev. Suspend-to-RAM doesn't cause this problem, but STD does.

Martin Olsson (mnemo) wrote :

FWIW, I tested the [unmodified] microdia bits (taken from git right after commit b8dad85dcb7c182933c40356c8255ff924e21dad) together with the jaunty 2.6.28-8-generic pre-release kernel and I was able to get video from my LifeCam VX-6000 (PCI ID 045e:00f4).

* Videos works in Skype, VLC and mplayer but it does not work in Cheese.
* At first I connected the cam into an USB port on my keyboard and then my dmesg said there wasn't enough power:
[ 4592.420493] usbcore: registered new interface driver sn9c20x
[ 4592.420693] sn9c20x: SN9C20x USB 2.0 Webcam Driver v2009.01 loaded
[ 5966.240081] usb 3-2.2: USB disconnect, address 4
[ 5970.413808] usb 3-2.2: new full speed USB device using uhci_hcd and address 6
[ 5970.523798] usb 3-2.2: not running at top speed; connect to a high speed hub
[ 5970.553866] usb 3-2.2: rejected 1 configuration due to insufficient available bus power
[ 5970.553869] usb 3-2.2: no configuration chosen from 1 choice
[ 5994.398237] usb 3-2.2: USB disconnect, address 6

Then I connected it to a real USB port at the back of the computer and insmod:ed the driver and then dmesg said:
[ 4592.420493] usbcore: registered new interface driver sn9c20x
[ 4592.420693] sn9c20x: SN9C20x USB 2.0 Webcam Driver v2009.01 loaded

BUT I still didn't get any /dev/video* device created. Eventually I figured out that I needed to unplug the camera and then reconnect it again while the driver module was loaded because the driver module doesn't seem to understand that the camera is connected already when the module is loading?

Anyway, when I reconnected the cam while the driver module _was_ running it worked. dmesg said:
[ 6211.423443] sn9c20x: SN9C20X USB 2.0 Webcam - 045E:00F4 plugged-in.
[ 6211.531191] sn9c20x: Detected OV9650 Sensor.
[ 6211.532046] sn9c20x: Webcam device 045E:00F4 is now controlling video device /dev/video0
[ 6211.550815] sn9c20x: Using yuv420 output format

And then I had a /dev/video* device that worked.

Evgeny Kuznetsov (nekr0z) wrote :

I have already pointed out that the way this driver is currently packaged it does not survive suspend-to-disk, either Ubuntu's default way or via uswsusp, and after a wake-up the camera does not work any longer (there may be other ways than reboot to reenable it, but I have yet to find them). Is there any way to repackage the driver so that it would unload/reload automagically on STD?

Martin Olsson (mnemo) on 2009-02-28
description: updated

Webcam confirmed non-working for 9.04.
I tried https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/87054/comments/22
both replacing and not replacing 'intrepid' with 'jaunty'. I've only tested with Cheese.

John Logan (john-loganfamily) wrote :

this is the steps I took and its working.

add the following to your list of apt sources

deb http://ppa.launchpad.net/nickel62metal/ubuntu jaunty main

then the old
>apt-get update
followed by
>apt-get install microdia-dkms

Then just reboot. It tested this with the application 'Cheese'.

Great! Confirmed working on Compal HEL80.

NicoInattendu (nico-inattendu) wrote :

On jaunty with chesse. LifeCam VX-6000.

For me the webcam was detected by cheese but no resolution are detected; and the 'fakesrc' gstreamer screen is displayed.
 luvcview neithers work .
I have a configuration with 2 webcams one 'Builtin Isight', who runs ok and Microsoft
 LifeCam VX-6000.

Byron Conti (russmhoward) wrote :

Followed John Logan's steps
Does not work for me
Using a MS LC VX-6000 on Jaunty amd64
Starting Cheese causes webcam light to flash (guess its trying to initialize), but no image or video in cheese.
Anyone any suggestions as to how to investigate further/fix?
Thanks.

Brian Johnson (brijohn) wrote :

Ok good news support for sn9c20x webcams should be coming to the kernel soon. I have recently rewrote the out of tree microdia driver to use the kernel's gspca framework and this code is already in the main v4l-dvb repositories. It should make it into the 2.6.31 kernel as well meaning karmic should support many of these webcams.

summary: - [Needs Packaging] Microdia SN9C201 webcam driver
+ [needs-packaging] Microdia SN9C201 webcam driver
Fabián Rodríguez (magicfab) wrote :

I've just tested this (0c45:62c0 Microdia Sonix USB 2.0 Camera) in Karmic. It seems it didn't make it into 2.6.31 after all. The PPA doesn't have packages for Karmic so I can't test further.

Arup (arup-chowdhury) wrote :

Microdia now works in Karmic, in my case its a Microdia NE78 chip and its detected fine. The problem is that image is just unusable, its too dark to start with, also the drivers don't enable the built in LEDs for low light use. Adjusting via v4l2ucp or xawtv results in overtly bright washed out image and the color cast is just bad period. Neither amount of adjustment gets you a fair image. I guess this driver needs some serious work.

Sebastien Bacher (seb128) wrote :

the issue doesn't seem a gnome-panel one

Changed in gnome-panel (Ubuntu Intrepid):
importance: Undecided → Low
status: New → Invalid
Sergio Zanchetta (primes2h) wrote :

This bug has been fixed in kernel > 2.6.27-x
Closing

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Intrepid):
importance: Undecided → Medium
status: New → Fix Released
Changed in linux-source-2.6.20 (Ubuntu Intrepid):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers