[feisty] WLAN RT2570 USB does not work with NetworkManager

Bug #85293 reported by Janek Thomaschewski on 2007-02-15
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

I have here the WLAN chip RT2570 USB and It works correctly when I configure it with a static or dynamic (DHCP) ip in the /etc/network/interfaces file. But when I try to let networkmanager configure my WLAN there comes the dialog which I have to fill with my WEP-key. But after pressing OK the "points in the try" shows that the networkmanager do something and after about a minute networkmanager switches back to wired network.

Where can I find logs or something like this for networkmanager? Or do you have any other debugging ideas?

ProblemType: Bug
Date: Thu Feb 15 08:29:41 2007
DistroRelease: Ubuntu 7.04
Uname: Linux janek-desktop 2.6.20-8-generic #2 SMP Tue Feb 13 05:18:42 UTC 2007 i686 GNU/Linux

Janek Thomaschewski (thefoxx) wrote :

Now, with the newest kernel 2.6.20-12-generic WLAN does not work completely, not only with NetworkManager. But the networks are listed and the connection-quality is shown...

Janek Thomaschewski (thefoxx) wrote :

I testet now my WLAN RT2570USB with the feisty beta desktop CD and it still don't work. Why don't you intigrate the closed binary driver like some other one in the restricted manager or intigrate the open one? It's really bad to try get it working with long manuel installations - and this since warty and before.
Do you plan support for this chip in feisty release?

bardi (bardi-e) wrote :

In order to get my wireless connection to work in feisty I had to blacklist rt73usb.

I added
# wireless hell
blacklist rt73usb
to /etc/modprobe.d/blacklist

info.product string Belkin 54g USB Network Adapter
info.udi string /org/freedesktop/Hal/devices/usb_device_50d_7050_noserial

I know from experience with dapper and feisty that this device uses
rt2570

After the blacklisting Network Manager appears to be working.

Janek Thomaschewski (thefoxx) wrote :

Thanks, I will try that.

Janek Thomaschewski (thefoxx) wrote :

No, that does not help here. But I think its logical that here it's not the same driver which conflicts with my card (when this is the problem).
Does anyone have any other ideas how to fix it or which infos I have to include?

BlackSmile[FR] (thomasclaessen) wrote :

Ok here is my experience
as i freshly install feisty on a old compaq presario with usb 1.1 (not my computer), I plugged the dongle (HWGUSB2-54) say as recognize.
Then I was able to see access point but not link quality.
I try to connect to any AP but cannot get the network. I also try manually without any result

Then I try to update with last rt2570 everything goes right except the fact that it seems not to update module but to place it in a strange location : /lib/modules/2.6.20-15-generic/extra

So I try to look at the different modules I would found on my computer. I found out that in feisty module are in /lib/modules/2.6.20-15-generic/kernel/ubuntu/wireless/rt2x00-legacy. I try to switch files and launch modules with insmod but no result left.

Then I found different file in /lib/modules/2.6.20-15-generic/kernel/ubuntu/wireless/rt2x00 as it seems new in the serialmonkey web site i decided to try.
And it work using both rt2xlib.ko and rt2500usb.ko modules.
So first try was done like this :
disconnect the dongle/ then restart the machine
then I set modules with a modprobe rt2x00lib and a modprobe rt2500usb
then i connect the dongle. I was able to see AP and also the link quality.
A shot on an AP without any wep or wpa enable and I was finally able to get the network.
each time I restart the computer I had to disconnect the dongle before powering on the computer.

an lsmod give me that rt2570 was up and working weird??
Even more weird :
I try to blacklist the rt2570 modules in /etc/modprobe.d

Now I'am able to get network without disconnecting the dongle at each start
Only one bad thing keeps remaining dongle cannot connect to AP with WPA (actually a livebox with the basics security enable) cause i get a strange message.

Henrik Nilsen Omma (henrik) wrote :

Janek, could you please test this in Gutsy (perhaps with a Live CD)? We'll only be able to address most network-manager bugs in the latest release. Thanks.

Also, this sounds like a 2.6.20 kernel bug, not NM.

Changed in network-manager:
importance: Undecided → Medium
status: New → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux-source-2.6.20:
status: Incomplete → Invalid
Janek Thomaschewski (thefoxx) wrote :

Sorry I forgot about this becouse I switched back to wired connection. But I can say, that now with Gutsy I have the same problem. The card is detected, the networks are shown in network manager or with iwconfig but when I try to connect, it takes a lot of time and nothing happens. No succeeded connection...
Does anyone have an idea how I can debug that? Or are there any logs? Where?

Changed in linux-source-2.6.20:
status: Invalid → New
Javier Jardón (jjardon) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 134660, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers