Ubuntu

Support for Microsoft Natural Ergonomic Keyboard 4000

Reported by Stéphane Magnenat on 2007-02-13
74
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Wishlist
Unassigned
Declined for Feisty by Brian Murray
Declined for Gutsy by Brian Murray
Nominated for Hardy by Fran6co
linux-source-2.6.22 (Ubuntu)
Wishlist
Chuck Short
Declined for Feisty by Brian Murray
Declined for Gutsy by Brian Murray
Nominated for Hardy by Fran6co

Bug Description

It would be nice if (K)Ubuntu had out of the box support for Microsoft Natural Ergonomic Keyboard 4000. The driver/configuration exists (documentation here: http://gentoo-wiki.com/HOWTO_Microsoft_Natural_Ergonomic_Keyboard_4000, patch here: http://marc.theaimsgroup.com/?l=linux-usb-devel&m=115569418007477&q=raw).

It would be also nice if there was GUI for assigning supplementary keys to applications (perhaps on Kubuntu global shortcuts work with them).

I think than supporting MS hardware out of the box when on Windows you have to install a driver would lead us closed to solving bug #1 :-)

Thanks,

Stephane

Brian Murray (brian-murray) wrote :

Thanks for your bug report. Which version of Kubuntu are you running? Incidentally, the Input Actions portion of the Accessibility area of KDE's System Settings can be used for assigning supplementary keys.

I'm running Feisty.
Thanks for pointing the Accessibility area. Some keys work, others not. The problem with the Accessibility area is that it is fairly low level : if I want a key behave like the direction key I have to remap in for each combination of shift and control ; but at least I can do it :-)

Thanks

Changed in linux-source-2.6.20:
assignee: brian-murray → nobody
importance: Undecided → Wishlist
status: Needs Info → Confirmed
Chuck Short (zulcss) wrote :

Added to my git tree.

Changed in linux-source-2.6.20:
status: Confirmed → Fix Committed

I would be pleased if there is a possibility to insert the patch to the ubuntu kernel. Maybe I would pay for it...!

Nick Parker (nickbp) wrote :

I assume the fix will show up in Feisty (?)

Brian Murray (brian-murray) wrote :

As this has been marked fix committed that means it is in the kernel source now but is not yet available. The bug should be marked fix released when you can actually get a new kernel with support for your device.

Great thanks :-)
Do I understand it right, the patch would be available with the next kernel release?

Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released

Hi
I realised, that the Status is set to Fix Released. After an update, I'm running 2.6.20-12-generic but I can't modprobe the module usbnek4k ?!?

So some main buttons won't work (One, Two, Three,... Favorits).

What I've to do to get keycodes for this buttons?

zerwas (zerwas) wrote :

I can also not find the driver in 2.6.20-13-generic.
So why is it marked as "fix released?"

Changed in linux-source-2.6.20:
assignee: nobody → zulcss
status: Fix Released → In Progress
Daniel Hahler (blueyed) wrote :

JFI: I've asked in #ubuntu-kernel and somehow Ben has not received the commit. Therefor it's "in progress" again and obviously won't make it into Feisty.

Nick Parker (nickbp) wrote :

That's a shame. Is the patch in the tree now (for post-feisty)? If not, when will this be done?

Diwaker Gupta (diwaker) wrote :

I'd love to see it included as well. I'm running the latest Feisty kernel (2.6.20-15-generic). Does anyone have a pre-compiled kernel .deb file that I can just install? That'll make it much easier to test the patch in a packaged environment.

Nick Parker (nickbp) wrote :

bump

Is the patch in?

Squeaky wheels getting grease and whatnot.

Matthew Cutts (cutts) wrote :

bump; it's been a few weeks, so I thought I'd ask if the patch got in.

zerwas (zerwas) wrote :

The patch also works with gutsy-kernel. So why not integrate it? Nobody wants to support Microsoft hardware? ;-)

omni-vi (catcher) wrote :

I would be very happy to see the patch in gutsy :-) .
Is there somebody working on that?

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Wishlist
status: New → Triaged
Changed in linux-source-2.6.20:
assignee: zulcss → nobody
status: In Progress → Won't Fix
Jeffrey Honig (jch-honig) wrote :

Another request to see this patched in Gutsy, or even Fiesty. This is my only complaint after switching from RHEL.

Nick Parker (nickbp) wrote :

It's worth noting that this was already fumbled with respect to Feisty's release.

Chuck Short (zulcss) on 2007-08-23
Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-team → zulcss
Ahmed Hamed (ahmedhamed88) wrote :

Is there any reason why this patch won't be included in Gutsy. Recompiling the whole kernel just to get a keyboard to work will surely make ubuntu look complicated to many people.

Brian Murray (brian-murray) wrote :

As you can see this bug is assigned to Chuck Short a community member of the kernel team who is working on including the support.

Changed in linux-source-2.6.22:
status: Triaged → In Progress
Nick Parker (nickbp) wrote :

That's great! Thanks!

Chuck Short (zulcss) wrote :

Unfortunately, this driver depends on hid simple driver interface which is not included in the kernel proper. Unless the simple driver interface is included upstream I cant include this driver into gutsy.

Sorry.

Changed in linux-source-2.6.22:
status: In Progress → Won't Fix
Markus Vuori (lite) wrote :

I'd like to see Ubuntu supporting this keyboard. I think this is a matter of will and supposedly there're plenty of other keyboard models not supported.

Nick Parker (nickbp) wrote :

Yeah, I've resorted to using other distros for a few months now.

zerwas (zerwas) wrote :

So there is really no chance to get this piece of hardware working by default? Liyus newest driver is available here: http://ubuntuforums.org/showpost.php?p=3328486&postcount=110

There must be something that we can do to have support for this keyboard. Am i wrong?

Oleksij Rempel (olerem) wrote :

if some body like to know: the patch for this keyboard was applyed to mainstream :)
bad news: it probably will be not included in gutsy kernel :(

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=1fe8736da695c2b14961438c73d5600538bd92d9;hp=4dc21a8005216ee3784df545f028775242c6f499

GeertPoels (geert-poels) wrote :

To what extent is it supported at this moment ?
Suppose we temporarily forget about the multimedia keys.
Is the basic and numeric keyboard working ?

Andrew (andrew-rw-robinson) wrote :

Everything works fine using the standard 105 key layout except:

Special buttons 1-5
My Favorites
Zoom

And it doesnt work during boot. (GRUB menu)

On Nov 26, 2007 1:23 PM, Andrew <email address hidden> wrote:
> Everything works fine using the standard 105 key layout except:
>
> Special buttons 1-5
> My Favorites
> Zoom
>
>
> --
> Support for Microsoft Natural Ergonomic Keyboard 4000
> https://bugs.launchpad.net/bugs/84965
> You received this bug notification because you are a direct subscriber
> of the bug.
>

GeertPoels (geert-poels) wrote :

Not during boot ?
Is this because of the USB-interface ?
Do 'standard' keyboards with USB interfaces work at boot time ?

Andrew (andrew-rw-robinson) wrote :

Works fine for me in the grub menu

Daniel Hahler (blueyed) wrote :

Hei Ku, you need to change some BIOS setting probably. It's called "Legacy USB keyboard support" (or similar) on my BIOS.

Hei Ku (asoliverez) wrote :

I remember now. I tried that, but it doesnt work in my case.
Motherboard is an MSI K8T Neo. I tried that when I first purchased the
keyboard, but it wouldnt work well once the system started. It is no
problem so far, since I reboot only now and then. But I would love to
see this fix implemented, specially since it is already in the main
kernel, 2.6.22-21 or so.

On Nov 26, 2007 7:30 PM, dAniel hAhler <email address hidden> wrote:
> Hei Ku, you need to change some BIOS setting probably. It's called
> "Legacy USB keyboard support" (or similar) on my BIOS.
>
>
> --
> Support for Microsoft Natural Ergonomic Keyboard 4000
> https://bugs.launchpad.net/bugs/84965
> You received this bug notification because you are a direct subscriber
> of the bug.
>

GeertPoels (geert-poels) wrote :

Hei Ku, this "being in the kernel" : if I read the comment at the link by fishor, I was only done in August.
What are the options now ?
The Ubuntu kernel maintainers will never apply this fix on an older kernel.
It will most naturally come with Hardy.

ARGH....
  When I recompiled the kernel (Huge leap of faith for a noob) not only did it not fix the keyboard but killed my wireless too. At this point I'd just like to know what keyboard layout to select so that the standard 105 keys will work. I have no number pad with anything I've tried and I use it a lot.

  This is a very popular keyboard that really helps my Tunnel Carpal Syndrome and I hope someone will put in the effort to fix it, even if it is a product of the evil empire.

  After six hours I'm quite frustrated with technology and will be retiring to the parlor with a pack of cards, some long necked bottles and an oil lamp.

Nick Jenkins (nickpj) wrote :

In Ubuntu 8.04.1 almost all of the keys are working, apart from the zoom key / slider. Is there some way to get the zoom key to behave like the scroll wheel on a mouse (e.g. scoll up and scroll down a web page when zoom slider is slid up or slid down?). The zoom key is marked with a red "1" in this diagram: http://i.testfreaks.com/images/products/600x400/159/microsoft-natural-ergonomic-keyboard-4000.205983.jpg

P.s. To get the back / forward keyboard keys working in Firefox, when using the "Microsoft Natural Ergonomic 4000 Keyboard", go System -> Preferences -> Keyboard -> Layout -> click the model button -> Choose Microsoft -> set model to "Microsoft Natural Keyboard Pro USB" -> click "close".

Benjamin Prosnitz (aetherane) wrote :

I just want to mention that someone opened a new bug report on the Zoom issues that still exist:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/264287

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers