custom DSDT loading patch needed in feisty

Bug #83544 reported by Johannes Frank on 2007-02-06
32
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Medium
Kyle McMartin

Bug Description

Binary package hint: linux-image-2.6.20-6-generic

The patch from Eric Piel is not yet contained in the generic linux image.
Including a custom DSTD.aml in initramfstools followed by a dpkg-reconfigure linux-image-$(uname-r) has no effect.
Patch available at: http://gaugusch.at/kernel.shtml

I confirm that i have some problems with ACPI and this kernel version. I think that its related to this, because i can boot only with acpi=off option

Colin Darie (colinux) wrote :

I have also this problem on feisty (herd cd 3, linux-image-2.6.20-6-generic) on a laptop Toshiba P100-284. I have to apply a custom DSDT because sound doesn't work (apparently as all P100 family) and the DSDT.aml has no effect on a reconfigure.

Michael Stempin (mstempin) wrote :

I can confirm this!
On my Asus M2400N Laptop (1.5 GHz Centrino, 512 MB RAM) the kernel only boots if I put acpi=off as a parameter on boot.
If acpi=off is not set the grey box with "loading the Linux kernel" appears for a couple of seconds, then disappears and the machine reboots.

Having set acpi=off the Desktop-CD boots just fine and everything seems to work (except extra keys (but I haven't played around with that yet).
I am actually typing this being online with the Desktop CD.

If any further information is needed just let me know.

--> I also posted this on Bug #83290 and attached dmesg output if that helps anyhow.
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/83290

Tim Caswell (tim-creationix) wrote :

I have the same problem with my new Toshiba P105-S6147. Since I bought it recently, it came with Vista and the 3.3 version of the bios. I tried downgrading the bios to 2.4 per the Gentoo forum's suggestion and still no good. I followed the instructions for a custom DSDT for Ubuntu Feisty and it didn't do a thing. I really hope this gets fixed. I have no sound, suspend, hibernate, and sometimes it won't even auto-power-down.

Changed in linux-source-2.6.20:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Michael Stempin (mstempin) wrote :

Just for the record on my Asus M2400N Centrino Laptop besides the problem with the extra keys, there is no sound, suspend, hibernate either.
I guess that is due to the acpi=off boot option.

I also really hope this gets fixed soon so I'll be able to test Fesity.

I never encountered these problems during the test versions of Breezy, Dapper and Edgy.
Everything worked fine in those versions.

Kyle McMartin (kyle) wrote :

Hi,

Thanks for your reports, I'll work on getting this fixed for the next feisty Herd release.

Cheers,
 Kyle

Changed in linux-source-2.6.20:
assignee: nobody → kyle
Tollef Fog Heen (tfheen) wrote :

Moving milestone forward.

Changed in linux-source-2.6.20:
status: Confirmed → Fix Released
Michael Stempin (mstempin) wrote :

As I just noticed that this is marked as "Fix Released"...
It is not working with the daily build from today.
It is not even booting with the acpi=off option actually. :-(
Just wnated to let you guys know, since the Feisty-Beta is around the corner (2 days) already.
Not trying to bother anyone... well maybe a little bit. ;-)

Michael Stempin (mstempin) wrote :

Tried the daily build from today again, but no luck. :-(

Wrote something about it here:
https://launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/83290

Since I think those two bugs go hand in hand.

Keep up the good work guys even if this bug prevents me from being able to use feisty I'm still confident that it will rock for others.

Michael Stempin (mstempin) wrote :

This actually seems to solved. :-)
My bad.
It seems that the other bug
https://launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/83290
is not related to this one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments