kernel oops while installing win 2k sp2

Bug #82935 reported by Erik Andrén on 2007-02-02
2
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
Medium
Chris Halse Rogers
linux-source-2.6.20 (Ubuntu)
High
Ben Collins

Bug Description

Binary package hint: kvm

Hi, I got the following oops when I tried to install win2k sp2 using the following command line:
 kvm -no-acpi -m 384 -hda vdisk.windows -cdrom ./Win_2k_Swe_SP2.iso -boot d

Erik Andrén (erik-andren) wrote :
Erik Andrén (erik-andren) wrote :

Without the kvm-intel module, everything works (albeit slow).

This is on a C2D 6600 (2.4 GHz).

The oops happens exactly when the installation switches from the splash screen to the installer screen.

Changed in kvm:
assignee: nobody → ben-collins
importance: Undecided → High
status: Unconfirmed → Fix Committed
Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released
Erik Andrén (erik-andren) wrote :

Ben, was the fix included in the 2.6.20-9? If so it didn't resolve my issue.

Erik Andrén (erik-andren) wrote :

Instead it makes my machine hard freeze.

Erik Andrén (erik-andren) wrote :

This is still an issue. I don't get a bluescreen anymore. Instead, the kvm windows turns black as the win2k installer switches from boot splash to installationmode.
The upstream bugreport suggests that upgrading to kvm-18 should resolve windows installation problems.

Steve Kwee (steve-kwee) wrote :

I am using Feisty 7.04 with kernel 2.6.20-12-generic

I upgraded to kvm-18 and still did not get w2k running.
There was a thread on this topic under
http://article.gmane.org/gmane.comp.emulators.kvm.devel/1860
and the patch posted there is included in kvm-18, but the installer still stops when it comes to the first reboot

# empty disk
kvm-18/bin/qemu-img create -f qcow w2k-srv.img 10G

# boot from cd
kvm-18/bin/qemu -cdrom iso/w2k-srv.iso -boot d -hda w2k-srv.img -m 384 -noacpi

without the -no-acpi the installation hangs during the first file copy phase of the windows installer

Chris Halse Rogers (raof) wrote :

Have you tested with the kvm in Gutsy (1:28-4ubuntu1)?

Changed in kvm:
importance: Undecided → Medium
status: New → Incomplete
assignee: nobody → raof
Soren Hansen (soren) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It would be very helpful if you could test it in Ubuntu Hardy (you can do this from a LiveCD!).

Erik Andrén (erik-andren) wrote :

I have no interest anymore in getting this bug fixed since I have switched to Virtualbox and am satisfied with its performance.
Close?

Soren Hansen (soren) on 2008-08-25
Changed in kvm:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers