Feisty herd 3 desktop CD sometimes fails to boot on CHGL30945PM1

Bug #82921 reported by Marc Tardif on 2007-02-02
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Medium
Ben Collins

Bug Description

When installing from the Feisty herd 3 desktop CD, the system sometimes fails to load with the following error message:

udevd[4076]: lookup_group: specified group 'nvram' unknown
udevd-event[4122]: udev_db_add_device: unable to create db file '/dev/.udev/db/class@input@mice': No such file or directory
[ 80.056000] intel_rng: FWH not detected
[ 81.760000] si3054: cannot initialize. EXT MID = 0000
[ 91.796000] BUG: soft lockup detected on CPU#0

Then, when rebooting with the same media, it sometimes works and installation completes successfully.

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

Are you absolutely sure it's not a media problem?

Kyle McMartin (kyle) wrote :

Would it be possible to get a dmesg, or /var/log/syslog? If not, I've got a few other ideas, but we'll see first.

(Does it go away if you add "noreplacement" to the kernel command line?)

Brian Murray (brian-murray) wrote :

Is it possible the same media from bug 82958 was used for this test?

Changed in linux-source-2.6.20:
assignee: nobody → brian-murray
Mikael Nilsson (mini) wrote :

Could it be wireless? Check bug #63418. Try booting with wireless turned *on*.

Tollef Fog Heen (tfheen) wrote :

Moving milestone forward.

Tollef Fog Heen (tfheen) wrote :

Moving milestone forward, herd-5 is out.

Marc, please answer the questions in the bug report.

Marc Tardif (cr3) wrote :

When I attempt to install Feisty herd 5 using media that has been checked, I still get the same error messages as before during the boot process:

udevd[4076]: lookup_group: specified group 'nvram' unknown
udevd-event[4122]: udev_db_add_device: unable to create db file '/dev/.udev/db/class@input@mice': No such file or directory
[ 80.056000] intel_rng: FWH not detected
[ 81.760000] si3054: cannot initialize. EXT MID = 0000

The only difference from my original bug report is that I am no longer able to reproduce the following error message:

[ 91.796000] BUG: soft lockup detected on CPU#0

To clarify the original bug report, the above error messages appear between displaying the splash screen with the progress bar and the gnome desktop. So, even though I get error messages, I consistently reach the desktop which enables me to proceed with the installation.

Also, Mikael Nilsson suggested that the problem might only occur when the wireless was turned off. However, I have tested with both wireless turned on and off, and I get the exact same results both times.

Kyle McMartin (kyle) wrote :

Can you post an lsmod and the complete dmesg? Softlockups are caused by someone holding interrupts disabled for too long (which can be caused by either a long delay in a critical section, or a deadlock on a spinlock), so they are quite hard to debug without all the info other than the "soft lockup detected" message.

Ben Collins (ben-collins) wrote :

Fairly certain this one is fixed with the -11 kernel. Most likely caused by the wireless rfkill switch.

Try flipping the switch to see if it affects the boot, and if it does, try upgrading to the -11 kernel to see if that resolves the boot problem for when the switch is enabled.

Changed in linux-source-2.6.20:
assignee: brian-murray → ben-collins
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

The above two files, lsmod.txt and dmesg.txt, were generated on the installed system which doesn't produce the error messages encountered when booting from the installation media.

The following two files were generated after booting from the installation media.

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

Since Kyle mentionned the problem might be related to kernel modules, here is the difference between the lsmod on an installed system and the lsmod on a system after booting from the installation media:

3c3
< af_packet 23816 2
---
> af_packet 23816 6
7c7
< ata_piix 16132 3
---
> ata_piix 16132 1
26c26
< ext3 133128 2
---
> ext3 133128 0
30c30,31
< freq_table 5792 3 acpi_cpufreq,cpufreq_ondemand,cpufreq_stats
---
> freq_table 5792 3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
> fuse 46612 1
38,39c39,41
< ipv6 261920 12
< ipw3945 118688 0
---
> ipv6 261920 10
> ipw3945 118688 1
> isofs 36284 1
44c46,47
< libata 117912 2 ata_generic,ata_piix
---
> libata 117912 2 ata_piix,ata_generic
> loop 17800 2
48a52
> nls_cp437 6784 1
61c65
< scsi_mod 142348 4 sg,sd_mod,sr_mod,libata
---
> scsi_mod 142348 4 sg,sr_mod,sd_mod,libata
63c67
< sd_mod 22272 4
---
> sd_mod 22272 0
84c88,89
< sr_mod 17060 0
---
> squashfs 46340 1
> sr_mod 17060 1
91a97
> unionfs 74148 1

Marc Tardif (cr3) wrote :

Ben, I have tested booting from the herd 5 desktop CD with both wireless turned on and off, and I get the exact same results both times.

Ben Collins (ben-collins) wrote :

I'm hoping this is fixed with the -12 kernel. We'll know when you can test beta.

Marking as needs info to remind Marc of re-testing when beta is released (unless you can upgrade to current fiesty and re-test).

Changed in linux-source-2.6.20:
importance: Undecided → High
Marc Tardif (cr3) wrote :

I have tested the latest daily-live cd which comes with the 2.6.20-12-generic kernel and I have observed the exact same behavior as with Feisty Herd 5.

Ben Collins (ben-collins) wrote :

Can you include dmesg from that boot please?

Thanks

Marc Tardif (cr3) wrote :
Ben Collins (ben-collins) wrote :

Are you just seeing the messages, or still getting a softlockup? I'm not really concerned about any message other than a softlockup, or something preventing the system from actually working.

Changed in linux-source-2.6.20:
importance: High → Medium
Marc Tardif (cr3) wrote :

The only difference from my original bug report is that I am no longer getting the softlockup message. The other messages are not preventing the system from actually working.

Ben Collins (ben-collins) wrote :

Ok, then the ipw3945 fix did take care of the softlockup.

Thanks

Changed in linux-source-2.6.20:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers