soft lockup detected on CPU#0! when booting from feisty-desktop-i386

Bug #80502 reported by Marc Tardif on 2007-01-18
10
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
High
Unassigned

Bug Description

When booting from the feisty herd 2 CD for i386 desktop, the usual startup screen appears. When selecting "Start or install Ubuntu", casper start loading and the usual scrollbar appears. However, before seeing the desktop, the process crashes with the following error message:

udevd[3969]: lookup_group: specified group 'nvram' unknown
udevd-event[4015]: udev_db_add_device: unable to create db file '/dev/.udev/db/class@input@mice': No such file or directory
[ 96.128000] intel_rng: FWH not detected
[ 98.224000] si3054: cannot initialize. EXT MID = 0000
[ 107.848000] BUG: soft lockup detected on CPU#0!

Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :
Marc Tardif (cr3) wrote :

Ben this is an regression we are seeing at the certification lab. Please make to address this bug before herd3.

Ben Collins (ben-collins) wrote :

Please also test this with amd64 CD.

Can you boot without the "splash quiet" flags, and see if you get more output?

Thanks

Changed in linux-source-2.6.20:
assignee: ben-collins → nobody
status: Unconfirmed → Needs Info
Ampinder (ajaysingh99) wrote :

Hi, I have tested the amd64 cd into the machine as you mentionned I got the message saying that my machine is a 32bit system that 64bit system is not supported. It's normal it's the machine has a i386 processor. I think we got a misunderstanding, you could see in the cpuinfo file that it's a i386 processor.

Marc Tardif (cr3) wrote :

When booting without the "splash quiet" flags, here are the last few lines which appear:

[ 95.028000] NET: Registered protocol family 17
[ 95.692000] si3054: cannot initialize. EXT MID = 0000
 * Loading kernel modules...
[ 96.164000] fuse init (API version 7.8)
 * Activating swap...
mount: Function not implemented
[ 105.968000] BUG: soft lockup detected on CPU#0!

I would've liked to send the entire syslog file but it is not possible to switch to the other terminals.

soc (simon-ochsenreither) wrote :

I have the same problem on 2 laptops, one i386, one amd64.
I can solve the problem by toggling wireless on and off during boot (both use the ipw3945 driver).

Robert McMeekin (rrm3) wrote :

I have the same problem on a Toshiba A105-S2101.

Confirmed on a ThinkPad T60:

> I have the same problem on 2 laptops, one i386, one amd64.
> I can solve the problem by toggling wireless on and off during boot
> (both use the ipw3945 driver).

Tollef Fog Heen (tfheen) wrote :

Moving milestone forward.

Same problem here Compal HEL80 core duo 2500, nvidia 7600

Confirmed on a Fujitsu Siemens Amilo A1630, after recovering from suspend and wireless activated (Ralink RT2500).
Deactivating the wireless card, suspend works.

Oops, :s/suspend/hibernate/g

Paul Hirst (paul-hirst) wrote :

I've just seen this bug for the first time after upgrading to 2.6.20-16. The last thing recorded in /var/log/messages is information about the fglrx driver being loaded.
For the moment I think I'm going to have to revert to the 2.6.20-15 kernel because the computer is unusable. X starts but the splash loading bar doesn't display and all disk activity stops. You can still move the mouse pointer but that's all. You can't kill X or switch to a VT.

Paul Hirst (paul-hirst) wrote :

I should have said. If it switch immediately to a VT when X loads I can, but a couple of seconds later 'BUG: soft lockup detected on CPU#0' appears on the screen and then the whole machine locks up.

Launchpad Janitor (janitor) wrote :

[Expired for linux-source-2.6.20 (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers