Ubuntu

Fiesty Live CD crashes during Boot

Reported by eitan on 2007-01-08
24
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

I have a repeat error while trying to install Ubuntu 7.10 Fiesty Herd 1 Desktop from a live CD. The error occurs after the "Ubuntu" start up screen (with the orange bar on the bottom) is complete. The error is as follows:

"Busyboy v1.1.3 (Debian 1:1.1.3-3ubuntu2) Built in shell (ash)
bin/sh: can't access tty; job control turned off"

And I am kicked to some terminal as (initramfs).

My station is a Sony Vaio VGN-N130G laptop. I am able to install both 6.06 and 6.10 through their live CDs without any trouble.

Chris Burgan (cburgan) wrote :

Thanks for the report.

Does this problem still occur with Feisty Herd 2?

Dmitriy Volk (dmitriy-volk) wrote :

Same exact problem happens with Xubuntu Live CD 7.10 Feisty Beta.
Laptop model is Sony Vaio PCG-Z505HS (old... very old).
Haven't tried 6.06 or 6.10 yet.

Changed in casper:
status: Needs Info → Unconfirmed
Andy Kniss (akniss) wrote :

Same problem with ISO 20070415 on a Dell Dimension 8250
Intel P4 3.06 GHz
1 GB PC1066 RDRAM
128 MB DDR ATI Radeon 9700 Pro
120 GB 7200rpm (not sure what brand or type)
2000FP Digital Flat Panel Display

Andy Kniss (akniss) wrote :

https://www.stgraber.org/ubuntu/isotesting/result/154/3

Gives a description on the ISO testing page.

Daniel Pinske (piniator) wrote :

Same problem with Feisty Final Live CD on a Samsung V25 Laptop.

I was able to mount my fat32 partition and copy the casper.log. My cdrom drive seems to be /dev/sda1 as I can mount it manually, but it never tries to mount it. Is there a way to tell casper which cdrom drive to use?

Jaap Woldringh (jjh-woldringh) wrote :

With one of my computers I have the same problem.
It installs Dapper and Edgy (and any other distro I tried) without a problem.
Feisty Live CD does not boot however, which I now think is related to initramfs, which I think (not know) replaces
initrd. Sorry if I am mistaken in this.
Without quiet and splash I get on booting (hand copied):

........
........
[65.733286] hdc: ATAPI 48X CD-Rom driver, 128 kB Cache, DMA
[65.733671] Uniform CD-ROM driver Revision: 3.20
cp: unable to open 'root/var/log/': No such file or directory
Done
Begin: Running /scripts/unit-bottom...
mount: Mounting /root/dev/ in /dev/.static/dev failed: no such file or directory
Done
mount: ............ : No such file or directory
.......
.......
target system doesn't have /sbin/init

Replacing the CD-ROM drive with another one did not change this, except now a
ATAPI 24X CD-Rom was found.

Replacing the NIC did not help either (it was due anyway, as it already did not
work well in Edgy).

I have downloaded the alternate CD and this seems to work, I could check it for errors,
and it is now checking the memory of my system, already one pass without finding an error.

A short description of my system:

MB chipset: Aladdin 5
Processor: AMD K6-2 501.2 MHz
Memory: 320 MiB, 217 MiB/s

I sincerely hope this will help you correct this bug, which, as I already said, seems to
be related to initramfs

Jaap

Jaap Woldringh (jjh-woldringh) wrote :

addition to previous post:

After three passes memory seems OK

I tried to boot the Live CD of Feisty Fawn another time, with the boot option break=top, quiet and splash removed, without success. Hand copied the last lines were:

[...] Time: tsc clocksource has been installed
[...] Freeing unused kernel memory: 328k freed
Loading, please wait ...
[...] input: AT Translated Set 2 keyboard as /class/input/input1
Spawning shell within the initramfs
BusyBox v1.1.3 .... etc
(initramfs) modprobe = piix
(initramfs) exit
.....
.....
.....

after this I get to exactly the same error as described in the previous post, after the line Uniform CD-ROM driver Revision: 3.20

So far the Live CD of Feisty is quite useless on this computer....

The boot option break=top and the initramfs action modprobe = piix I retrieved from some other related bug report I found here :).

I am going to install with the alternate CD now, which, I think, uses initrd, anyway it uses the non graphical installer, which is quite OK with me.

Jaap

Jaap Woldringh (jjh-woldringh) wrote :

In addition to my previous post:

Install using the alternate CD succeeded. Changed the second hard disk (hdb) though after that as Feisty could not find the /home directory which was on that disk.

On the new hdb same problem until I installed (with the alternate CD) this HD, keeping the other partitions on hda, and breaking off the install, which gave a number of complaints, but now everything runs OK (so far). Now /home is found, which makes me think the previous hdb was dying.

Booting the Live CD again, after this, gives the same problems, however.... so it is not the possibly dying previous hdb-disk which was the cause, though the bug may be related to the *existence* of a second hard disk (???).

Off topic: due to the misspelling of Feisty (Fiesty) in the heading this bug report was difficult to find.

Typing this in Feisty, on this computer:

Jaap

Brian Murray (brian-murray) wrote :

Jaap - if possible could you please add the output of 'lspci -vvn' and 'lspci -vv' from a working install of Ubuntu to your bug report as attachments? Thanks in advance.

Changed in casper:
assignee: cburgan → brian-murray
status: Unconfirmed → Needs Info
Jaap Woldringh (jjh-woldringh) wrote :

Herewith the attachment of lspci -vv on the computer affected.
I tried to attach the other file too, but that seems not possible so the other one comes in the next message.

I must say the affected computer was changed: it got other hardd disks and other memory, but in the new condition it acted the same and Ubuntu was installed using the Alternate CDrom

Jaap

Jaap Woldringh (jjh-woldringh) wrote :

And here is the other one :)

Good luck, thanks for attending this nasty bug, one of my three computers are suffering from it, the only one with two hard disks, the other ones ( a laptop and a desktop) have only one.

Jaap

Changed in linux-source-2.6.20:
assignee: brian-murray → ubuntu-kernel-team
importance: Undecided → Medium
status: Needs Info → Confirmed

I have the exact same problem, and that "modprobe piix" does nothing for me.

The same thing also happens on gutsy beta versions, and "modprobe piix" doesnt work because it says "FATAL: module piix not found"

PLEASE fix this before the final of gutsy, ive already missed out on feisty and i dont want the same thing to happen with gutsy.

Please fix this problem before the final of gutsy. On the gutsy alpha versions the problem is still present.

I was able to install it, but still with problems with my cdrom.
It's a Dell 1420. I read on some forums that 'modprobe piix' should solve my problem, but I don't have the module.
What can I do to have this module ?

Thanks.

Error message: FATAL: Module piix not found.
Kernel version: Linux anakin 2.6.22-9-generic #1 SMP Fri Aug 3 00:50:37 GMT 2007 i686 GNU/Linux

I've managed to fix this by extracting the feisty live cd to a partition then booting into it via grub, BUT FIRST I UNPLUG MY CD ROM DRIVE.

Then i can install and use it, but if i plug my cd rom drive back in and try to boot into feisty i get the same error.

So i can now have feisty with no cd rom drive or no feisty at all.

P.S. this happens with all distros on a 2.6.20+ kernel.

P.S. (see my above post).

I have an internal "diamond data DVD read/write" cd drive. Also know as "atapi dual layer 4max cd/dvd rom drive". My elive linux detects it as hdc just fine.

If any more information is needed, or if you need to test a bug fix on someones computer my email address is <email address hidden>

Jaap Woldringh (jjh-woldringh) wrote :

I have tried Gutsy tribe 3 and 4 (if I have the numbers right, the two latest tribes of Gutsy at this time or writing), and they both install quite well on this computer: no problem at all. So for me the problem is fixed, assuming nothing will be changed. I congratulate you with your solution, but a solution that means unplugging the CDROM drive is no real solution, I am afraid :)

So you (jaap woldringh) had this same problem but its been fix in tribe 3 and 4, or did you never have this problem?

Jaap Woldringh (jjh-woldringh) wrote :

Hello Tommytabib,

Please see my postings above to see whether I had this same problem or not :)
I really think that the problem is not the same for everyone affected, and that a cure that fixes this for one person does not fix this for another. In your case it seems that the CDROM drive is the problem, in my case it isn't. I hope the real cause(s) of this nasty bug will be found and repaired.

Shang Wu (shangwu) wrote :

Try F6 to enter "Other Options" and add "all_generic_ide" at the end of the line.

Well guys, I was able to install and boot using the liveCD.
 My problem is after the installation, 'cause the cdrom is missing and I
can't load the "piix" module to get it working.
 I totally agree that it's not the same problem for everyone, since some can
load the module, some can fix with the all_generic_ide during the boot
(think these people can't install also) and some has problems after the
installation, with the system running... that's my case...

On 8/14/07, ShangWu <email address hidden> wrote:
>
> Try F6 to enter "Other Options" and add "all_generic_ide" at the end of
> the line.
>
> --
> Fiesty Live CD crashes during Boot
> https://bugs.launchpad.net/bugs/78380
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
__________________________________
William Markito Oliveira
phone: +55 19 91090198
mail: <email address hidden>

description: updated
Steve Dodd (anarchetic) wrote :

Here's another thing that might help .. I've got an old machine here that the kernel disables ACPI on, because it thinks (incorrectly) that the BIOS is too old. With no ACPI, it somehow doesn't seem to setup the second IDE channel properly, so I can't access the CD-ROM. Adding "acpi=force" to the kernel command line fixes it.

I have a similar problem. I have had Edgy running for almost 1 year now, with only minor hiccups.

However, I opted last week to download the Feisty upgrade and now cannot boot up - I can only run off the Edgy 6.10 Live CD to access the web etc.

I also get the "tty" problem

Is there any way I can roll back to Edgy without losing the data on my hard drive? Can I re-install Edgy? I'd be happy to just have a system that is working and let someone smarter figure out the bug in the mean time.

Op woensdag 03 oktober 2007, schreef digger:
> I have a similar problem. I have had Edgy running for almost 1 year now,
> with only minor hiccups.
>
> However, I opted last week to download the Feisty upgrade and now cannot
> boot up - I can only run off the Edgy 6.10 Live CD to access the web
> etc.
>
> I also get the "tty" problem
>
> Is there any way I can roll back to Edgy without losing the data on my
> hard drive? Can I re-install Edgy? I'd be happy to just have a system
> that is working and let someone smarter figure out the bug in the mean
> time.

This is a well known problem with the Feisty Live CD, and there appears to be
no real cure which works for everybody.
What you can try is to install the alternate CD for Feisty.
Better still: why not wait a couple of weeks and try the newest (K)Ubuntu,
(Gutsy) which will be released October 18th.
Success

Steve Dodd (anarchetic) wrote :

digger:

The upgrade should have left your earlier kernels in the grub menu - does falling back to those help? Also, dmesg output would be useful (if possible - don't know if dmesg is included in the initramfs), alternatively booting without the 'splash' and 'quiet' kernel command line options might yield some information.

Well i got it working!

I just installed a new asus lightscribe dvd burner and put my old dvd drive as the slave, and now all works as it should.

Strange thing is that the cd drive that was causing this problem is still plugged in and is working, i think its because its now as a slave it just cooperates. Weird.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Jaap Woldringh (jjh-woldringh) wrote :

I cannot test this because my computer does not boot at all....

It says: "This kernel requires the following features not present on the CPU
cmov
Unable to boot - please use a kernel appropriate for your CPU."

The processor is an AMD-K6 2 / 500 MHz.

The tested image is intrepid-desktop-i386.iso, the MD5sum is correct.

I am sorry that I can not help you here, except that another issue now appears that ***an i386 image does not work with an i386 processor***!!

Glad to see that you are still working on this topic, I clean forgot about it as I use the alternative images to install on this computer, which goes without a hitch.

(as an aside: it is my only computer (out of three) that runs Hardy without freezing!!!)

Greetings, and sorry for this,

Jaap Woldringh

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Jaap Woldringh (jjh-woldringh) wrote :

I am sorry that I cannot test this anymore, as the computer which had this problem is replaced by another one. Which even seems to run Hardy without a problem :)

Greetigs,

Jaap Woldringh

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Ike Panhc (ikepanhc) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04. To reopen the bug, click on the current status, under the Status column, and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers