Linux won't recognize had drive on Dell Inspiron 1501

Bug #74830 reported by lusich on 2006-12-07
16
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
High
Kyle McMartin

Bug Description

Bottom line is, you can install the distro on the laptop by adding "acpi=force
irqpoll" to the boot, but during start up or shutdown the computer gives a load
of errors of the type:"unexpected IRQ trap at vector b8 " or "b0" for that
matter. It goes into a loop and eventually freezes.

Here are a few threads on the topic:
http://forums.gentoo.org/viewtopic-p-3764583.html#3764583
http://ubuntuforums.org/showthread.php?t=299929
http://community.livejournal.com/linux/1554783.html

there are also a few threads going on at Dell Community forum under Hard
Drives,
but no real solution yet. The "irqpoll" solution is not a good one, since it
doesn't fix the problem, it rather just ignores it, and your laptop then still
freezes.

Robbie Groenewoudt (dutchmega) wrote :

I can confirm this bug in my Dell Inspiron 1501

However, "ircpoll acpi=force" is not needed. Only "pci=nomsi" is needed. With that, you also wikidon't get any nasty IRQ traps.

bios-version:2.1.0
system-manufacturer:Dell Inc.
system-product-name:Inspiron 1501

Ubuntu Edgy with latest updates

Robbie Groenewoudt (dutchmega) wrote :

Attached hdparm -iI

Robbie Groenewoudt (dutchmega) wrote :

Same problem at Herd 4 Feisty Fawn.

Ubuntu not booting would be an important bug I guess

Ben Collins (ben-collins) wrote :

I think this was fixed by not using MSI by default, but kicking to the team so we can review it later.

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: Unconfirmed → Confirmed

"pci=nomsi" does work as I have the same notebook, but if you have a SD card in the built-in slot, Ubuntu will boot the live CD without a CPU fault and Ubuntu will NOT install. It will error out while trying to boot the live CD. It will never boot completely with a SD card in the built-in slot. Windows Vista will boot even with the SD card in the slot... This makes me believe the problem lies in Ubuntu or the Linux Kernel itself... I believe the error was something like CPU 0 Soft Lock or something similar to that.

Also, the built-in wireless card does not work on the Dell Inspiron 1501.

I wanted to add that although "pci=nomsi" does work, the average new user will not know this and assume that Ubuntu is broken.

Also, if a SD card is in the built-in slot, the user will not connect the two and assume Ubuntu is broken when it locks up during every live CD boot and/or install.

Robbie Groenewoudt (dutchmega) wrote :

"Also, the built-in wireless card does not work on the Dell Inspiron 1501."

The wireless works with ndiswrapper. It will be supported in kernel 2.6.21 so when that one is released, maybe we can get a patch via backports.

I don't have a SD-card, I can't test it here

Tollef Fog Heen (tfheen) wrote :

Moving milestone forward; herd 5 is out.

Download full text (58.8 KiB)

ubuntu@Dell:~$ dmesg
[17179569.184000] Linux version 2.6.17-11-generic (root@terranova) (gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)) #2 SMP Thu Feb 1 19:52:28 UTC 2007 (Ubuntu 2.6.17-11.35-generic)
[17179569.184000] BIOS-provided physical RAM map:
[17179569.184000] BIOS-e820: 0000000000000000 - 000000000009dc00 (usable)
[17179569.184000] BIOS-e820: 000000000009dc00 - 00000000000a0000 (reserved)
[17179569.184000] BIOS-e820: 00000000000ce000 - 0000000000100000 (reserved)
[17179569.184000] BIOS-e820: 0000000000100000 - 0000000077e70000 (usable)
[17179569.184000] BIOS-e820: 0000000077e70000 - 0000000077e81000 (ACPI data)
[17179569.184000] BIOS-e820: 0000000077e81000 - 0000000077f00000 (ACPI NVS)
[17179569.184000] BIOS-e820: 0000000077f00000 - 0000000080000000 (reserved)
[17179569.184000] BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
[17179569.184000] BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
[17179569.184000] BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
[17179569.184000] BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
[17179569.184000] 1022MB HIGHMEM available.
[17179569.184000] 896MB LOWMEM available.
[17179569.184000] found SMP MP-table at 000f8780
[17179569.184000] On node 0 totalpages: 491120
[17179569.184000] DMA zone: 4096 pages, LIFO batch:0
[17179569.184000] Normal zone: 225280 pages, LIFO batch:31
[17179569.184000] HighMem zone: 261744 pages, LIFO batch:31
[17179569.184000] DMI present.
[17179569.184000] ACPI: RSDP (v000 PTLTD ) @ 0x000f8750
[17179569.184000] ACPI: RSDT (v001 DELL M08 0x06040000 LTP 0x00000000) @ 0x77e7a60c
[17179569.184000] ACPI: FADT (v001 ATI Bowfin 0x06040000 ATI 0x000f4240) @ 0x77e80c4d
[17179569.184000] ACPI: TCPA (v002 AMD 0x06040000 PTEC 0x00000000) @ 0x77e80cc1
[17179569.184000] ACPI: SSDT (v001 PTLTD POWERNOW 0x06040000 LTP 0x00000001) @ 0x77e80cf3
[17179569.184000] ACPI: MADT (v001 PTLTD APIC 0x06040000 LTP 0x00000000) @ 0x77e80e08
[17179569.184000] ACPI: MCFG (v001 PTLTD MCFG 0x06040000 LTP 0x00000000) @ 0x77e80e4e
[17179569.184000] ACPI: SLIC (v001 DELL M08 0x06040000 LTP 0x00000000) @ 0x77e80e8a
[17179569.184000] ACPI: DSDT (v001 ATI SB600 0x06040000 MSFT 0x03000000) @ 0x00000000
[17179569.184000] ATI board detected. Disabling timer routing over 8254.
[17179569.184000] ACPI: PM-Timer IO Port: 0x8008
[17179569.184000] ACPI: Local APIC address 0xfee00000
[17179569.184000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[17179569.184000] Processor #0 15:12 APIC version 16
[17179569.184000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[17179569.184000] ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
[17179569.184000] IOAPIC[0]: apic_id 1, version 33, address 0xfec00000, GSI 0-23
[17179569.184000] ACPI: IRQ9 used by override.
[17179569.184000] Enabling APIC mode: Flat. Using 1 I/O APICs
[17179569.184000] Using ACPI (MADT) for SMP configuration information
[17179569.184000] Allocating PCI resources starting at 88000000 (gap: 80000000:60000000)
[17179569.184000] Built 1 zonelists
[17179569.184000] Kernel command line...

dmesg, lsmod, lspci -n, lspci -vvnn, sudo lspci -vvnn

Ben Collins (ben-collins) wrote :

Can someone confirm whether this is still the case on latest kernels?

Robbie Groenewoudt (dutchmega) wrote :

It works now at 2.6.20-12-generic :)

Ben Collins (ben-collins) wrote :

Thanks, most likely due to Kyle's patch for disabling msi by default. It can be enabled with pci=msi if anyone needs it.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → kyle
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers