Ubuntu

ata2 timeouts, fails to boot

Reported by jmevatt on 2006-12-01
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: linux-image-2.6.19-7-generic

When loading 2.6.19 on my system after a fresh dist-upgrade to feisty, it stalls when it's loading the ata2 drivers. There's a few informational messages that go something like this:

ata2.00: ATAPI, max UDMA/33

and it apparently tries to load some drivers (or maybe it's searching for drives) and stalls (doesn't do anything).

After a couple of minutes, it times out and prints this message:

ata2: failed to recover some devices, retrying in 5 secs
ata2.00: configured for UDMA/33

and then repeats the cycle a few more times before continuing. After it makes it past this, it attempts to load the USB drivers, and stalls once again after loading the USB HID core driver (but no error messages). After this, it prints the following message:

Alert! /dev/hda5 doesn't exist

(/dev/hda5 is my root mount point)

and loads BusyBox and drops to a shell (ash) with the (initramfs) prompt.

I figure it's attempting to (and failing to) detect my hard drive(s). Rebooting to 2.6.17 works fine.

jmevatt (jmevatt) wrote :

I should also mention that the version for the image I'm using (linux-image-2.6.19-7-generic) is 2.6.19-7.10.

Sokraates (sokraates) wrote :

I can confirm this.

There were no problems with the first feisty-kernels. Yesterday I updated for the first time since about a month and then I received this error.

Chrooting into feisty from my edgy-install works, though.

Sokraates (sokraates) wrote :

Here's my output with "quiet" set:

[ 66.357532] ata2.00: failed to set xfermode (err_mask=0x4)
[101.904734] ata2.00: failed to set xfermode (err_mask=0x4)
[137.447946] ata2.00: failed to set xfermode (err_mask=0x4)
[142.446202] ata2.01: failed to set xfermode (err_mask=0x40)
ALERT! /dev/hdb3 does not exist. Dropping to shell!

After the BusyBox-message there is a line:
/bin/sh: can't access tty; job control turned off

/dev/hdb3 is my root-partition for feisty. Without "quiet", the xfermode-errors are somewhere in the middle of the output.

Finally the CD-ROM drivers are loaded, then "Done" is displayed, followed by the ALERT-line.

My mainboard is a MSI KT4AV. The HDs are two Samsung SpinPoint 160 GB.

Ben Collins (ben-collins) wrote :

First off, edit /boot/grub/menu.lst and remove the line that starts "# kopt_2_6 = root...", then run "sudo update-grub".

Then retest against 2.6.20 aswell.

Changed in linux-source-2.6.19:
status: Unconfirmed → Needs Info
Stéphane Marguet (stemp) wrote :

Thanks Ben, worked for me for the 2.6.19-7 kernel.
But still not for the 2.6.20

Sokraates (sokraates) wrote :

Works for me too with 2.6.19-7. It fails with 2.6.19-5, though (BusyBox-error). 2.6.17-10 works flawlessly. I still need to download 2.6.20 and will post the results.

Booting takes ages with 2.6.19-7 now, but it works.

The system shows "Starting up" and then nothing happens for a while. After a long time the ata2 errors I posted above appear. Only the numbers in the brackets are different on each boot. Finally there is a new error:

udevd[4403]: lookup_group: specified group 'nvram' unknown
udevd-event[4448]_ udev_db_add_device: unable to create db file '/dev/.udev/db/class@input@mice': No such file or directory

That's bug 73425.

By the way: The menu.lst I use is located on my Edgy-root-partition.

So to make this work I had to chroot into feisty, update grub and then copy the new entries from the Feisty-menu.lst into the Edgy-menu.lst.

Ben Collins (ben-collins) wrote :

Still need info on 2.6.20-4.

Changed in linux-source-2.6.20:
importance: Undecided → High
Sokraates (sokraates) wrote :

Finally works for me with 2.6.20-5.

Only bug 73425 remaining (and probably another one giving a weird message, but that remains to be seen).

Thank you very much!

Changed in linux-source-2.6.20:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers