Failed to allocate mem resource #6 ...

Bug #54294 reported by Duncan Lithgow on 2006-07-27
56
Affects Status Importance Assigned to Milestone
Linux
Invalid
Unknown
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Low
Ben Collins
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Every time I boot my laptop, an HP Pavilion dv8220ea (https://wiki.ubuntu.com/LaptopTestingTeam/HP_Pavilion_DV8220EA) I get the text below which I've taken from /var/log/syslog:

[ 0.372370] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
[ 0.372441] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
[ 0.372506] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
[ 0.372571] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
[ 0.372636] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
[ 0.372702] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
[ 0.372850] PCI: Cannot allocate resource region 0 of device 0000:06:00.0
[ 0.373818] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0

I'm not quite sure what it means but I thought someone should know about it. I haven't seen any problems with the boot up otherwise, runs nicely.

Since the original bug the following systems have been added to this bug: (last updated 12th Sept.)
Supermicro PDSBE-0 board
Acer Aspire 5021WLMi
ACER Aspire 5920G with Ubuntu Feisty 7.04
Acer Aspire 9303
ACER Aspire 9410
Acer TravelMate 636LCi (nVidia Geforce 2 Go)
Asus Z71V
BenQ Joybook R55 G21
Compaq C315LA
Fujitsu Amilo XI1526 (nvidia go 7600)
fujitsu siemens amilo PI1556
fujitsu siemens amilo xi 1526
fujitsu siemens amilo pro v2055
HP dv5245ea (nVidiaGeforce GO 7400)
HP dv5285ea (nVidiaGeforce GO 7400)
HP dv6000t
HP dv6000 (nVidia 8400 GS)
HP dv6215Eea (nVidia Geforce 7400)
HP nx9105
HP dv9297ea
HP dv9375eu (nVidia GeForce 7600)
Intel DQ965GF (board?)
Intel 945 PSN desktop MB
MD98000
Sony VAIO VGN-C2ZB
Sony Vaio VGN-FZ11M (GeForce 8400M GT)
Toshiba Satellite 5200-903 (Geforce FX 5600 Go)
toshiba satellite A100 - 750
toshiba satellite m30-801
Toshiba Satellite M35 (nVidia GeForce Go 5200)
Toshiba Tecra S4
Zepto Znote 6214W (nVidia G70)

Duncan Lithgow (duncan-lithgow) wrote :

I see someone has said this effects xserver-xorg-video-ati (Ubuntu), maybe it does but I've got an nVidia card. No ATI stuff here.

Stevn Bartley (sbartley) wrote :

We are getting the same type of error on boot up of a Dapper installed system.

System is using a Supermicro PDSBE-0 board. System installed without error. During system boot we get the following information displayed to the screen:

Uncompressing Linux... Ok, booting the kernel.
[17179574.208000] PCI: BIOS BUG #81[49435024] found
[17179574.208000] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
[17179574.208000] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
[17179574.208000] PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.0
[17179574.212000] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0

The system continues past this and boots normally. All seems to be working correctly but this error during boot is an issue we do not want to put in front of our end users of possible.

Thanks.

Duncan Lithgow (duncan-lithgow) wrote :
Download full text (3.5 KiB)

with kernel 2.6.17-10-generic it looks like this:

Oct 13 07:58:23 localhost kernel: [17179570.884000] Linux Plug and Play Support v0.97 (c) Adam Belay
Oct 13 07:58:23 localhost kernel: [17179570.884000] pnp: PnP ACPI init
Oct 13 07:58:23 localhost kernel: [17179570.912000] pnp: PnP ACPI: found 10 devices
Oct 13 07:58:23 localhost kernel: [17179570.912000] PnPBIOS: Disabled by ACPI PNP
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Using ACPI for IRQ routing
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Cannot allocate resource region 0 of device 0000:06:00.0
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Bridge: 0000:00:01.0
Oct 13 07:58:23 localhost kernel: [17179570.912000] IO window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] MEM window: d0000000-d1ffffff
Oct 13 07:58:23 localhost kernel: [17179570.912000] PREFETCH window: c0000000-cfffffff
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Bridge: 0000:00:1c.0
Oct 13 07:58:23 localhost kernel: [17179570.912000] IO window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] MEM window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] PREFETCH window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Bridge: 0000:00:1c.1
Oct 13 07:58:23 localhost kernel: [17179570.912000] IO window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] MEM window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] PREFETCH window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Bridge: 0000:00:1c.2
Oct 13 07:58:23 localhost kernel: [17179570.912000] IO window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] MEM window: 52000000-520fffff
Oct 13 07:58:23 localhost kernel: [17179570.912000] PREFETCH window: disabled.
Oct 13 07:58:23 localhost kernel: [17179570.912000] PCI: Bus 9, cardbus bridge: 0000:08:06.0
Oct 13 07:58:23 localhost kernel: [17179570.912000] IO window: 00002400-000024ff
Oct 13 07:58:23 localhost kernel: [17179570.912000] IO window: 00002800-000028ff
Oct 13 07:58:23 localhost kernel: [17179570.912000] PREFETCH window: 50000000-51ffffff
Oct 13 07:58:23 localhost kernel: [17179570.912000] MEM wind...

Read more...

Duncan Lithgow (duncan-lithgow) wrote :

The same bug around the net:
* http://lkml.org/lkml/2006/8/27/51
* http://lists.infradead.org/pipermail/linux-pcmcia/2005-September/002708.html with linux-2.6.14-rc2 and Novatel-U530 wireless-modem PCcard
* http://ubuntuforums.org/showthread.php?t=243453

Is this bug the same as #56376 ?

Duncan Lithgow (duncan-lithgow) wrote :

Still present in Feisty Herd 4.

description: updated
Ben Collins (ben-collins) wrote :

I doubt these are actually causing problems. These messages started appearing because of some new sanity checks. They'll still be in dmesg, but they wont clutter your screen. I'd seriously check into a BIOS update though.

Changed in linux-source-2.6.20:
assignee: nobody → ben-collins
importance: Undecided → Low
status: Unconfirmed → Fix Committed
Andrew Henry (adhenry) wrote :

I get the exact same error (cannot allocate resource region 7 & 8) on both a 1.5 yr old Acer Aspire 5021WLMi and a brand new HP DV9297ea. I do not think I have the latest BIOS update for the HP--there is an F.15 version and I have F.14--and I have never upgraded the Acer BIOS, but the HP was manufactured in feb 2007, so why would a BIOS update help? Is there any more specific info you can give Ben, that leads you to recommend a BIOS update?

Duncan Lithgow (duncan-lithgow) wrote :

Still present in Feisty Herd 5, slightly changed to:

[ 0.272524] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
[ 0.272529] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
[ 0.272533] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
[ 0.272537] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
[ 0.272541] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
[ 0.272545] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
[ 0.272634] PCI: Cannot allocate resource region 0 of device 0000:06:00.0
[ 0.304379] NET: Registered protocol family 8
[ 0.304382] NET: Registered protocol family 20
[ 0.305225] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0

... and I only see that last line onscreen - the rest is only in the logs. I'm attaching a new /var/log/dmesg file. The relevant part is around line 185.

Duncan Lithgow (duncan-lithgow) wrote :

I just came across part of this bug in bug #78257 where someone is having trouble with sound in kernel 2.6.20-5. I'm now running 2.6.20-11

[ 0.161771] PCI: Failed to allocate mem resource #6:20000@c0000000 for 0000:01:00.0

I've gone through all the bugs for this kernel which have a similar problem with allocation and given them the tag 'allocate' - I hope that helps with debugging for someone.

Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released

Ben, you've marked this as 'Fix Released'. I'm running the latest kernel (2.6.20-12-generic) and can't see any difference - has this fix been put into the Ubuntu packaged kernel?

Michael (m-gruys) wrote :

Has nothing to do with BIOS version in my opinion.
I have an Intel DQ965GF with the newest BIOS date smbios.bios.release_date = '02/25/2007'
smbios.bios.version = 'CO96510J.86A.5840.2007.0225.2142'
and I got still a PCI: Failed to allocate mem resource #6:20000@e0000000 for 0000:0
1:00.0 message at booting.
However the system works perfectly. The message is only showed when booting and is recorded in /var/log/dmesg
I hope it is not harmful...

Michael (m-gruys) wrote :

addition to prior post:
cat /proc/version
Linux version 2.6.20-12-generic (root@palmer) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Wed Mar 21 20:55:46 UTC 2007

Has nothing to do with BIOS version in my opinion.
I have an Intel DQ965GF with the newest BIOS date smbios.bios.release_date = '02/25/2007'
smbios.bios.version = 'CO96510J.86A.5840.2007.0225.2142'
and I got still a PCI: Failed to allocate mem resource #6:20000@e0000000 for 0000:0
1:00.0 message at booting.
However the system works perfectly. The message is only showed when booting and is recorded in /var/log/dmesg
I hope it is not harmful...

joeamined (joeamined) wrote :

I have the same problem with a HP Pavilion dv6000.
There was no problem with edgy, but since i moved to Feisty i have got this :

[ 0.206515] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0

using kernel 2.6.20-13-generic

Oskar NRK (oskarnrk) wrote :

Same as joeamined, HP Pavillion dv6000, moving from Edgy to Feisty, and I have this error, but after this all works fine.

I can remember that when I use an old Toshiba Satellite A20 and I moved from Dapper to Edgy I had the same (or very very very similar) error.

m4him (register-lomadeluz) wrote :

I have the same problem on an Asus Z71V. I am at the current Bios. Mine hangs on the error mentioned above and does not boot.
I also have the same error with Region 7, Region 8, and Region 9

Joon Guillen (flyderman) wrote :

i would like to report the same on my dv6000t.

Changed back to 'Confirmed' clearly this is not fixed as several people (me at least) are still reporting this problem with the current kernel.

Changed in linux-source-2.6.20:
status: Fix Released → Confirmed
Frank@Home (kinscherff) wrote :

I have to report same issue on a Laptop MD98000 w/ kernel 2.6.20-15-generic.

I did an upgrade from edgy to feisty. This issue started with feisty. System seems to run without problems, but I have not tested 3D on nVidia Corporation GeForce Go 7400 yet.

Attached find my dmesg output with error message showing up during boot.

Regards
Frank

[ 0.198680] PnPBIOS: Disabled by ACPI PNP
[ 0.198740] PCI: Using ACPI for IRQ routing
[ 0.198744] PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
[ 0.238035] NET: Registered protocol family 8
[ 0.238038] NET: Registered protocol family 20
[ 0.238343] pnp: 00:06: ioport range 0x6a0-0x6af has been reserved
[ 0.238348] pnp: 00:06: ioport range 0x6b0-0x6ff has been reserved
[ 0.238829] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0
[ 0.238899] PCI: Bridge: 0000:00:01.0

Timo Aaltonen (tjaalton) wrote :

Closing xorg task.

Changed in xorg:
status: Unconfirmed → Rejected
Jonas Ekström (ekstrom-jonas) wrote :

I get this error message with my fujitsu siemens amilo PI1556 laptop. I did an BIOS upgrade as Ben suggested, still have the error message on boot up. System then boots and seems to be working.
[ 18.242235] PCI: Failed to allocate mem resource #6:20000@0000000 for 0000:0
1:00.0

Attaching dmesg

I'm also getting this error message upon system start up ( on Ubuntu 6.06 and Ubuntu 7.04 ), just before the splash-up screen.

The system seems to be otherwise unaffected.

I'm on an Acer Aspire 9303 laptop with the latest BIOS version.

sriram (sriram-parthasarathy) wrote :

Hi,
I get the very same error message when trying to install Ubuntu 6.10 version in my machine.

Sriram

I have the same dmesg line on ACER Aspire 9410 with BIOS up-to-date.

[ 0.222566] Linux Plug and Play Support v0.97 (c) Adam Belay
[ 0.222594] pnp: PnP ACPI init
[ 0.227906] pnp: PnP ACPI: found 11 devices
[ 0.227927] PnPBIOS: Disabled by ACPI PNP
[ 0.228010] PCI: Using ACPI for IRQ routing
[ 0.228015] PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
[ 0.269385] NET: Registered protocol family 8
[ 0.269389] NET: Registered protocol family 20
[ 0.269993] pnp: 00:07: ioport range 0x6a0-0x6af has been reserved
[ 0.269999] pnp: 00:07: ioport range 0x6b0-0x6ff has been reserved
[ 0.270589] PCI: Failed to allocate mem resource #6:20000@c0000000 for 0000:01:00.0
[ 0.270653] PCI: Bridge: 0000:00:01.0
[ 0.270656] IO window: disabled.
[ 0.270664] MEM window: d0000000-d1ffffff
[ 0.270671] PREFETCH window: b0000000-bfffffff

sebas.rhcp (sebas-rhcp) wrote :

I have the same error, but system works fine

KillerBob (t1000) wrote :

On notebook HP nx9105 I get a message at startup like "failed to allocate mem resource..."

seby (sebit) wrote :

Same error on notebook HP dv6000 (feisty 2.6.20-15-generic)

This is not an issue on notebooks only.
My desktop machine with an Intel 945 PSN motherboard shows the same lines.

ksp@mithrandir:~$ dmesg | grep -B 5 -A 5 Failed
[ 28.291373] hpet0: 3 64-bit timers, 14318180 Hz
[ 28.292386] PCI-GART: No AMD northbridge found.
[ 28.292462] pnp: 00:06: ioport range 0x500-0x53f has been reserved
[ 28.292466] pnp: 00:06: ioport range 0x400-0x47f could not be reserved
[ 28.292469] pnp: 00:06: ioport range 0x680-0x6ff has been reserved
[ 28.292867] PCI: Failed to allocate mem resource #6:20000@50000000 for 0000:01:00.0
[ 28.292913] PCI: Bridge: 0000:00:01.0
[ 28.292915] IO window: disabled.
[ 28.292919] MEM window: 50000000-51ffffff
[ 28.292923] PREFETCH window: 40000000-4fffffff
[ 28.292927] PCI: Bridge: 0000:00:1c.0

It seems that the kernels folks have the problem in their bugzilla:
http://bugzilla.kernel.org/show_bug.cgi?id=7917

Does the Ubuntu kernel wranglers automatically notify the kernel folks or should someone else post to the kernel bugzilla?

Changed in linux:
status: Unknown → Confirmed
emilio (emilio-remogna) wrote :

same problem on toshiba satellite A100 - 750 using Ubuntu 7.04

kernel: [ 0.576917] PCI: Failed to allocate mem resource #6:20000@e0000000 for 0000:01:00.0

no problem with Ubuntu 6.10

Telefo (buonprezzo) wrote :

I have the same error on toshiba satellite m30-801, Ubuntu Feisty, with Kernel 2.6.20-15-386 and generic too, and sistem doesn't boot.

Erazor2 (web-roxxs) wrote :

Same error here on a BenQ Joybook R55 G21.

PCI: Failed to allocate mem resource #6:20000@c0000000 for 0000:01:00.0

nVidia G70 with 512MB VRAM in a Zepto Znote 6214W notebook.

This bug is known since 8 months now - isn't there a way to get rid of that msg? It doesn't seem to affect the system stability or the device so the low importance is ok, but I don't wanna see an error msg every time I boot the system. :(

KillerBob (t1000) wrote :

It seems to be the cause for card reader not working.

drobvice (robertsdonald) wrote :

I have this as well on my Toshiba Satellite M35 with a GeForce Go 5200 video card:

PCI: Failed to allocate mem resource #6:20000@f0000000 for 0000:01:00.0

drobvice (robertsdonald) wrote :

Forgot to mention this is ubuntu 7.04

eso (esoterican) wrote :

Same error on a Toshiba Tecra S4.

guyvdb (guyvdb-gmail) wrote :

same problem here on a fujitsu siemens amilo xi 1526

the only real issue is that it seems to slow down bootup (?)

Jahmon (jahmonspam-forum) wrote :

Same problem here. Using Kubuntu feisty running on 2.6.20-15-generic

HP DV5285ea Geforce GO 7400 but i doubt it's coming from the graphic card....

I have the same problem:
using Feisty Fawn, Nvidia GeForce 7600, HP Pavilion Notebook DV9375eu.
AMD Turion X2 TL-60

thunderfox (john2203) wrote :

Same problem using Feisty Fawn on Acer TravelMate 636LCi, Nvidia Geforece 2 Go

description: updated
description: updated
description: updated
23 comments hidden view all 103 comments

I'm also seeing this with kernel 2.6.22 - so I've added that package to the list of affected kernels.

description: updated

three or more users reporting trouble with this kernel

Changed in linux-source-2.6.22:
status: New → Confirmed
mr_matze (rabbuni) wrote :

I can confirm this "Bug".

I am using an Acer 5652 Notebook with a NVIDIA Geforce Go 7600.

What I don't understand exactly is the dmesg output:
[ 0.186480] Boot video device is 0000:01:00.0
[ 0.188210] PCI: Transparent bridge - 0000:00:1e.0
[ 0.188324] PCI: Bus #07 (-#0a) is hidden behind transparent bridge #06 (-#07) (try 'pci=assign-busses')
[ 0.188330] Please report the result to linux-kernel to fix this permanently

and later

[ 0.292623] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
[ 0.292628] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0

[ 0.326374] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0

the last message is also what appears on the screen while booting.
0000:01:00.0 points to the geforce, according to lspci.

The system boots and works good apart from that message.

I attached the complete dmesg

Robert Pollak (robert-pollak) wrote :

I am using daily-live/20070921.1/gutsy-desktop-i386.iso,
and I see "PCI: Failed to allocate mem resource #6:10000@f0000000 for 0000:01:00.0"
on my Acer TravelMate 630XC,
but the system behaves fine otherwise.

thedrs (thedrs) wrote :

Same error on Toshiba Tecra M2.

 laptop:~$ dmesg | grep allocate
 [ 100.582974] PCI: Failed to allocate mem resource #6:20000@e0000000 for 0000:01:00.0

going deeper you see that -

 laptop:~$ lspci -s 0000:01:00.0 -v
01:00.0 VGA compatible controller: nVidia Corporation NV34M [GeForce FX Go5200 32M/64M] (rev a1) (prog-if 00 [VGA])
        Subsystem: Toshiba America Info Systems Unknown device 0020
        Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 10
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Capabilities: <access denied>

I checked the posted link above to kernel team bug - it deals with something else (PCI bridge problem)

Download full text (3.9 KiB)

Hello,

I also experience this bug. Unlike others it blocks me from loading the rt2x00-driver (which causes the error). I am using kernel 2.6.22.9 for x86-64 (Archlinux, so almost vanilla).

Here is the error-message:

PCI: Unable to reserve mem region #1:8000@febf8000 for device 0000:03:00.0
rt2x00pci -> rt2x00pci_probe: Error - PCI request regions failed.
rt61pci: probe of 0000:03:00.0 failed with error -16

The pci-region which it seems to affect (cat /proc/iomem):
feb00000-febfffff : PCI Bus #03
  febf7400-febf74ff : 0000:03:03.0
    febf7400-febf74ff : r8169
  febf7800-febf7fff : 0000:03:02.0
    febf7800-febf7fff : ohci1394
  febf8000-febfffff : 0000:03:00.0
    febff000-febff7ff : pnp 00:0a

The only thing that takes up the memory-region is pnp, which shouldn't blocks other drivers I suppose? Well, I have to say that the loading of this module worked before (quite some time ago). I also upgraded my bios in the meantime. I updated it to the latest version during the weekend (1.7) and the problem remains. My motherboard is the MSI K9A Platinum. I have a radeon (r300)-graphics-card (pci-express) btw. My only problem with my hardware is that the rt2x00 (pci-card) doesn't load because of this error.

"lspci -vvv"-output of my wlan-pci-card:
03:00.0 Network controller: RaLink RT2600 802.11 MIMO
        Subsystem: Accton Technology Corporation Unknown device ee05
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at febf8000 (32-bit, non-prefetchable) [size=32K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Here is the output of "lspci -b" for the people who are interested:

00:00.0 Host bridge: ATI Technologies Inc RD580 [CrossFire Xpress 3200] Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 13)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Ma...

Read more...

Changed in linux:
status: Confirmed → Fix Released

I notice this has been marked 'fix released' by the kernel team. Which kernel does that refer to? The current Ubuntu Gutsy kernel or something else?

Hello,

I looked at the kernelbug-conversation, about this and it seems that they just removed the message. Seemingly, the don't think that this is causing any problems.

------- Comment #7 From Andrew Morton 2007-08-02 15:40:09 [reply] -------
Greg, could you please consider removing that message, or rephrasing it
in some manner so that it is less alarming?

  ------- Comment #8 From Greg Kroah-Hartman 2007-10-03 16:03:29 [reply] -------
The message is now gone in 2.6.23. Closing this bug.

Well, I'm not so sure about this, but I'll notice it when I use the next kernel-release.

Greetings,

Michel

marine (chrismarine) wrote :

Same here with a Acer 9420, using Gutsy

marine@mustang:~$ dmesg | grep allocate
[ 15.092833] PCI: Failed to allocate mem resource #6:20000@c0000000 for 0000:01:00.0
marine@mustang:~$ lspci -s 0000:01:00.0 -v
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1) (prog-if 00 [VGA])
        Subsystem: Acer Incorporated [ALI] Unknown device 0107
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d1000000 (32-bit, non-prefetchable) [size=16M]
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        Memory at d0000000 (64-bit, non-prefetchable) [size=16M]
        Capabilities: <access denied>

marine@mustang:~$ uname -a
Linux mustang 2.6.22-14-generic #1 SMP Wed Oct 10 05:28:36 GMT 2007 x86_64 GNU/Linux

death4life (pieter557) wrote :

I'm still getting thsin in gutsy gibbon
I have a fujistu amilo pi1556 with an nvidia geforce go 7600.

~$ sudo lspci -s 0000:01:00.0 -v
[sudo] password for pieter:
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce Go 7600] (rev a1) (prog-if 00 [VGA])
        Subsystem: Fujitsu Siemens Computer GmbH Unknown device 10b0
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at b2000000 (32-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at b1000000 (64-bit, non-prefetchable) [size=16M]
        I/O ports at 2000 [size=128]
        Capabilities: [60] Power Management version 2
        Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [78] Express Endpoint IRQ 0

~$ uname -a
Linux pieter-laptop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

I can run X only when I use the vesa driver. When I use the nvidia driver, the screen goes black and i can't do anything but reboot. Booting in to windows vista also gives a black screen, that makes me doubt it's rather a hardware fault.

godwizard (godwizard) wrote :

my dump message:
[ 18.408665] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
[ 18.408735] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
[ 18.408801] PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.0
[ 18.408866] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
[ 18.408932] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
[ 18.408998] PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1
[ 18.409064] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
[ 18.409129] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
[ 18.409195] PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.2
[ 18.470621] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0
[ 27.438141] Cannot allocate resource for EISA slot 1
[ 27.438144] Cannot allocate resource for EISA slot 2
[ 27.438146] Cannot allocate resource for EISA slot 3
[ 27.438148] Cannot allocate resource for EISA slot HELP ME!!!

description: updated

attaching output from dmesg

HW: ACER Aspire 5685WLMi
SW: Linux version 2.6.22-14-generic (Ubuntu 7.10 64bit)

Hello,

I also still have this problem with kernel 2.6.23.1. Please repoen the bug, it is preventing me from using/testing the rt2x00-wireless driver. A little bit oftopic, but please merge the new wireless stack with the main kernel as soon as possible (including hostapd as soon as possible). Compiling the latest rt2x00 seems not very easy as far as I can read from other (may be wrong).
Anyway, here is the dmesg-output:

PCI: Unable to reserve mem region #1:8000@febf8000 for device 0000:03:00.0
rt2x00pci -> rt2x00pci_probe: Error - PCI request regions failed.
rt61pci: probe of 0000:03:00.0 failed with error -16

cat /proc/iomem:

feb00000-febfffff : PCI Bus #03
  febf7400-febf74ff : 0000:03:03.0
    febf7400-febf74ff : r8169
  febf7800-febf7fff : 0000:03:02.0
    febf7800-febf7fff : ohci1394
  febf8000-febfffff : 0000:03:00.0
    febff000-febff7ff : pnp 00:0a

Thank you and greetings,

Michel

Hello again,

just to mention (again) that I'm using 64-bit linux on an AMD-processor (Archlinux). I suppose thatthis bug doesn't have anything to do with http://lkml.org/lkml/2007/3/31/51? I suppose ... not.

Greetings,

Michel

Download full text (4.3 KiB)

Hello,

last mesasge for now. I was looking at /proc/iomem and noticed PCI-bus 3 in two diferent places.I found this strange, but maybe it is normal?

cat /proc/iomem
00000000-0009fbff : System RAM
  00000000-00000000 : Crash kernel
0009fc00-0009ffff : reserved
000c0000-000cffff : pnp 00:10
000e4000-000fffff : reserved
00100000-3ffcffff : System RAM
  00200000-004b17ec : Kernel code
  004b17ed-005b43ef : Kernel data
3ffd0000-3ffddfff : ACPI Tables
3ffde000-3fffffff : ACPI Non-volatile Storage

50000000-500fffff : PCI Bus #03
  50000000-5001ffff : 0000:03:03.0

d8000000-dfffffff : PCI Bus #01
  d8000000-dfffffff : 0000:01:00.0
e0000000-efffffff : pnp 00:0e
f0000000-f08fffff : pnp 00:0f
fe8f4000-fe8f7fff : 0000:00:14.2
  fe8f4000-fe8f7fff : ICH HD audio
fe8fa000-fe8fafff : 0000:00:13.4
  fe8fa000-fe8fafff : ohci_hcd
fe8fb000-fe8fbfff : 0000:00:13.3
  fe8fb000-fe8fbfff : ohci_hcd
fe8fc000-fe8fcfff : 0000:00:13.2
  fe8fc000-fe8fcfff : ohci_hcd
fe8fd000-fe8fdfff : 0000:00:13.1
  fe8fd000-fe8fdfff : ohci_hcd
fe8fe000-fe8fefff : 0000:00:13.0
  fe8fe000-fe8fefff : ohci_hcd
fe8ff000-fe8ff0ff : 0000:00:13.5
  fe8ff000-fe8ff0ff : ehci_hcd
fe8ff800-fe8ffbff : 0000:00:12.0
  fe8ff800-fe8ffbff : ahci
fe900000-fe9fffff : PCI Bus #01
  fe9c0000-fe9dffff : 0000:01:00.0
  fe9e0000-fe9effff : 0000:01:00.1
  fe9f0000-fe9fffff : 0000:01:00.0
fea00000-feafffff : PCI Bus #02
  feac0000-feadffff : 0000:02:00.0
  feaff000-feafffff : 0000:02:00.0
    feaff000-feafffff : r8169

feb00000-febfffff : PCI Bus #03
  febf7400-febf74ff : 0000:03:03.0
    febf7400-febf74ff : r8169
  febf7800-febf7fff : 0000:03:02.0
    febf7800-febf7fff : ohci1394
  febf8000-febfffff : 0000:03:00.0
    febff000-febff7ff : pnp 00:0a

fec00000-fec00fff : IOAPIC 0
  fec00000-fec00fff : pnp 00:09
fed00000-fed003ff : HPET 2
  fed00000-fed003ff : pnp 00:0a
fee00000-fee00fff : Local APIC
ffb80000-ffbfffff : pnp 00:0a
ffeff000-ffeff7ff : pnp 00:0a
fff80000-ffffffff : reserved

lspci -t
-[0000:00]-+-00.0
           +-02.0-[0000:01]--+-00.0
           | \-00.1
           +-06.0-[0000:02]----00.0
           +-12.0
           +-13.0
           +-13.1
           +-13.2
           +-13.3
           +-13.4
           +-13.5
           +-14.0
           +-14.1
           +-14.2
           +-14.3
           +-14.4-[0000:03]--+-00.0
           | +-02.0
           | \-03.0
           +-18.0
           +-18.1
           +-18.2
           \-18.3

lspci -b
00:00.0 Host bridge: ATI Technologies Inc RD580 [CrossFire Xpress 3200] Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controll...

Read more...

Franz (francescogabrielli) wrote :

the same for me:

AcerAspire5601AWLMi

after installing from cd Gutsy 7.10, before with 7.04 no problem.

Hi!

AndrewW (andrew-walters) wrote :

Hi

I have only just started to get this error after upgrading to Gutsy:

PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1

I'm using a HP nc6230 laptop.

I'm receiving the message too, while booting the gutsy alternate install cd, but from the kernel.org bugzilla for this bug:

So I would suggest we close this as "apparently confused BIOS, but Linux
works". ... Greg, could you please consider removing that message, or rephrasing it
in some manner so that it is less alarming? ... The message is now gone in 2.6.23. Closing this bug.

But I'm not sure how to update the status of this bug to reflect this. It's marked as confirmed for two versions of the linux source, but unless someone packports the change into a patch (?), then there wont be a fix on any linux source version before 2.6.23. Maybe mark them as fix released, and the fix is upgrade your kernel to 2.6.23 to remove the message (when it becomes available) or ignore it as a warning...

albech (ubuntu-albech) wrote :

Getting same on VAIO VGN-FE14SP

Alex Zhang (ctrl-space-enter) wrote :

same here,

Dell Latitude 830,
Centrino Core 2 duo,
2.6.22-14-generic
Gutsy 7.10

eoe (eoe) wrote :

Same on SONY VAIO VGN-FZ11E (Gutsy 7.10, kernel 2.6.22-14-generic)

Kent Jonsson (keeej) wrote :

Same here on a Toshiba satellite using Xubuntu.

Kent Jonsson (keeej) wrote :

I forgot to say that the update programs dont funcion.
Other than that it seems to bee working fine.
im using kernel 2.6.20-15

description: updated
charIie (bcp5023) wrote :

I'm running Ubuntu Gutsy (kernel 2.6.22-14-generic)

Acer TravelMate 4670 Laptop

dmesg
[ 20.446481] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
[ 20.446534] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
[ 20.446583] PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.0
[ 20.446632] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
[ 20.446681] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
[ 20.446731] PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1
[ 20.446780] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
[ 20.446829] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
[ 20.446878] PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.2
[ 20.446928] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.3
[ 20.446977] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.3
[ 20.447026] PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.3

lspci
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)

Jonas (peace-dammit) wrote :

Same thing on a HP DV8289EA. After Grub:

Starting up ...
[ 50.372142] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c:0]
[ 50.372213] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c:0]
[ 50.372278] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c:1]
[ 50.372344] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c:1]
[ 50.372409] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c:2]
[ 50.372474] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c:2]
[ 50.372627] PCI: Cannot allocate resource region 0 of device 0000:06:1c:0]
[ 50.436469] PCI: Failed to allocate mem resource #6:20000@d000000 for 0000:0

Jonas (peace-dammit) wrote :

Forgot: I'm running Kubuntu 7.10

LordSavage (lordsavage) wrote :

Starting up ...
[ 31.877190] PCI: Failed to allocate mem resource #6:20000@d0000000 for 0000:01:00.0
[ 31.817162] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
[ 31.817218] PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0

On Acer Aspire 5652WLMi

Changed in linux:
status: Fix Released → Confirmed
jroger (jroger-007) wrote :

Same problem with a notebook Fujitsu-Siemens Amilo Xa 2528 (geforce 8600 gs)

While trying to boot on livecd :

PCI: Failed to allocate mem resource #6:20000#c0000000

Then system hangs

yobser (yobser) wrote :

I've got the same problem.
PCI: failed to allocate mem resource #6:20000@.0000000 for 0000:01:00.0
Notebook Compal. Video adapter nVidia 8600M GT.
I did all checks (dmesg & lspci) and I conclude something is wrong with my video adapter. I tried think that is not graphic card. But I could not start Compiz - after login my session was terminated and system has returned to gdm. During running session I saw some artifacts.
I want to be mistaken. Does anyone have success with Compiz and this error?

I have this error .. but I have no loss of functionality whatsoever. Able to
use compiz to the full extent.

On Dec 29, 2007 1:29 PM, yobser <email address hidden> wrote:

> *** This bug is a duplicate of bug 159241 ***
> https://bugs.launchpad.net/bugs/159241
>
> I've got the same problem.
> PCI: failed to allocate mem resource #6:20000@.0000000 for 0000:01:00.0
> Notebook Compal. Video adapter nVidia 8600M GT.
> I did all checks (dmesg & lspci) and I conclude something is wrong with my
> video adapter. I tried think that is not graphic card. But I could not start
> Compiz - after login my session was terminated and system has returned to
> gdm. During running session I saw some artifacts.
> I want to be mistaken. Does anyone have success with Compiz and this
> error?
>
>

yobser (yobser) wrote :

That is good if no loosing functionality. I afraid error is and problem must be. :-)
It's bad nobody knows how to resolve this problem. I tried to boot from liveCD - I ve got the same message.

Changed in linux:
status: Confirmed → In Progress
VereVa (vereva) on 2008-01-16
description: updated
Stevie (stevie1) wrote :

i have the same error on a fujitsu siemens XA 1526.

after grub i can see:

PCI: failed to allocate mem resource #6:20000@.0000000....
PCI: BIOS BUG #81[00000000] found....

then the usplash starts.
i cant see anything in the logs tho, only after grub booting.

Stevie (stevie1) wrote :

i forgot, im on gutsy

Nicolas Stouff (nico-stouff) wrote :

Same error "cannot allocate ressource in PCI region blah blah"
On Compaq Presario C500 (Intel g945 graphics, hda intel audio sound card)
Not having any trouble, just 5 or 6 lines at each boot.
Not actually a problem, but if it can help...

Ruslan (r-for-ruslan) wrote :

I have same laptop as you Nicolas, however now I don´t see any errors while laptop boots up..I use Gutsy.

a.user (ionescu) wrote :

Have the following message after grub loading (after just installing and rebooting for the first time):

PCI: Failed to....

and than emediatly i get an black screen and othing more happens. not possible to read the whole message. the system halts.

so it does not seem to work.

a.user (ionescu) wrote :

edit to the above post:

i've forgotton that this problem occurse with the 64bit version of ubuntu. with the 32bit version i still get the pci failed... message but after this it works.

Maurizio (mauriziosilverii) wrote :

I have the same problem with version 7.04 and 7.10 of Ubuntu. My laptop is Acer Aspire 1360.

Changed in linux:
status: In Progress → Confirmed
Maurizio (mauriziosilverii) wrote :

The solution is the kernel 2.6.25

Changed in linux:
status: Confirmed → Invalid
Displaying first 40 and last 40 comments. View all 103 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.