cx88-dvb wont load for PCI ID [14f1:8800]

Bug #164257 reported by sojourner on 2007-11-21
14
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Jim Lieb
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

after a recent update my pchdtv no longer works ( it was working about 2 weeks ago , present date 20 november 2007)
I have cx88-dvb added to /etc/modules but it is not being loaded . Sudo modprobe cx88-dvb gives this message

ron@ron-desktop:~$ sudo modprobe cx88-dvb
FATAL: Error inserting cx88_dvb (/lib/modules/2.6.20-16-generic/kernel/drivers/media/video/cx88/cx88-dvb.ko): No such device

examining /lib/modules/2.6.20-16-generic/kernel/drivers/media/video/cx88/ shows that the module is there .

$ ls /lib/modules/2.6.20-16-generic/kernel/drivers/media/video/cx88/
cx8800.ko cx88-alsa.ko cx88-dvb.ko cx88xx.ko
cx8802.ko cx88-blackbird.ko cx88-vp3054-i2c.ko

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux-source-2.6.20.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. What happens if you change to the directory containing the module and try to load it with 'insmod cx88-dvb'? Thanks in advance.

Changed in linux-source-2.6.20:
status: New → Incomplete
sojourner (itsmealso2) wrote :

sorry brian I posted a reply just after your request that I try insmod but it seems not to have saved.here it is again.

root@ron-desktop:/lib/modules/2.6.20-16-generic/kernel/drivers/media/video/cx88# insmod cx88-dvb
insmod: can't read 'cx88-dvb': No such file or directory
root@ron-desktop:/lib/modules/2.6.20-16-generic/kernel/drivers/media/video/cx88#
 ls
cx8800.ko cx88-alsa.ko cx88-dvb.ko cx88xx.ko
cx8802.ko cx88-blackbird.ko cx88-vp3054-i2c.ko
root@ron-desktop:/lib/modules/2.6.20-16-generic/kernel/drivers/media/video/cx88#

properties for the module show the mod is object code with a size of 31.7 KB and a modification date of 23 september 2007 . the module date is the same as the date for the 2.6.20.16 - gemeric kernal

sojourner (itsmealso2) wrote :

after some updates came down today( december 13 ,2007 ) cx88-dvb began loading at startup and works normal now . I will wait a couple of days and if all continues to work I will close this bug.

sojourner (itsmealso2) wrote :

ok its been a week and cx88-dvb is still playing nice so mark this one closed. I tried to mark it closed but that choice dosent appear for me.

Brian Murray (brian-murray) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the drop down box. You can learn more about bug statuses at http://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux-source-2.6.20:
status: Incomplete → Fix Released
lnx (nwegener) wrote :

My 7.10 is completely updated, but I still get this error today.

Brian Murray (brian-murray) wrote :

What happens when you try to manually load the driver as mentioned in comments 2 and 3?

hammer (harth) wrote :

Hi I'm using Gutsy (amd64) with MSI TV@nywhere Satellite card. In short, it's not working:

1. the autodetect during boot is yielding
 cx88[0]: Your board isn't known (yet) to the driver. You can
 cx88[0]: try to pick one of the existing card configs via
 cx88[0]: card=<n> insmod option. Updating to the latest
 cx88[0]: version might help as well.

2. After manually specifying card=13
(contents of /etc/modprobe.d/options:
options cx88xx card=13
options tda9887 qss=0)

dmesg gives:
[ 819.717910] cx2388x cx88-mpeg Driver Manager version 0.0.6 loaded
[ 819.718530] CORE cx88[0]: subsystem: 1822:0023, board: MSI TV-@nywhere Master [card=7,insmod option]
[ 819.718537] TV tuner 33 at 0x1fe, Radio tuner -1 at 0x1fe
[ 819.800456] input: cx88 IR (MSI TV-@nywhere Master as /class/input/input6
[ 819.800681] cx88[0]/2: cx2388x 8802 Driver Manager
[ 819.803697] cx2388x dvb driver version 0.0.6 loaded
[ 819.803702] cx8802_register_driver() ->registering driver type=dvb access=shared

3. sudo scan ./channels.conf
gives
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
main:2247: FATAL: failed to open '/dev/dvb/adapter0/frontend0': 2 No such file or directory

4. With Mythtv the scans give also not results

5. After googling and inspecting my system ...
 sudo modprobe cx88-dvb
gives
FATAL: Error inserting cx88_dvb (/lib/modules/2.6.22-14-generic/kernel/drivers/media/video/cx88/cx88-dvb.ko): No such device
(even executing this in /lib/modules/2.6.22-14-generic/kernel/drivers/media/video/cx88)
but
 ls /lib/modules/2.6.22-14-generic/kernel/drivers/media/video/cx88
cx8800.ko cx8802.ko cx88-alsa.ko cx88-blackbird.ko cx88-dvb.ko cx88-vp3054-i2c.ko cx88xx.ko

So I think the problem still exists ...

Any further ideas?

Many thanks in advance.

P. S.
:/var/log$ uname -a
Linux ffbhome 2.6.22-14-generic #1 SMP Tue Dec 18 05:28:27 UTC 2007 x86_64 GNU/Linux

hammer (harth) wrote :

Hi,

sorry, I think I have put this into the wrong branch, since it is related to Gutsy 7.10 (kernel 2.6.22).
I will post it there.

Sorry again for the confusion.

Cheers.

sojourner (itsmealso2) wrote :

this bug occurs with several kernals , I requested it be closed because it began working in my fiesty install which is the one where my tv card is .but I still get the error in gutsy and hardy , go ahead and request that they reopen it .

sojourner (itsmealso2) wrote :

I'm going to request this be reopened as it un fixed itself after updatdes to fiesty either 10 or 11 january 2008

hammer (harth) wrote :

Hi,

just for your information ... I also have submitted this bug here:

https://bugs.launchpad.net/bugs/181759

Brian Murray (brian-murray) wrote :

I'm sorry I missed this earlier, but the "No such device" message indicates that you don't have a card supported by the cx88 driver. What is the PCI ID of your pchdtv capture card? The full output of 'sudo lspci -vvnn' is a good way to obtain this. Thanks in advance.

Changed in linux-source-2.6.20:
status: Fix Released → Incomplete
hammer (harth) wrote :
Download full text (17.6 KiB)

Hi,

here is the output you asked for:

#############################################################################
lspci -vvnn

00:00.0 Host bridge [0600]: ATI Technologies Inc RS690 Host Bridge [1002:7910]
        Subsystem: ASUSTeK Computer Inc. Unknown device [1043:826d]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 64

00:01.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx) [1002:7912] (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 99
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=68
        I/O behind bridge: 0000d000-0000dfff
        Memory behind bridge: fdb00000-fdcfffff
        Prefetchable memory behind bridge: 00000000f0000000-00000000f7ffffff
        Secondary status: 66MHz+ FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
        Capabilities: [44] HyperTransport: MSI Mapping
        Capabilities: [b0] Subsystem: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx) [1002:7912]

00:07.0 PCI bridge [0604]: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3) [1002:7917] (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 32 bytes
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        I/O behind bridge: 0000e000-0000efff
        Memory behind bridge: fdf00000-fdffffff
        Prefetchable memory behind bridge: 00000000fdd00000-00000000fddfffff
        Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
        Capabilities: [50] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] Express Root Port (Slot-) IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s <64ns, L1 <1us
                Device: Errors: Correctable+ Non-Fatal+ Fatal+ Unsupported+
                Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s L1, Port 4
                Link: Latency L0s <64ns, L1 <1us
                Link: ASPM Disabled RCB 64 bytes CommClk- ExtSynch-
                Link: Speed 2.5Gb/s, Width x1
                Root: Correctable- Non-Fatal- Fatal- PME-
        Capabilities: [80] Message Signalled Interrupts: Mask...

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Confirmed

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

hammer (harth) wrote :

Sorry for the delay!

Right now, I have switched to Ubuntu 8.10:
uname -a
Linux xxxx 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux

Unfortunately, I'm still facing the same problem, that the cx88-dvb module cannot be loaded:

modprobe cx88-dvb
FATAL: Error inserting cx88_dvb (/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/cx88/cx88-dvb.ko): No such device

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Changed in linux:
importance: Undecided → Medium
status: Incomplete → Triaged
Jim Lieb (lieb) on 2009-01-12
Changed in linux:
assignee: nobody → lieb
status: Triaged → In Progress
Jim Lieb (lieb) wrote :

This bug is consolidated with bug #181257 because the reporters of this bug have upgraded to Intrepid where that bug has been reported. Please track any status and test kernels through that bug. We have determined that both cards reported here are internally identical.

Changed in linux:
status: In Progress → Won't Fix
Jim Lieb (lieb) wrote :

Sorry, that is bug #181759, typos being what they are. I cut and pasted this time...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers