Cannot install and mount ZIP IOMEGA PARALLEL PORT

Bug #146262 reported by ralph on 2007-09-28
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Low
Unassigned

Bug Description

I have just installed 7.04
I cannot detect my iomega zip 100 on my parallel port.
Result of fsk -l is

Disk /dev/hda: 20.0 GB, 20003880960 bytes
255 heads, 63 sectors/track, 2432 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot Start End Blocks Id System
/dev/hda2 1 2432 19535008+ 5 Extended
/dev/hda5 105 591 3911796 83 Linux
/dev/hda6 592 1199 4883728+ 83 Linux
/dev/hda7 1200 1564 2931831 83 Linux
/dev/hda8 1565 1600 289138+ 83 Linux
/dev/hda9 1601 2432 6683008+ 83 Linux
/dev/hda10 1 104 835285+ 82 Linux swap / Solaris

There are no relevant messages in dmesg

result of cat /etc/fstab is

# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda5
UUID=fd9457d1-11cf-49f5-9d2c-50539f12d4dc / ext3 defaults,errors=remount-ro 0 1
# /dev/hda9
UUID=942b0f1a-83e0-47dd-b8b7-ab1e16482752 /home ext3 defaults 0 2
# /dev/hda8
UUID=c8bf50b9-7551-40a8-8a8d-a84e2534c4f4 /tmp ext3 defaults 0 2
# /dev/hda6
UUID=06bdd6a7-e80f-4fbf-88d0-9607779357f7 /usr ext3 defaults 0 2
# /dev/hda7
UUID=b75c6c97-e4a4-4440-9099-32f01843a507 /var ext3 defaults 0 2
# /dev/hda10
UUID=c0882f63-0270-411d-b871-f74d806bc68b none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0

I have tried modprobe ppa etc and putting ide_floppy in modules all to no avail

I started the machine with a disk in the zip.

Basically there are no SCSI as far as I can see in /dev

Any help would be gratefully received.

Thanks

Please note that I have followed the procedure as per the community installation document and this
maybe works for 6.03 but not for 7.04.

There is no node in /dev that corresponds to sda4.

I have tried sda but this doesn't work either.
for

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description doesn't yet have enough information.
Please include as attachments the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

Changed in hal:
status: New → Incomplete

I just connected my parallel Zip 250 to Ubuntu 8.04, and it refused to acknowledge the existence of the drive until I added "imm" to /etc/modules, and now it works great, but only for the first disk I insert, because trying to eject using Nautilus only unmounts and says "Cannot eject volume" after which the "eject" command in Terminal successfully ejects, but hangs in a D+ state and leaves the drive completely unresponsive until a reboot.

Brian Murray (brian-murray) wrote :

Daniel it would be helpful if you were to provide the information I asked for in my previous comment. Thanks in advance.

I do not believe this to be a kernel issue, but here goes:
Linux tbb 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Low
status: Incomplete → Confirmed

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Bryan Wu (cooloney) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - http://www.ubuntu.com/getubuntu/download. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

-Bryan

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions