update to Linux-image 2.6.20-16 broke sound with realtek alc850

Bug #145393 reported by kmarshall on 2007-09-26
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
linux-source-2.6.20 (Ubuntu)
Ubuntu Audio Team

Bug Description

Binary package hint: linux-image-2.6.20-16-generic

Updated via Adebt updater several packages including the linux-image-2.6.20-16-generic. This package is now at 2.6.20-16.32 ... what this last sub-number was prior to the update I do not know. However, after the update my sound no longer worked. I also have an older kernel 2.6.20-15.27 installed. If I boot with this kernel the sound works. I have booted with both kernels more than once and the result is always the same. It works in the older one and does not work in this newest update.

The sound system is Realtek ALC850 rev 0 on Asus A8N-SLI Delux MOB

Only a minor annoyance, but still worth reporting.

I am currently booted into the version in which the sound works. If you need more information from the broken configuration I will need to go back. Let me know and I will.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output requested in the Reporting Sound Bugs section of https://help.ubuntu.com/community/DebuggingSoundProblems as separate attachments? Thanks in advance.

Changed in linux-source-2.6.20:
status: New → Incomplete
Brian Murray (brian-murray) wrote :

Could you please also provide the full output of 'modinfo snd_intel8x0'? Thanks again.

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-audio
importance: Undecided → High
status: Incomplete → Triaged

Hi kmarshall,

This bug was reported a while ago and there hasn't been any recent activity. The Hardy Heron Alpha series is currently under development and contains an updated version of the kernel. It would be helpful if you could test the latest Hardy Alpha release: http://www.ubuntu.com/testing . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. However, please note that Hardy contains ALSA version 1.0.16 which mutes some sound levels by default so when testing make sure all levels are unmuted and turned up. Thanks.

Changed in linux-source-2.6.20:
status: Triaged → Incomplete
Solitary Man (pharynx) wrote :

i have the same problem that after some updates there is no sound (i have kubuntu 8.04 [64bit] installed). before the sound had worked perfect...
i have a realtek alc660-vd soundcard.

Sam_ (and-sam) wrote :

just for the record, no problems here and using

cat /proc/asound/cards
0 [CK804]: NFORCE - NVidia CK804
NVidia CK804 with ALC850 at irq 20

uname: Linux 2.6.24-19-generic x86_64 GNU/Linux
Distributor ID: Ubuntu
Description: Ubuntu 8.04.1
Release: 8.04
Codename: hardy

Had no sound after upgrading from Gutsy to Hardy and switched in gnome-volume-manager and audio settings from
NVidia CK804 (Alsa mixer) to Realtek ALC850 rev 0 (OSS Mixer).

Nick Ellery (nick.ellery) wrote :

It unfortunately appears that this bug is not yet resolved. Does this issue still exist in the Hardy Heron 8.04 LTS release? If so, the Intrepid Ibex 8.10 Alpha2 is also scheduled for release today. It will appear at the following when available: http://www.ubuntu.com/testing/intrepid/alpha2 . It contains the actively developed 2.6.26 Ubuntu kernel. It would be great if you could test this upcoming release via a LiveCD and verify if the issue still exists. If so, please include the appropriate debugging information as outlined at https://wiki.ubuntu.com/DebuggingSoundProblems . Thanks in advance.

As Nick mentioned, for those still having issues, please test with the latest Alpha for the upcoming Intrepid Ibex 8.10 - http://www.ubuntu.com/testing . We'll keep this report open against the actively developed kernel bug against 2.6.20 this will be close as it does not qualify for a Stable Release Update - http://wiki.ubuntu.com/StableReleaseUpdates . Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.20:
status: Incomplete → Won't Fix

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.


2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Michele Mangili (mangilimic) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers