webcams not working in 2.6.20-16 but they do with 2.6.20-15 (also module "v4l2-int-device" apears in restricted module)

Bug #131648 reported by hugolp on 2007-08-10
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

Hi

I am having problems with kernel 2.6.20-16-generic. Two diferent model webcams with diferent drivers dont work. But they do with kernel 2.6.20-15.

With the first webcam I though the drivers where not good (ov51x-jpeg) but when another webcam didnt work neither with diferent drivers (pwc) didnt worked neither in 2.6.20-16-generic but both did in 2.6.20-15-generic, I guessed its an Ubuntu problem.

Also, I get this extrange module in restricted controlers in -16 that I dont get in -15. Its named "v4l2-int-device". It sais its never in use even If I mark it for being used. As is a video for linux 2 isue it might be related to the webcam problems.

I am not the only one having problems with video devices and that gets the "v4l2-int-device" in the restricted modules menu. Check here: http://ubuntuforums.org/showthread.php?t=512734&highlight=v4l2-int-device

Hugo

Revision history for this message
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducable with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the actively developed kernel. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in linux-source-2.6.20:
importance: Undecided → Medium
Revision history for this message
hugolp (hugolp2) wrote :

I just move house and I am on a grps internet conection (mobile phone) and its very slow. I wont get a proper conection in the house in one or two weeks. Then Ill try to download the gutsy image and install to test.

Hugo

Revision history for this message
hugolp (hugolp2) wrote :

I installed Ubuntu Gutsy RC and this isue is still happening. I get the v4l2-int-device in restricted modules. Same behavier as in feisty. The curious thing is that this didnt appear in a Gutsy clean install. They appeared after compiling the lastest v4l-dvb trunk. I need to do that in order to get my two tv dvb-t cards working. I havent tried to install the webcam drivers yet. When I do Ill post again.

Revision history for this message
feld (felderado) wrote :

2.6.22-14 ov51x-jpeg doesn't work right -- i get a strange green image using my Eyetoy.
2.6.22-13 it worked fine.

Ubuntu Gutsy, amd64

Revision history for this message
Ralph Janke (txwikinger) wrote :

Could you please test if this problem also occurs with the newest hardy release.

Thanks

Changed in linux-source-2.6.20:
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote : This bug is now reported against the 'linux' package

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
Andres Mujica (andres.mujica) wrote :

I'm marking this as invalid because we lack the information needed for properly debug this issue. Please if you feel this need to be reopened, please be sure to check before with Intrepid latest updated.

Thanks for your report.

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers