No sound after install - C-Media 8738

Bug #128149 reported by andy_blah on 2007-07-25
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Sunny Shin

Bug Description

I have recently ran in a issue with Ubuntu 7.04 with my soundcard, witch is a C-Media 8738. I never had this issue, before in the older versions of Ubuntu. At first when I`m on live CD the soundcard works and after I boot and use the freshly installed Ubuntu, it does not work. I have tried to use this guide, since I previously had some issues on one install and helped me: http://ubuntuforums.org/showthread.php?t=205449. I get to the step with the driver compiling because the other methods in the guide are not working. The compiling fails with a few errors and after that when I reboot the sound volume control shows a "denied" sign and when I click on it it shows a message: "No volume control GStreamer plugins and/or devices found."
Also I have tried to change the options in System>Preferences>Sound but it did not work, only one time and the sound was really loud and after a few seconds it didn`t work again.

andy_blah (andreipunbaa) on 2007-07-25
description: updated
Sunny Shin (shin-seu) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Ubuntu developers need more information regarding your hardware configuration. Hence, could you please add the output requested in the Reporting Sound Bugs section of https://help.ubuntu.com/community/DebuggingSoundProblems as separate attachments? I highly appreciate your help.

andy_blah (andreipunbaa) wrote :

I hope this matches your requests. And sorry for the big file, I didn`t have time to split it, I separated commands by a line of dashes

Sunny Shin (shin-seu) wrote :

Thank you for your additional information. Here, you attempted to load the snd-es18xx, but it is incorrect. Please, try to load the snd-cmipci driver.

andy_blah (andreipunbaa) wrote :

I don`t understand that, I really selected cmipci!
Also Ubuntu dosen`t detect my soundcard :S

andy_blah (andreipunbaa) wrote :

EDIT: I don`t understand that, I really selected cmipci!
Also Ubuntu dosen`t detect my soundcard as before.

Sunny Shin (shin-seu) wrote :

Thank you for your answer.

The file which you attached includes the following command.
andyblah@UBUNTUANDY:~$ sudo modprobe snd_es18xx isapnp=0 port=0x220 mpu_port=0x330 dma1=1 dma2=5 irq=5 fm_port=0x388
This means that you tried to load snd_es18xx, but you have cmipci sound card. This is incorrect.
Please, try to load the snd-cmipci driver.

The following is a document for your soundcard and it would be helpful.
http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=C-Media&card=.&chip=CMI8338%2C+CMI8738%2C+CMI8768&module=cmipci

andy_blah (andreipunbaa) wrote :

Ethier way it still gives me the same error message.
And I followed the link you gave me, and tried to do it step by step but I got stopped with a error at a simple step of creating a directory (mkdir alsa). I have posted the second text file with the results.

Sunny Shin (shin-seu) wrote :

I appreciate your previous attempt. And I am sorry, but I detected couple of your mistakes.
andyblah@UBUNTUANDY:~$ sudo modprobe snd_cmipci isapnp=0 port=0x220 mpu_port=0x330 dma1=1 dma2=5 irq=5 fm_port=0x388
Here, snd_cmipci should have been fixed as snd-cmipci (If this doesn't work, then try $ sudo modprobe snd-card-cmipci )

Second, when you use mkdir at the /usr/src, you have to use 'sudo'.
Thus, the command should be
$ sudo mkdir alsa

Thank you for your time.

andy_blah (andreipunbaa) wrote :

I`m sorry that I`m disturbing you again, but still I haven`t solved anything after making the directory alsa, now they tell me to use the cp command, but the path they suggest is invalid here, if you could explain me what I should put instead of that path?
Also I have tried to fix what you suggested me with the modprobe, but till it gives me the same same same mistake!

No, thank you for your time!

Sunny Shin (shin-seu) wrote :

I highly appreciate your help.
I saw the file which you attached and I'm sorry, but I still don't think that this is a bug.

One odd thing is, when you use modprobe, you receive the bunch of following messages.
WARNING: Could not open '/lib/modules/2.6.20-15-generic/kernel/sound/core/snd.ko': No such file or directory

So, I guess that your system could have some problem.
Check your filesystem having the following directories, such as /lib/modules/2.6.20-15-generic/kernel/sound/core/.

One recommendation is to update to the latest version of the kernel is the safest as the package installation may clean things up for you.
Thank you.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

SEWilco (scot-wilcoxon) wrote :

I upgraded to Intrepid Ibex prerelease and have no sound with my CM8738. Maybe this bug is still present.

`lspci -v` does mention:
00:0c.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
 Subsystem: C-Media Electronics Inc CM8738
 Flags: bus master, medium devsel, latency 32, IRQ 5
 I/O ports at d400 [size=256]
 Capabilities: <access denied>

$ aplay -l
aplay: device_list:215: no soundcards found...

Apparently the ALSA module for CM8738 is snd-cmipci but I'm not seeing any snd-cmipci files in my system.

When running Intrepid, can you run the alsa-info.sh script - http://alsa-project.org/alsa-info.sh - and attach the resulting alsa-info.txt file:

./alsa-info.sh --no-upload

Thanks.

Victor Vargas (kamus) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers