Dell E530 - No Audio

Bug #120097 reported by Roger Noriega on 2007-06-12
10
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.22 (Ubuntu)
High
Unassigned
linux-source-2.6.20 (Ubuntu)
High
Unassigned

Bug Description

Audio fails to play with Feisty Gold on Dell E530. The command "aplay test.wav" displays Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo but sound is not audiable. It appears that the kernel does not have support for ALC888. I checked alsamixer nothing is muted.

Card: HDA Intel
Chip: Realtek ALC888
lspci -n output
00:1b.0 0403: 8086:293e (rev 02)

Ben Collins (ben-collins) wrote :

Can you attach "cat /proc/asound/card0/codec#0 > codec.txt" please.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → ben-collins
status: Confirmed → Needs Info
Roger Noriega (rnoriega) wrote :

Attached output of cat /proc/asound/card0/codec#2

Ben Collins (ben-collins) wrote :

Can we also get the lspci -vvn of this machine? We have the one for Lanai.

Thanks

Roger Noriega (rnoriega) wrote :

Attached output of lspci -vvn

Ben Collins (ben-collins) wrote :

Tim is taking on this bug.

Changed in linux-source-2.6.20:
assignee: ben-collins → timg-tpi
Ben Collins (ben-collins) wrote :

Tim, the lspci is here. Please send the right parts of this bug (lspci for just the audio and codec file) to crimsun.

Thanks

Changed in linux-source-2.6.20:
status: Needs Info → In Progress
Ben Collins (ben-collins) wrote :

Here's a table of model types for that system:

        [ALC883_3ST_2ch_DIG] = "3stack-dig",
        [ALC883_3ST_6ch_DIG] = "3stack-6ch-dig",
        [ALC883_3ST_6ch] = "3stack-6ch",
        [ALC883_6ST_DIG] = "6stack-dig",
        [ALC883_TARGA_DIG] = "targa-dig",
        [ALC883_TARGA_2ch_DIG] = "targa-2ch-dig",
        [ALC883_ACER] = "acer",
        [ALC883_MEDION] = "medion",
        [ALC883_MEDION_MD2] = "medion-md2",
        [ALC883_LAPTOP_EAPD] = "laptop-eapd",
        [ALC883_LENOVO_101E_2ch] = "lenovo-101e",
        [ALC883_LENOVO_NB0763] = "lenovo-nb0763",
        [ALC888_LENOVO_MS7195_DIG] = "lenovo-ms7195-dig",

You can try some of these, and pretty quickly, like this:

Login via console (Ctrl+Alt+F1):

sudo /etc/init.d/gdm stop # Gets gnome out of the way

sudo modprobe -r snd-hda-intel
sudo modprobe snd-hda-intel model=foo
aplay /usr/share/sounds/generic.wav

If it doesn't work, run through the previous three commands trying each
model till it does work.

Ben Collins (ben-collins) wrote :

Any testing on this one?

Roger Noriega (rnoriega) wrote :

Audio out is working in the -16 kernel, loading the models did not help with the record.

Michael Morgan (mikmorg) wrote :

Sepang audio works using Realtek's latest drivers, including record.
We would prefer a backport, and are looking to find the module which we
need to investigate by process of elimination.

Changed in redfish:
assignee: nobody → mikmorg
importance: Undecided → High
status: New → In Progress
Henrik Nilsen Omma (henrik) wrote :

Subscribing distro-qa.

Roger, Michael: Please subscribe 'distro-qa' to the hardware bugs you file so we can track their progress. This is our internal QA team (Canonical employees only). Make sure not to subscribe 'ubuntu-qa' which is an open community team. Thanks.

Roger Noriega (rnoriega) wrote :

Done Subscribing distro-qa.

Michael Morgan (mikmorg) wrote :

ALSA 1.0.14 works natively, and so does Realtek's ALSA. RT's ALSA is very close to 1.0.14, if not functionally the same (from what I've gathered).

Realtek's version can be downloaded here: ftp://202.65.194.212/pc/audio/realtek-linux-audiopack-4.06a.tar.bz2

ALSA 1.0.14 can be downloaded here:
ftp://ftp.silug.org/pub/alsa/lib/alsa-lib-1.0.14.tar.bz2
ftp://ftp.silug.org/pub/alsa/driver/alsa-driver-1.0.14.tar.bz2
ftp://ftp.silug.org/pub/alsa/utils/alsa-utils-1.0.14.tar.bz2

Note that the './install' file in Realtek can be used as a legible guide as to installing 1.0.14 just like RT does.

Michael Morgan (mikmorg) wrote :

Unfortunately, it seems that we may have to install 1.0.14 to get everything to work. Realtek's modifications are negligent, and 1.0.14 definitely works when installed properly. The other catch is the requirement of the model=3stack option for snd-hda-intel.

The reason I say we may have to install 1.0.14, is that the fix is in alsa-utils. alsa-utils depends on alsa-lib. alsa-lib depends on alsa-driver. When one changes the base API of the alsa-driver package to 1.0.14, the codecs and chip drivers also must be changed - symbols DO change!!! When you change those drivers, the alsa-lib driver has to be upgraded (same problem), and so forth for the alsa-utils.

Please prove me wrong!

Tim Gardner (timg-tpi) wrote :

I reinstalled Feisty on my Sepang using the alternate install CD (the Live CD wont boot). I then applied the linux-backports-modules-2.6.20-15-generic_2.6.20-15.11_i386.deb package (to get E1000 ICH9 support) and rebooted. Then I ran the Synaptics upgrade, but rebooted into 2.6.20-15. With no changes it appears to me that Sepang audio works out of the box. I was able to record (from the front mic) with variable volume, etc. 2.6.20-16 also works as expected.

This is weird.

Agreed. Could you send me an alsactl --version, and aplay --version?

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Tim Gardner
Sent: Friday, June 29, 2007 2:07 PM
To: Morgan, Mike
Subject: [Bug 120097] Re: Dell E530 (Sepang) No Audio

I reinstalled Feisty on my Sepang using the alternate install CD (the
Live CD wont boot). I then applied the linux-backports-
modules-2.6.20-15-generic_2.6.20-15.11_i386.deb package (to get E1000
ICH9 support) and rebooted. Then I ran the Synaptics upgrade, but
rebooted into 2.6.20-15. With no changes it appears to me that Sepang
audio works out of the box. I was able to record (from the front mic)
with variable volume, etc. 2.6.20-16 also works as expected.

This is weird.

--
Dell E530 (Sepang) No Audio
https://bugs.launchpad.net/bugs/120097
You received this bug notification because you are a member of The
Redfish Team, which is a direct subscriber.

More weirdness - I reinstalled Feisty GOLD from scratch (after Beta unit cooled enough to boot). Audio (from rear speakers) works, and front mic works (speaking into the front mic produces sound out of the rear speakers). The Gnome record application thinks it is recording, but aplay produces no sound from the recorded file. I also installed the Gnome mixer so that I was sure record sources were un-muted, etc.

alsactl version 1.0.13
aplay: version 1.0.13

Updating to current Feisty (2.6.20-16) did not have any effect.

Tim Gardner (timg-tpi) wrote :

The sound solution appears to be Alsa 1.0.14 driver, library, and utils. This feels like the right thing to do since Gutsy will also have these bits.

Tim Gardner (timg-tpi) wrote :

This further clarifies audio recording symptoms: The back MIC functions, however the is no volume control. The front MIC does not seem to function at all.

Tim Gardner (timg-tpi) wrote :

Another sound update using the Sepang recovery ISO 121, Applications/Sound & Video/Sound Recorder, and Applications/Sound & Video/GNOME ALSA Mixer:

Setup:
In GNOME ALSA Mixer uncheck the rightmost 'Rec.' checkbox (underneath the rightmost Capture slider bar), check the leftmost 'Rec.' checkbox, and check Mute on both microphones. Crank all of the slider bars to the top.
In Sound Recorder select 'Record from input: Capture', then 'Record as: WAV audio'.
Insert your microphone, select Record, and make some noise.

I was able to control record volume on the back microphone. However, the front microphone (while functional) seems to always be at maximum volume. Confusingly, even though the mixer shows 2 Capture sources, both microphones are enabled from the leftmost Capture slider bar 'Rec' checkbox. The rightmost Capture appears to have no effect.

Rez or Michael - Can you reproduce these results?

Michael Morgan (mikmorg) on 2007-08-12
Changed in redfish:
assignee: mikmorg → nobody
Tim Gardner (timg-tpi) wrote :

Record quirks have been release noted on Dell web site.

Changed in linux-source-2.6.20:
assignee: timg-tpi → nobody
status: In Progress → Fix Released
Changed in redfish:
status: In Progress → Fix Released
Tim Gardner (timg-tpi) wrote :

The E530 requires linux-backports-modules-2.6.22 in order to record audio.

Changed in linux-backports-modules-2.6.22:
importance: Undecided → High
milestone: none → ubuntu-7.10-rc
status: New → Fix Released
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306042

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers