Ubuntu

Dell Inspiron 1420 -- No audio

Reported by Roger Noriega on 2007-06-11
48
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
High
Unassigned

Bug Description

Audio fails to play with Feisty Gold on Dell Inspiron 1420. The command "aplay test.wav" displays Playing WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo but sound is not audiable. It appears that the kernel does not have support for STAC9228.

Card: HDA Intel
Chip: Sigmatel STAC9228

lspci -n output
00:1b.0 0403: 8086:284b (rev 02)

Ben Collins (ben-collins) wrote :

Can you attach "cat /proc/asound/card0/codec#0 > codec.txt" please.

Actually, I can get this from my system I suspect. I'll keep it to needsinfo for whoever gets it first :)

Changed in linux-source-2.6.20:
status: Confirmed → Needs Info
Roger Noriega (rnoriega) wrote :

Attached cat /proc/asound/card0/codec#0

Tim Gardner (timg-tpi) wrote :
Ben Collins (ben-collins) wrote :

Tim is taking on this bug.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → timg-tpi
status: Needs Info → In Progress
rez (rezwanul-kabir) wrote :

Pls refer to bug#121056 opened to address this issue.

Tim Gardner (timg-tpi) wrote :

Please try this test kernel: http://people.ubuntu.com/~rtg/linux-image-2.6.20-16-generic_2.6.20-16.30_i386.deb-redfish-119898.1

It has the sigmatel patch from http://launchpadlibrarian.net/8131817/patch_sigmatel.patch as well as CONFIG_SND_VERBOSE_PRINTK enabled.

wget http://people.ubuntu.com/~rtg/linux-image-2.6.20-16-generic_2.6.20-16.30_i386.deb-redfish-119898.1 linux-image-2.6.20-16-generic_2.6.20-16.30_i386.deb
sudo dpkg -i linux-image-2.6.20-16-generic_2.6.20-16.30_i386.deb
sudo reboot

Tim Gardner (timg-tpi) wrote :

I encountered this debug output when running the sound test from System/Preferences/Sound:

Jun 19 10:38:26 lanai kernel: [ 19.488000] ALSA sound/pci/hda/hda_intel.c:556: hda_intel: azx_get_response timeout, switching to polling mode...

I also tried 'nomsi' as a kernel boot parameter with no audible difference.

rez (rezwanul-kabir) wrote :

Headphone continues to work with the test kernel posted above by Tim. However, internal speakers still don't work.

Ben Collins (ben-collins) wrote :

Sweet, I've got working sound on Lanai. You guys should be able to whip
this into a quick workaround for the FI by creating a
file /etc/modprobe.d/lanai-sound with this in it:

options snd-hda-intel model=3stack

I tried both 3stack and 5stack. Both worked, so you may want to test
with both and make sure that it picks up the right inputs and outputs
(jacks, microphone, headphone, etc..).

Sweet.

Mike- Please should have feedback for you on how this worked on both Lanad Sepang's in-house.

Thanks Ben!!

Confirming the workaround for Lanai.

Tim Gardner (timg-tpi) wrote :

Not a kernel bug.

Changed in linux-source-2.6.20:
assignee: timg-tpi → ubuntu-kernel-team
status: In Progress → Rejected
Henrik Nilsen Omma (henrik) wrote :

Un-subscribing distro-qa as the general Ubuntu issue is resolved.

Ben Collins (ben-collins) wrote :

It is a kernel bug. We need this workaround added to the auto-detect table in the driver.

Changed in linux-source-2.6.20:
status: Invalid → In Progress
Tim Gardner (timg-tpi) wrote :

Developing the quirk fix in the kernel.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → timg-tpi
Tim Gardner (timg-tpi) wrote :

Added quirk support for PCI_VENDOR_ID_DELL/0x01f3.

Changed in linux-source-2.6.20:
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) wrote :

I'm waiting to hear if the 5stack modprobe option allows recording before sending this patch upstream to the ALSA project.

rez (rezwanul-kabir) wrote :

Both 5stack and 3stack options allowed audio recording..So we are fine.

Michael Morgan (mikmorg) on 2007-06-25
Changed in redfish:
importance: Undecided → High
status: New → Fix Committed
Tim Gardner (timg-tpi) wrote :

Feisty commit dc24b94b0d384a70b400d56f97060351f800c3df added quirk support for PCI_VENDOR_ID_DELL/0x01f3. Dell DKMS also adds 3stack option to modprobe.d.

Changed in linux-source-2.6.20:
assignee: timg-tpi → nobody
status: Fix Committed → Fix Released
Changed in redfish:
status: Fix Committed → Fix Released

Audio still broken with Gutsy Tribe-4 on Inspiron 1420n.

Adding XPS1330 that has the same Sigmatel 9228 codec to this bug for the sake of tracking as audio is not working on that system as well even with Tribe-5.

Alsamixer displays "Generic 1095 ID 1392" under "Chip:"

Tim Gardner (timg-tpi) wrote :

Gutsy l-u-m commit c35aec38786a8beb41d8ac5562d24ad56c0f2aad

If this doesn't fix the XPS 1330 sound issue, then start a new bug since its not the same problem.

Tim:

Just updated all packages on a 1420 and I can confirm that sound works. However, I don't hear any sound when I login/logout, even though these feature are enabled (be default) in System -> Preferences -> Sound, in the Sounds tab. Is this as designed, or is the full fix to be released in Tribe-6?

Brian Murray (brian-murray) wrote :

Jose:

Not hearing the login sound is bug 129029 which has been milestoned for the Beta release of Gutsy.

Sound issue is fixed on XPS 1330 with latest Gutsy updates.

Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305715

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers