Ubuntu

DVB Nova-T video skips with "cx88_wakeup: 2 buffers handled (should be 1)"

Reported by Hanno on 2007-06-07
14
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-image-2.6.20-15-generic

[I have reported this problem upstream to the linux-dvb mailing list.

http://www.linuxtv.org/pipermail/linux-dvb/2007-May/018232.html

Alas, not a single response there. So this may be specific to the Ubuntu kernel.]

Hi,

using a Nova-T dvb card, I get the following in /var/log/messages...

22:09:54 kernel: cx88_wakeup: 2 buffers handled (should be 1)
22:09:57 kernel: cx88_wakeup: 2 buffers handled (should be 1)
22:10:06 kernel: cx88_wakeup: 2 buffers handled (should be 1)
22:10:09 kernel: cx88_wakeup: 2 buffers handled (should be 1)
22:10:12 kernel: cx88_wakeup: 2 buffers handled (should be 1)
22:10:15 kernel: cx88_wakeup: 2 buffers handled (should be 1)

...every few seconds while watching TV with xine or other dvb-apps. The
event results in a visible interruption of the video stream.

Looking on the net for solutions, I found these suggestions:

- changing PCI latency in the BIOS settings

- putting the card into a different PCI slot

- using "pci=routeirq" or "pci=noacpi" kernel boot parameters

I tried all these, but it did NOT help.

So, where should I look for solutions now?

The system is an Intel 965 chipset mainboard, running a default Ubuntu
"Feisty" 7.04 with its stock kernel (package 2.6.20-15-generic).

The dvb card is fine, it works without these problems with a different
mainboard and the same Linux distribution.

Hope this info helps:

------------------------------------------

# egrep "CPU|cx88" /proc/interrupts

    CPU0 CPU1
23: 21861 407216 IO-APIC-fasteoi cx88[0], cx88[0], HDA Intel

------------------------------------------

# lspci -v

07:01.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video
and Audio
        Subsystem: Hauppauge computer works Inc. Unknown device 9002
        Flags: bus master, medium devsel, latency 64, IRQ 23
        Memory at 92000000 (32-bit, non-prefetchable) [size=16M]
        Capabilities: [44] Vital Product Data
        Capabilities: [4c] Power Management version 2

07:01.2 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and
Audio Decode
        Subsystem: Hauppauge computer works Inc. Nova-T DVB-T Model 909
        Flags: bus master, medium devsel, latency 64, IRQ 23
        Memory at 91000000 (32-bit, non-prefetchable) [size=16M]
        Capabilities: [4c] Power Management version 2

07:01.4 Multimedia controller: Conexant CX23880/1/2/3 PCI Video and
Audio Decode
        Subsystem: Hauppauge computer works Inc. Nova-T DVB-T Model 909
        Flags: bus master, medium devsel, latency 64, IRQ 10
        Memory at 90000000 (32-bit, non-prefetchable) [size=16M]
        Capabilities: [4c] Power Management version 2

------------------------------------------

Thanks for taking the time to report this bug. Unfortunately we can't fix it, because your description doesn't yet have enough information.

Please include the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at [WWW] http://wiki.ubuntu.com/KernelTeamBugPolicies. Thanks in advance!

Changed in linux-source-2.6.20:
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Hanno (sockpuppet) wrote :

Thanks!

> uname -a

Linux capella 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Hanno (sockpuppet) wrote :

> dmesg.log

Hanno (sockpuppet) wrote :

> lspci-vvnn.log

Hanno (sockpuppet) wrote :

...and just in case it helps you:

Thank you, I'm marking this as confirmed.

Changed in linux-source-2.6.20:
status: Needs Info → Confirmed
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
Hanno (sockpuppet) wrote :

Hi. Out of curiousity, I tried using the "2.6.22-7-generic" package for the next Ubuntu on this system.

The system is still the same Feisty installation, only these three packages were installed additionally:

linux-image-2.6.22-7-generic_2.6.22-7.14_i386.deb
linux-restricted-modules-2.6.22-7-generic_2.6.22.2-7.2_i386.deb
linux-restricted-modules-common_2.6.22.2-7.2_all.deb

This didn't help to solve the problem, either. Bug remains the same.

Pete (pete123) wrote :

My main mythtv server runs SuSE still, (2.6.18.2-34-default) and I'm also experiencing the same problem (kernel: cx88_wakeup: 2 buffers handled (should be 1)) so I'm doubting its Ubuntu specific.

Pete (pete123) wrote :

As requested by Hanno, specs of my backend

Pete (pete123) wrote :
Hanno (sockpuppet) wrote :

Hi Pete,

I had expected that my problem might be chipset-specific, but you are using a totally different chipset and a different CPU than I do. This is interesting and appears to be proof that it's not the mainboard or the core2duo.

Will ask upstream once again. Maybe some of the DVB driver developers will respond this time.

Pete (pete123) wrote :

Hanno,

That is what I was expecting you to think after reading the bug report, but I thought it would be helpful to let you (and others) know that it is not. I originally thought the problem with skipping video was due to the system being underpowered for 3 tuner cards but that is definitely not the case with your setup.

Hopefully some progress will be made this time.

Changed in linux-source-2.6.20:
status: Confirmed → Triaged
Hanno (sockpuppet) wrote :

Pete, on the Linux-DVB mailing list, another user says he has the same message, but appears to see no problems (no video skipping) on his system:

http://www.linuxtv.org/pipermail/linux-dvb/2007-July/018884.html

Do you see any video skips when the message pops up?

Hanno (sockpuppet) wrote :

Reported to mcentral.de - a forked linux DVB driver project - by request of its maintainer.

http://mcentral.de/wiki/index.php/Bugtracker#cx88_wakeup:_2_buffers_handled_.28should_be_1.29

Pete (pete123) wrote :

I read the posts on the linux-dvb mailing list earlier and noticed that. This is the reason why I was looking for a bug / going to report it in the first place, due to it being unwatchable because of the skipping sometimes.

In short, yes, the video skips a lot.

sparky64 (mail-ae-electrical) wrote :

I am having same problems , Also having occasional stutters in picture (May be due to poor signal as main tv has same problems but a lot fewer)
Logs attached
uname -a

Pete (pete123) wrote :

I have since moved that server from SUSE to Ubuntu Feisty recently. At the same time I changed the wiring setup to that machine also. Previously it was one cable from an amplifer simply split with a block, this is now changed this to three separate cables from the amplifier (one per tuner). In my case this is no longer a problem at all, perfect reception all the time.

Maybe this is something someone else can consider trying, it might just be as simple as bad signal, seems to have been in my case. (I presume it was not the switch from SUSE) Sadly I was unable to try the new wiring setup with SUSE. Note, none of the other hardware changed in the machine, just Ubuntu swapped in instead of SUSE.

sparky64 (mail-ae-electrical) wrote :

fitted new arial for computer/tv and now have signal strength of 10 (as high as it go's.
It has cured the picture freeze etc but still get the same error of 2 buffers.
Also tried a video recorder and had the same error.
Tried the live version of mandriva with no problems as well as edgy.

Tim Johnston (tjston) wrote :
Download full text (11.3 KiB)

I also have been having a problem with console messages:

cx88_wakeup: 2 buffers handled (should be 1)
cx88_wakeup: 4 buffers handled (should be 1)

every second or so, and at the same time, VERY jerky video with mythfrontend, and 2.6.20-series kernels, Most recently with 2.6.23.1. My tv card is branded DVico Fusion DVB-T Plus. dmesg, and lspci -vv shown below

So I went BACK to kernel 2.6.19.1, and no more console messages !! But video still VERY jerky with mythfrontend. Unwatchable. The utility "top" shows that mythfrontend is tying up 90-99% of cpu time. Hence why the jerky video, I suspect.

But Kaffeine runs fine, 15-20% of cpu time, and smooth video playback. Some video artifact in fast-motion scenes, but really quite acceptable.

The system is a P4 with 1GB RAM, asus main board. I have trolled google at length for a solution, but to no avail, so I thought that I would tack on my experiences to this thread as further evidence that there is indeed a bug somewhere. Hopefully someone will find it in due course.

Other factors: I'm in Australia. Some of the threads that I've seen mention that there digital tv transmission here is different somehow.

dmesg says:

CORE cx88[0]: subsystem: 18ac:db10, board: DViCO FusionHDTV DVB-T Plus [card=21,autodetected]
TV tuner 4 at 0x1fe, Radio tuner -1 at 0x1fe
cx88[0]/0: found at 0000:02:0e.0, rev: 5, irq: 10, latency: 32, mmio: 0xdb000000
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
PCI: Enabling device 0000:02:0e.2 (0014 -> 0016)
ACPI: PCI Interrupt 0000:02:0e.2[A] -> Link [LNKC] -> GSI 10 (level, low) -> IRQ 10
cx88[0]/2: found at 0000:02:0e.2, rev: 5, irq: 10, latency: 32, mmio: 0xda000000
cx88[0]/2: cx2388x based dvb card
DVB: registering new adapter (cx88[0]).
DVB: registering frontend 0 (Zarlink MT352 DVB-T)...
cx2388x blackbird driver version 0.0.6 loaded

lspci -vv says:

00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 11)
        Subsystem: ASUSTeK Computer Inc. Unknown device 8088
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0
        Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [e4] Vendor Specific Information
        Capabilities: [a0] AGP version 2.0
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>

00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 11) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: dd000000-dfdfffff
        Prefetchable memory behind bridge: dff00000-f7ffffff
        Secondary status: 66MHz+ FastB2B+ ParErr- DEVSEL...

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

AceLan Kao (acelankao) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - http://www.ubuntu.com/getubuntu/download. If the issue remains in Jaunty, please test the latest upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers